Help! Problem with inno3d 7600 gs

By maddict
Aug 26, 2006
  1. Hi guys,

    I've recently bought an Inno3d 7600 GS card for my system. I've fixed it in my system and installed the provided drivers. After rebooting windows I realize there's a certain lag when entering windows. The lag is minimal...maybe around 2-3 seconds. Then i started playing Doom 3. Doom 3 works fine for me (except for the small lag).

    Then i moved on to playing Call of Duty 2. In the game while moving, a serious lag occured. After the lag my system totally freezes and shows a BSOD for nv4_disp. I restarted my system and tried to play Rise of Legends. While playing i realize there are random pixels in the game (straight brown or grey line across the screen, missing human body, etc). Then while scrolling the game, it lags ( at first only a small lag). The lag then increases to a point where the entire game totally freezes and then my system automatically restarts itself.

    I need to know if my system can support this 3d card. I'm thinking maybe my system is too old to support this card. Probably the AGP slot of 4x can't support the 3d card's 8x achitecture. Here's my specs:

    Processor: Intel Pentium 4 (Northwood) 2.4 Ghz
    Mboard: MSI 651M Combo (Bios: SiS-651-6A6IXM4OC-00, Chipset: SiS64X/65X)
    AGP Slot: V2.00, Speed 4x, Fast Write DIsabled. Aperture Size 128MB
    RAM: 768MB
    Hard Disk: 200GB, 40GB

    Please help. Really need to fix my 3d card soon.
  2. Mr47

    Mr47 TS Rookie Posts: 17

    I would blame it on the mobo. 4X agp isn't the best with such a strong card.The old SiS chipset doesn't do much good with nVidia cards either.Try enabling Fast Writes, and try other drivers.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...