TechSpot

How to get broadband preference over dial-up connection

By jobeard
Sep 22, 2005
Topic Status:
Not open for further replies.
  1. My DSL connection works great and for occasions where I need to dial-in,
    I've also got a dialer and related config to dial-up as well.

    However, the first attempt after booting to connect to the Internet attempts to
    use the dial-up instead of seeing the existing hispeed connection already established. I have to cancel the prompt for dialing, and then wait for the
    hispeed Ethernet to be seen -- annoying.

    In Win/98 the tcp stack could be shuffled up or down, but in XP/Home ed,
    I don't see how to make the Ethernet have preference.

    Any ideas?

    tnx, Jeff
     
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,552   +301

    In the Internet Options control panel, make sure that is set to "Dial whenever a network connection is not present". Thats how you keep it from dialing.

    But in your particular case, I don't think its Windows thats messing that up, I bet you have a program thats trying to load and connect to the internet on startup, and it may have its own agenda in its prefs on what connection to use.
     
  3. mailpup

    mailpup TS Special Forces Posts: 8,442   +220

    I have a dial up at home and I set it to "Never dial a connection." It will still dial a connection but only when I want it to like when I click on the ISP icon. This will prevent other programs, including some games, from automatically trying to dial up the internet when they load.
     
  4. jobeard

    jobeard TS Ambassador Topic Starter Posts: 13,426   +317

    Yep, that's what is peculiar; the option IS set already. :suspiciou
    The programs that cause this are my email client or firefox, either of which
    are the first things I'll run after boot.
    The dialer will popup with a dialog to dial out or cancel, which of course I cancel.
    Then the hispeed takes over correctly

    I am half-tempted to delete the dial-up altogether.
     
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,552   +301

    If it does it before you fire up email or firefox, take a look at run -> msconfig and see if there is any nasties in there you don't want auto loading that might want to dial in.
     
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    From in the same properties area of IE, you could run the Internet Connection Wizard and set it to the highspeed connection. Then maybe that option will work?

    But Firefox, I don't think, would obey IE's options, and may have its own somewhere.

    Set the dialup to Never Dial. And if it still tries to dial, you know some program is directly calling it. Thus, SNGs suggestion.
     
  7. jobeard

    jobeard TS Ambassador Topic Starter Posts: 13,426   +317

    I was hoping to order the TCP stack such that if ethernet was inactive,
    the dial-up would jump in and make the connection (as was the case in Win/98)
    No such luck.

    The solution that does work is to manually DISABLE the dial-up and if the
    hispeed fails, go back and reenable dial-up. What a regression. :blackeye:
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.