TechSpot

Keyboard symbols and actual key strokes not the same

By 4seasons
Jan 21, 2005
  1. I've just done a complete re-install of Windows 98se. I have no spyware etc that I'm aware of. I've done several scans and have very good protection.

    My keyboard Language configured to read English/United States. The Layout is Unites States 101. In Windows things are fine. In DOS I can't type in the symbol ~
    Instead I get \
    Because of this there are certain simple functions I'm unable to perform such as tempor~1

    I tried using English (Canadian) as my Language setting with my Layout set at Canadian Standard but it kept reverting to Canadian Multicultural while in Windows, EVEN when I went into the Registry and made sure I changed the correct key value.

    I've just tried another keyboard and it's doing the same thing so I know it's not a hardware thing. Could it have something to do with my BIOS? Or is there some other simple setting I'm missing? Sure hope someone might be able to help.

    4seasons
     
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Does the chosen language match your keyboard?
    Sound like you use a UK-keyboard with US-language or the other way around.
    A US-keyboard has a @ above the 2, and # above the 3.
    A UK-keyboard has a " above the 2, and £ above the 3.
    There are a bunch more differences but these are the easiest to spot.
    You can change this in Control Panel/Regional Options
     
  3. 4seasons

    4seasons TS Rookie Topic Starter

    keyboard is U.S. with # above 3 and % above 5 and ^above 6 etc. It's a Microsoft product sent from Dell, USA. It was working just find before my computer crashed a week ago. I could type commands using the symbol ~ in DOS mode without any problems.

    I'm trying to figure out if there is some little box somewhere that I've left unchecked or it's checked and shouldn't be.
     
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Check if there is a line in your Autoexec.bat that has the command keyb.com in it.
    For the UK/Ireland this would be: keyb.com uk,,keyboard.sys
    replace the UK with US if you want to try it out.
    For the US there should not be one, as US English is default for English DOS, W98, W2K, XP etc.
    Try out all the 'funny' characters on the various non-alphabet keys BELOW the qwerty-line. One of them will have it. Just remember where if you need it, until you sorted your keyboard drivers.
     
  5. 4seasons

    4seasons TS Rookie Topic Starter

    The only line I can see is:

    C:\>keyb cf,,C:\WINDOWS\COMMAND\keybrd2.sys

    Any significance?
    What is the cf ?
     
  6. patio

    patio TS Maniac Posts: 482

    cf designates Canadian French...
    Use notepad to edit it to us and you're good to go.

    patio. :cool:
     
  7. 4seasons

    4seasons TS Rookie Topic Starter

    Thanks Patio,

    I'm very new at that procedure, please explain exactly what it is I have to do. Leave no steps out if you don't mind.
     
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    change that line in autoexec.bat from:
    C:\>keyb cf,,C:\WINDOWS\COMMAND\keybrd2.sys
    into
    rem C:\>keyb cf,,C:\WINDOWS\COMMAND\keybrd2.sys
    (rem AND a space)
    save the file, then reboot. Problem solved.
    You may want to do the same on your boot-floppy.
     
  9. 4seasons

    4seasons TS Rookie Topic Starter

    realblackstuff~

    Actually, I followed Patio's adice. I managed to figure out how to make the change using notepad. It was a piece of cake. All I had to do was open notepad, and open autoexec.bat. I changed the cf into us and it worked.

    Thanks for taking the time to answer my questions realblackstuff. Hope I can return the favor sometime.


    And Patio THANK YOU!!
     
  10. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I don't quite agree. the US parameter is not meant to go with keybrd2.sys, but with keyboard.sys
    You should do as I suggested, or delete that keyb-line altogether.
     
  11. 4seasons

    4seasons TS Rookie Topic Starter

    "or delete that keyb-line altogether."

    I don't understand. What part of the keyb-line should I delete? Not being one who understands the relationship between DOS and Windows very well, wouldn't deleting what you're suggesting affect the characters in some way. Isn't that line in the Autoexec.bat file there for a reason??
     
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Your initial PC (or software) must have been setup for French-Canadian language and/or keyboard, hence the LINE with the keyb command in it.
    By putting "rem " in front of any line, that line will be ignored, which is basically the same as if that WHOLE line was NOT there.
    Now that you have a US-keyboard, and US software, there is no longer a need for a keyboard control-program, because (as I said already), the default is US-English.
    If you are happy with the current situation and it works, fine, but you don't need it, so why have it?
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...