TechSpot

Low FPS in Wolfenstein Enemy Territory

By amtoxic
Sep 12, 2010
Post New Reply
  1. I've been getting a steady 125 for the past year or so. Yesterday, I was playing normal for about an hour. Then I dropped to about 60FPS out in the open, and was maintaining a steady 125 in tight areas. I know this isn't really a place to talk about specific games, but i thought I might try =/

    3.06GHz CPU - Single thread - not hyperthreaded
    256MB ATI Radeon 9250 AGP

    I've tried many things, including disabling AA, and optimizing the graphics drivers for highest performance. I even tried to overclock it, which I didn't get very far with. That video card is a POS when it comes to overclocking!
     
  2. Relic

    Relic TechSpot Chancellor Posts: 1,392   +16

    Man W:ET was a great game, remember playing it often years ago and had a blast with friends. In any case your specs for this game at least should be plenty. I'd normally say make sure you have the latest drivers and update them if need be, but I'm not sure you even can anymore =D. So my advice would be try cleaning out your PC, make sure if you installed something recently that it isn't running in the background and for that matter turn off any unnecessary programs and give your PC a defrag. Most of that should improve overall PC performance and might help your in-game frames.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.