Mobo Fried?

By II WinDScaR II
Sep 2, 2005
Topic Status:
Not open for further replies.
  1. I hooked everything according to the manual and power up then it turns off.Now it won't come back on. WTF?

    Parts:
    ECS 651C-M Socket 478 SIS 651 Micro ATX Intel Motherboard
    XFX PVT44AWAMG Geforce 6200 256MB DDR AGP 4X/8X Video Card
    Deskstar 61.4gb HDD
    RAIDMAX RX-420K ATX12V 420W Power Supply 100 - 240V TUV, UL, CSA, CE, FCC, CB
    Samsung 512mb PC2700 DDR
    MIC CD-RW/DVD Rom Disk Drive
    H-L CD-RW Disk Drive
    intel Celeron 2.70ghz processor
    windows 2000 OS
  2. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,565

    Can you give a more detailed description of what is happening? When it was turning on, how far along did you go before it would turn off?

    Now that it won't turn on, what does it do? Do you have any lights on the motherboard? When you hit the power button, do the fans spin? Any beeps?

    First thing that came to mind is that your motherboard is shorting out on your case. Did you use the riser pins when you installed your motherboard?
  3. zephead

    zephead TechSpot Paladin Posts: 2,483

    you should be aware that you have an ecs motherboard, which like nearly all other ecs products, is basically crap. not only is your particular board low in quality, but it's performance is low too. therefore it is susceptible to failure not unlike what you are experiencing. just consider this possibility...
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.