TechSpot

motherboard not working. computer not getting on

By d2a2d
Jul 19, 2005
Topic Status:
Not open for further replies.
  1. HI,

    I have P4 1.7Ghz computer with Amptron motherboard. My computer is not getting turned on. It just died after showing black screen. I checked it by replacing it power supply and processor. they are fine. nothing wrong with power supply neither the processor. I also checked RAM and batery on the motherboard. they are also fine. when i try to turn on the computer the only thing happens is just one rotataion of processor fan and thats it. NO led lights come on or the power supply fan ...

    ANY HELP!

    JA
  2. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 1,382

    Hello! Welocome to TechSpot

    Have you pulled the MoBo out of the case and checked it over
    for any shorts or burn spots?
    It does, however, sound like the "pretty blue smoke" got out. :(
    G'Luck
  3. zephead

    zephead TechSpot Paladin Posts: 2,483

    i'd expect as much from an amptron, given thier poor quality. let's hear some more about the rest of the computer, especially the power supply, which is another prime suspect.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.