TechSpot

My hard drive is not recognized by "My Computer"

By Turn
Feb 7, 2006
  1. Hi, my new hard drive (Hitachi Deskstar 120GXP) is recognised properly by the BIOS at start-up, shows up properly in the Device Manager but does not appear in "My Computer", i've tried different settings in BIOS, such as "Auto", "LBA", "CHS" but i still can't find it in "My Computer". I use Win XP. What should i do?

    Please Help
     
  2. JMMD

    JMMD TechSpot Chancellor Posts: 854

    Have you initialized it yet? You need to go into Disk Management and initialize it, create a partition and then format it.
     
  3. Turn

    Turn TS Rookie Topic Starter

    Yes, I have. I've already format it and there is already data on it, cause i've used it at one time, then i had a reboot and now 'My Computer' can't find it no more.

    In Disk Management its known as "Disk 1", my system disk as "Disk 0" and my other HDD as "Disk 2". There is no letter in front of the 80Gb, which 'My Computer' can't find.

    This is how it looks like:
    http://server3.pictiger.com/img/139294/other/80gbdeskstar.php
    (Swe OS)
     
  4. JMMD

    JMMD TechSpot Chancellor Posts: 854

    Just right click on it and add a drive letter.
     
  5. Turn

    Turn TS Rookie Topic Starter

    Thats impossible. The only alternativ i've got is "Delete Partition".
    The rest of the alternativs are not highlighted.
     
  6. JMMD

    JMMD TechSpot Chancellor Posts: 854

    What options do you have if you right-click in the area where it says Disk1.

    The other thing that's weird is the capacity field is incorrect. It says 76GB under Disk1 but 39GB under the drive listing at the top of the screen.
     
  7. Turn

    Turn TS Rookie Topic Starter

    If I right-click in the area where it says Disk1 i got two options; "Delete Partition" and "Help".
     
  8. loupegarou

    loupegarou TS Rookie Posts: 39

    previous xp hard drive?

    is this a hard drive from a previous xp install?

    Does it say "Basic Disk" in the area where it says hard drive 1?

    Have you done a Bios update?

    Sorry for all the questions just trying to see where you are.
     
  9. alidabiri

    alidabiri TS Rookie Posts: 441

    first, back up your data.
    auto in bios sounds ok.
    how did you initialize it?
    xp wants you to initialize it in xp, so it will know it created the partition, etc..
    when it says delete partition, do it,
    then it will prompt you to name a letter on it.
    just back up your data before you do it.
     
  10. alidabiri

    alidabiri TS Rookie Posts: 441

    get a 98 floppy boot disk from www.bootdisk.com
    start your pc with boot disk in the machine
    go to bios, and tell it to start boot from floppy first
    after win98 comes up, enter fdisk
    display partition(s) (if any)
    delete partition(s)
    create new partition
    restart
    format the hard disk
    turn pc off
    take win98 boot disk out
    start pc
    go to bios to see if your hard disk is recognized
    let xp start
    go to disk management and name your drive.
     
  11. Turn

    Turn TS Rookie Topic Starter

    No, this is not a hard drive from a previous xp install. It says Disc 01, thats it.

    I have not done a Bios update, guess it wouldn't hurt to try doing that aswell.

    The thing is, that this HDD got major amounts of data on it, and for that matter i'm not so happy about deleting the partition, but i guess there is no other way this time, is it? :(

    When using Partition Magic, the prog said "Type 44", thats it. I could not change the drive letter, i couldn't basically do anything except delete the partiotion.
    Thanks guys for your support, i really really appreciate it!
     
  12. JMMD

    JMMD TechSpot Chancellor Posts: 854

    WAIT, don't delete the partition. Use a recovery tool like GetDataBack. It'll be able to recover your files and move them to another drive.
     
  13. Turn

    Turn TS Rookie Topic Starter

    'GetDataBack'...thanks i'll try with that. Perhaps it'll work.

    EDIT: I did everything you told me to do and i got EVERYTHING back. I'm so happy i could cry right now, thanks a million for all the help!
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...