TechSpot

My new built PC won't connect to the Internet

By waterproof
Mar 17, 2011
Post New Reply
  1. This is how my setup looks like

    cable broadband > modem > switch > PCs wired connected to the switch, I can add PCs/laptop/friends laptop/my xbox no issue, it configures an IP address for the device and works on the go.

    Anyway, I am having an issue with 1 PC, which I built, they're not newly high ends one just good enough for my lil sister to play after school. It seems to don't want to connect to the internet. Network device is fine, LAN drivers installed properly along with updated drivers for the PC. I can actually view my network devices from my problem PC and see other PC media devices, so it's not a hardware fault that's for sure.

    I'm using Windows 7 64bit SP1 Ultimate



    Issues that was displayed
    * says i'm in unknown public location
    * Tried to IPCONFIG it > default gateway is blank, IP (ipv4) address is blank
    * did Local area connection settings to automatically obtain IP address as how it was default fine with my other PCs
    * Tried to ping to my default gateway says 'transmit failed: general failure'
    * Also tried to reset the network stack, didn't work
    * Tried bypassing the switch and and just directly connecting the modem - same issue


    Anyone could help me with this issue? Thank you would be much appreciated!!!
  2. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,892   +86

    Not my area of expertise, but these have solved connection problems for me in the past.
    Are you configured for DHCP?
    and have you also tried:
    ipconfig /release to terminate any active TCP/IP connections

    ipconfig /renew to re-establish a connection?


    Here is some more info on these command line utilities if you have not seen it yet
    http://compnetworking.about.com/od/workingwithipaddresses/a/ipconfig.htm

    hope it helps
  3. waterproof

    waterproof TechSpot Enthusiast Topic Starter Posts: 235

    tried it buddy, here's the screenshot of the problem pc http://i55.tinypic.com/8vuon5.png

    also the network connection, it says 'undentified network'.. public

    know what that means?
  4. waterproof

    waterproof TechSpot Enthusiast Topic Starter Posts: 235

    Anyone can help? why was this moved to networking? its a OS issue
  5. waterproof

    waterproof TechSpot Enthusiast Topic Starter Posts: 235

    screenshot of the troubled PC

    [​IMG]

    Anyone can help? seriously man.. its bugging me off


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.