Network driver for Gigabyte Mobo

By jdillman1502
Jan 12, 2009
  1. I need to find a network driver for the onboard NIC on a Gigabyte Ep43-ds3r Mobo. I have tried the driver off the cd that came with, tried the driver from Gigabyte's website, and even the driver from Realtek website. None of them will work. The pc picks it up as a Realtek RTL8168C(P)/8111C(P) PCI-E Gigabit Ethernet NIC. I dont know if the computer is ID'ing this NIC wrong or what. Im also not sure why it shows as a PCI-E NIC when it's the onboard. Any help would be very much appreciated.

  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    According to your manual RTL8111C is what you have.

    It shows up as PCI-E because it connects to that bus.

    Try this install procedure;

    To install drivers from the internet:

    go into Windows Explorer, left click on Desktop, then File, then New and then Folder - name the folder XXXDrivers (where XXX = type, eg, AudioDrivers)

    go to the site for your driver, find the RIGHT one for your mobo and OS,(click on the nearest site to you if appropriate) and then download button - when asked where to 'save' the download specify your desktop folder XXXDrivers and wait until the download is complete.

    Once it is done, clear your screen and click on the desktop folder and then on the file inside - if it is a zip or rar file it will need to be unzipped or unpacked - make sure if you are asked to specify where to unzip/unpack to tell it to do so to the XXXDrivers folder.

    Once you are done that, uninstall the old drivers for the device and then select the device and specify update drivers and direct the search to the folder you made (don't let Windows do it).
  3. jdillman1502

    jdillman1502 TS Enthusiast Topic Starter Posts: 120

    After more research, I believe the issue is related to Windows files. I bought a brand new network card and I have the same problems. After going through the install process I get a message telling me "The system cannot find the specified file." I am also unable to uninstall the devices. The pc tells me "The device may be needed to boot the computer" and won't let me uninstall. I'm thinking I may need to just reinstall at this point. If you have any other ideas, let me know.

  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Check your bios and see if wake on lan is enabled - if so, disable it.
  5. jdillman1502

    jdillman1502 TS Enthusiast Topic Starter Posts: 120

    I ran a repair on Windows using the installation disc and it took care of the issue. Thanks for your responses.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...