TechSpot

On the verge of shooting myself with this Limited or no connectivity BS

By harrisdurrani
Jun 11, 2009
  1. If someone could please help me i would REALLY REALLY appreciate it.. and wouldn't be able to thank you enough.

    First some general info

    1) I am connected to the Internet through my Wireless Laptop.
    2) Whenever i connect another router or my Xbox 360 with the God Dam ethernet it keeps saying limited or no connectivity and shows the IP in 169.252.xx.xx ... what do i do .. this is really annoying.. i have tried everything possible, reinstalled drivers like 3 times, disabled and enabled the ethernet.

    This is what i am getting when i do an ipconfig /all

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Harris Durrani>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : sonic-434c3ecf2
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : cogeco.net

    Ethernet adapter Wireless Network Connection 2:

    Connection-specific DNS Suffix . : cogeco.net
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Networ
    k Connection
    Physical Address. . . . . . . . . : 00-1B-77-E2-2C-19
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.0.105
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DNS Servers . . . . . . . . . . . : 192.168.0.1
    Lease Obtained. . . . . . . . . . : Thursday, June 11, 2009 2:26:16 AM
    Lease Expires . . . . . . . . . . : Friday, June 12, 2009 2:26:16 AM

    Ethernet adapter Local Area Connection 8:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethern
    et
    Physical Address. . . . . . . . . : 00-1D-72-09-50-96
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.57.217
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    DNS Servers . . . . . . . . . . . : 192.168.0.1

    This is really frustrating.. someone please help..

    thanks
     
  2. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

  3. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Did it work at one time, or is this a problem that came up as part of a new install?
     
  4. jobeard

    jobeard TS Ambassador Posts: 9,098   +592

    from what you posted, you have TWO adapters
    1) Wireless which has a good set of ipconfig info
    2) Wired Broadcom which has the 169.* stuff and likely not even connected

    Windows does not support multiple connects like this; DISABLE the Broadcom device
    and the issue should solve itself :)

    My laptop is normally Wired at home but needs Wireless when traveling -- had the some kind of misleading info. Use the Device Mgr to disable the interface that is NOT
    needed at the time.
     
  5. harrisdurrani

    harrisdurrani TS Enthusiast Topic Starter Posts: 159

    Thanks for the insight..

    i actually solved the problem in a rather stupid way .. i deleted xp and installed Vista, bridged my ethernet with my wireless connection.. and it works lol.. now i can play xbox live and have started sharing movies, music etc from my PC to my 360 using tversity..

    I think it was more to do with Xp service pack 3 !! i don't know! but its working fine now!! thanks to Vista lol
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...