Pioneer DVD-RW DVR-K14 Issue

By thedeadpoet
Jul 6, 2006
  1. I have an issue with my Pioneer dvd-rw dvr-k14 where it reads cd-roms but wont read cd-r's, cd-rws, dvd-r's or dvd-rw's ect and therefore I cant burn cd's.

    I used to use Memorex 52xMultiSpeed CD-Rs which worked perfectly but now even they refuse to read.

    Infact I cant even run Diagnostic Programs such as Nero CD-DVD Speed to find out the specs.

    I didnt get any software with my computer (a VAIO PCG-9S2M) as everything was installed onto it prior to my purchase so I cant reinstall the driver.

    I'm aware that its probably possible to find these drivers elsewhere but I'm not sure if this is what I should be doing.

    Any advances are greatly appreciated.
  2. N3051M

    N3051M TS Evangelist Posts: 2,115

    you can try reinstalling the burner's drivers by:

    Right click my computer>properties>hardware tab>device manager
    Locate the tree with dvd drive, expand it. Find your dvd drive, right click and uninstall.
    Reboot your machine and let windows find the drivers again by itself.

    if that doesnt work, and you've tried different brands of media, you may also want to take a look to see if there is any firmware updates for your dvd drive.
  3. thedeadpoet

    thedeadpoet TS Rookie Topic Starter Posts: 16

    Appreciate the advice mate.

    I'll look for a firmware update for the drive and install that first before reinstalling the whole thing.

    I'll come back if it dosent work.
  4. thedeadpoet

    thedeadpoet TS Rookie Topic Starter Posts: 16

    How can I check what Firmware I have?

    And strangely enough, I cant find any drivers for dvr-k14...not even on the Pioneer Website :s
    So its a good thing I checked first before uninstalling the present one.

    Perhaps I should just send an email to pioneer explaining the situation eh?
    I mean if anyone will know, they will.

    Thanks for the help anyway man, appreciate that.
  5. iss

    iss TechSpot Chancellor Posts: 1,994

    ALL Optical drives use the native windows drivers so there are no drivers to download. when you uninstall the device or the IDE channel the drive si on and reboot windows automatically reinstalls the driver when windows restarts.

    what you need to look for is FIRMWARE.
  6. thedeadpoet

    thedeadpoet TS Rookie Topic Starter Posts: 16


    So I'm going to uninstall the driver and reboot, and basically what you're saying is the issue should resolve itself?

    Lets hope so.

    I'll keep you posted anyway.
  7. thedeadpoet

    thedeadpoet TS Rookie Topic Starter Posts: 16


    So I've uninstalled the driver and rebooted windows.
    Windows boots up normally, I log into my account and I reach my desktop.

    So I go into control panel>system>hardware>device manager and as expected my drive is uninstalled.

    Then I click add new hardware, and it gives me a list of devices to choose from and on the list is PIONEER DVD-RW DVR-K14.
    I choose this, wait less than a minute and I'm told 'this device is working properly, click finish to exit.

    Naturally I follow, insert a blank cd-rw, then a cd-r, and it wont read.
    Alternatively I open My Computer and recieve an error message reading 'Please insert a disk into drive F:'

    I try a dvd-r and I'm told 'F:/ is not accessble, Incorrect function'

    Sweet Christ.
  8. iss

    iss TechSpot Chancellor Posts: 1,994

    from what you describe I would say that your burner is faulty. none of what you posted should have occured. the Drive should have automatically been detected and the drivers automatically installed when windows restarted. the fact you had to use new hardware wizard would indicate that the drive or the IDE cable it is on is defective.
  9. N3051M

    N3051M TS Evangelist Posts: 2,115

    I second iss's statement.. you'll need to open up your pc, unplug the IDE cable (flat ribbon cable) and replace with another one or one you know works. That way we can tell for sure that it is the cable or the drive being at fault. Also make sure that there is power going to the drive by maybe using a different power molex on it..

    Edit: is this drive a laptop drive? i've just looked it up, and it is for OEM pcs, in which case you will need to visit their website to see if there is any firmware updates..
  10. boogiedood

    boogiedood TS Rookie

    Hey, I had the exact same problem you did on my HP dv1000 laptop. My problem to be exact, was that whenever I put in a disc and tried to read it, it would tell me to "please insert a disc" message. I was able to fix this with a firmware from the HP website that was labeled sp30367 . So I'm assuming you can try and find this on the Sony website and install it yourself. Hope this helps.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...