TechSpot

Please help - Cisco 2611 IOS 12.0

By Canadian
Mar 24, 2009
  1. To whomever is reading this thanks, and I hope you can help my with my problem.

    I am currently attending a local college and taking a Cisco class right now. I decided to buy an old Cisco 2611 router for home so I can play around with it to learn on my own.

    I am currently attempting to set it up in such a way that I could replace my regular Dlink router.

    Now the problem, I need the router to pull an IP Address from my modem on interface e0/0

    How do I do this? (Cisco 2611 IOS 12.0)

    The following is my show run (It is currently configured to work in the classroom, so the external IP addresses are all 192.168.1.x with internal as 192.168.0.x)

    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname BrianisGod
    !
    enable secret 5 $1$miAT$aw9wS8dvDeT3FexOVnz6D/
    !
    !
    !
    !
    !
    ip subnet-zero
    !
    ip dhcp pool pool1
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server 192.168.1.254
    !
    ip audit notify log
    ip audit po max-events 100
    !
    !
    !
    process-max-time 200
    !
    interface Ethernet0/0
    ip address 192.168.1.68 255.255.255.0
    no ip directed-broadcast
    ip nat outside
    !
    interface Ethernet0/1
    ip address 192.168.0.1 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    !
    interface Serial1/0
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    no ignore-hw local-loopback
    !
    interface Serial1/1
    no ip address
    no ip directed-broadcast
    shutdown
    no ignore-hw local-loopback
    !
    interface Serial1/2
    no ip address
    no ip directed-broadcast
    shutdown
    no ignore-hw local-loopback
    !
    interface Serial1/3
    no ip address
    no ip directed-broadcast
    shutdown
    no ignore-hw local-loopback
    !
    ip nat inside source list 1 interface Ethernet0/0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.254
    no ip http server
    !
    access-list 1 permit 192.168.0.0 0.0.0.255
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    password telnet
    login
    !
    !
    no scheduler allocate
    end
     
  2. cpetry

    cpetry TS Rookie

    Honestly, you're better off setting up a static IP address for that interface. Why you would want to use DHCP between two devices like that is beyond me.

    If you still want to try this:

    To configure Cisco IOS DHCP, follow these steps, which include sample commands:
    1.Configure an IP address on the router's Ethernet port, and bring up the interface. (On an existing router, you would have already done this.)
    Router(config)# interface ethernet0/0
    Router(config-if)#ip address 1.1.1.1 255.0.0.0
    Router(config-if)# no shutdown

    2.Create a DHCP IP address pool for the IP addresses you want to use.
    Router(config)# ip dhcp pool mypool

    3.Specify the network and subnet for the addresses you want to use from the pool.
    Router(dhcp-config)# network 1.1.1.0 /8

    4.Specify the DNS domain name for the clients.
    Router(dhcp-config)#domain-name mydomain.com

    5.Specify the primary and secondary DNS servers.
    Router(dhcp-config)#dns-server 1.1.1.10 1.1.1.11

    6.Specify the default router (i.e., default gateway).
    Router(dhcp-config)#default-router 1.1.1.1

    7.Specify the lease duration for the addresses you're using from the pool.
    Router(dhcp-config)#lease 7

    8.Exit Pool Configuration Mode.
    Router(dhcp-config)#exit
     
  3. Canadian

    Canadian TS Rookie Topic Starter Posts: 77

    So, I finally found the solution. Upgrade the IOS to a new version (I am using 12.3 now)

    Then, in the interface put in

    ip address dhcp

    That will result in the router pulling an ip address from your ISP.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...