PnP BIOS extension problems...

By sogan_dolma
Jan 26, 2006
  1. Hello guys...
    I was wondering if you could help with a problem I've been having. Occasionaly I get a BSOD and my system restarts. It is moderatly annoying, but I sure would like to keep it from happening all the time. The problem is due to certain faulty or missing drivers. In Device Manager the only thing wrong is the PnP BIOS extension.
    Clicking Properties shows:

    Windows cannot initialize the device driver for this hardware. (Code 37)

    Any suggestions?

    AMD64 3200+ (Venice core)
    ASUS 6600GT 128MB
  2. hewybo

    hewybo TS Maniac Posts: 435

    Try this

    This is on Micro$oft's website: Code 37
    Windows cannot initialize the device driver for this hardware. (Code 37)
    Recommended resolution

    The driver returned failure from its DriverEntry routine. Uninstall the driver, and then click Scan for hardware changes to reinstall or upgrade the driver.

    On the General Properties tab of the device, click Troubleshoot to start the Troubleshooting Wizard.
  3. sogan_dolma

    sogan_dolma TS Rookie Topic Starter

    Thanx, but...

    I did try uninstalling the drivers but my system completely froze. It took forever and I finally decided to restart. Sooo... I really don't know what to do next. I appreciate the help tho... :grinthumb
    I believe I could fix it if only I was able to uninstall and then reinstall the drivers...
  4. hewybo

    hewybo TS Maniac Posts: 435


    Have you gone to ASUS to be sure you have the latest drivers? Also, bring up the problem item in device manager, right-click it, then click troubleshoot. Maybe you'll find some info without having to freeze the system. I wish one of the smarter people would show up, cuz it sounds like a mobo problem to me, but I ain't very smart.

    Oh- have you gone into your BIOS to be sure the PnP setting is correct? Also, have you tried the event viewer to find out what warnings/errors are posted? :confused:
  5. TheHelper

    TheHelper TS Rookie

    1st things first back up your registry in case anything wrong happens. click start --> run ---> type in "regedit" into the open space -- click ok --> click on the 1st hkey (make sure its highlighted in Grey) --> click on file ---> export--> and save all the Hkeys to a place that you can easy get to. As for naming the file copy and past Hkey root under selected branch into file name and in the export range click on "All". --> Lastly click on save. Do this for all 5. Next step is simple. Go to -->
    Go to and click on the second option that says "cdgone reg" and save it. After it is saved click on it and it will ask you if you want to add this to your registery click on yes and your problem will be fixed it happened for me. Good luck. up your registry.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...