Possible ethernet adaptor corruption?

By Kev32
Aug 3, 2005
  1. This is just something I've come across whilst putting up a network in my house. I've just, for the first time, installed my LAN drivers for my built in Rhine II Fast Ethernet Adaptor (ABIT KV7 mobo). So after that I plugged it via a cat5 ethernet cable into the 10/100 HUB (which at the moment isn't connected to anything other than an XBOX until i get hold of some 15m cabling to connect it to another HUB). Anywho, whilst looking in the event viewer, under applications, I came across the message :

    The COM+ Event System detected a bad return code during its internal processing. HRESULT was C0000005 from line 44 of d:\qxp_slp\com\com1x\src\events\tier1\eventsystemobj.cpp. Please contact Microsoft Product Support Services to report this error.

    Now the strange thing is this message repeats itself each time I reboot until I either A) Disable the Rhine II Ethernet Adaptor OR B)Unplug the cable from my PC....then the error message vanishes. I've googled the search and I came up with a few sites. The most frequent pointed to :

    Only problem is Local Security Policies doesn't exist, either because I'm running XP Home or the fact my XP is oem.

    Of course I have yet to try the LAN with other PC's but I don't know, in my past endeavors a c0000005 error is usually not such a nice thing.
  2. Kev32

    Kev32 TS Rookie Topic Starter Posts: 75

    Ok so I've now linked my PC up to a HUB with another PC, unfortunately the two arn't talking to each other (can't even ping either PC). However I know they are recognising each other as there are events (in the event viewer) which prove that they are there. Only problem is that I'm getting an eventid:8003 at source:MRxSmb saying something about both PC's are the master browser and only one can be the master browser on a specific subnet. I have never had this problem so I'm not sure what it means.

    Also I only get this event on one of the PC's, it is also seeing the other PC as in workgroup computers it's icon comes up, only problem is that I cannot access it, it says the network path is unavailable. The other PC has no events to do with the network and cannot even access workgroup computers. Any help on both this issue and the one in my previous post will be appreciated. Thanks!
  3. zephead

    zephead TechSpot Paladin Posts: 1,569

    you have no router/gateway connected, why should they work?

    try updating your ethernet adapter's device drivers. check that cabling. it should be cat5 or better for reliable 100baseT operation, and it should be wired using the twisted pair scheme.
  4. zellyman

    zellyman TS Rookie Posts: 33

    Yeah you gotta get a router so that they can both get an address from a 3rd machine (the router) to create a network that they can communicate across.
  5. urbandragon

    urbandragon TS Rookie Posts: 231

    Sorry to disagree but you do not need a router... you are referring to DHCP which is one of the many services some routers can perform.

    The only thing he is going to have to do is configure the tcp/ip stack on each computer with a static ip address/subnet mask otherwise he will get an APIPA(automatic private ip address address)... anyone in the network field will know what i am talking about.....

    have you tried uninstall/reinstall of nic drivers.
  6. zellyman

    zellyman TS Rookie Posts: 33

    Allow me to rephrase then. To do it EASILY get a router. You plug stuff in, it works, no questions asked.
    (I AM in the network field, sheesh :p)
  7. Kev32

    Kev32 TS Rookie Topic Starter Posts: 75

    A router is precisely what I am getting in prep for the arrival of bband. At the moment though I have changed the IP addresses on both PC's to 192.168.0.x and have disabled the firewall. I personally think that this is my major problem though :

    The COM+ Event System detected a bad return code during its internal processing. HRESULT was C0000005 from line 44 of d:\qxp_slp\com\com1x\src\events\tier1\eventsystemobj.cpp. Please contact Microsoft Product Support Services to report this error.

    It always happens whenever I turn on the adaptor. Unless of course it's just my PC telling me that it's getting a bad return call from the network, as I don't get this error if the cat5 cable is unplugged from either my PC or the actual hub.

    I'll have a go with another HUB of mine, see if that changes anything.
  8. Kev32

    Kev32 TS Rookie Topic Starter Posts: 75

    Ok so updated all the 2 NIC's. Whats strange is that my one PC recognises the fact that the other PC is on the network. The PC's name is there in workgroup and yet when I select it it says ''Network Path not Found''. Both PC's also recognise that they are connected to a network they just simply will not communicate with each other, and it's not a problem with the HUB, just had 3 XBOX's linked to the very same HUB with no problems.
  9. tdeg

    tdeg TS Rookie Posts: 119

  10. ChineseTechie

    ChineseTechie TS Rookie Posts: 85

    I had the same problem too and it had to do with Norton Anit-Virus. For some reason, Norton AV blocked communication between the two computers connected through a router. I would think it's firewall or AV of some sort.

  11. Kev32

    Kev32 TS Rookie Topic Starter Posts: 75

    Tried rolling back the NIC drivers, and I don't have Norton but I do have AVG. Thing is, I used to use a wireless network card for my PC to connect to my other PC (which was connected to the very same HUB as I am using now, then connected to a WAP) but then I moved my room outside and could get no signal. So now I have created a 15m (Fully tested and operational) cat5 cable running from my room to the HUB. That link you gave me is where I first went, unfortunately I'm using XP Home which lacks ''Local Policies'' file. All I can think of is that my ethernet adaptor is configured incorrectly as this message points at a memory access violation. I will be trying with an external PCI NIC in about an hour so will see if that works. I doubt this problem has got anything to do with my other PC as that has used the same NIC on the same network for the past 3 years.

    By the way should I manually be using my own IP's? Since my dad taught me about networking I always setup a particular network with IP address 192.168.0.x and subnet

    Another quick question, I was wondering if anyone could verify that the setup I plan to create in the near future will work, I've attached the file.

    {EDIT} Just found in the BIOS that my ''onboard LAN boot ROM'' is disabled whilst Onboard LAN is enabled. Does this mean anything?
  12. Kev32

    Kev32 TS Rookie Topic Starter Posts: 75

    OK IT's WORKING! So what I did in the end was. I never got another PCI nic. Instead I got a HUB 10/100 put that in my room and did the following setup:

    My PC --- HUB ------ HUB (via uplink port) --- Other PC

    The network works perfectly now. However I am getting collisions in the HUB which is probably standard and doesn't mean anything as I'm currently playing music through my other PC and browsing it's files :cool:

    {EDIT} No more collisions, pushed the wire fully into the socket :p
  13. tdeg

    tdeg TS Rookie Posts: 119

    Yea, you need to use an uplink port or a crossover cable to connect 2 hubs.
  14. Kev32

    Kev32 TS Rookie Topic Starter Posts: 75

    Not to sure why this setup did not work :

    My PC ------------ HUB --- Other PC

    Perhaps it was because of the distance between the PC and the HUB (about 15-20m)? Anyway, I may rework the wires to act as a crossover wire, I heard that they have less collisions. I'm still getting a few occasionally, they don't do anything really.
  15. tdeg

    tdeg TS Rookie Posts: 119

    Double check your cables, maybe one of them is a cross-over cable and you didn't realize it.

    And 15-20m is nothing for ethernet if your cable is ok. You usually run into problems are you approach 100m.
  16. ChineseTechie

    ChineseTechie TS Rookie Posts: 85

    I thought for new hubs you don't need crossover cable. It would automatically detect what you are using and config. it to make it work.

  17. zellyman

    zellyman TS Rookie Posts: 33

    I know switches will do that , but maybe he just got a cheaper one that doent auto correct for it?
  18. Kev32

    Kev32 TS Rookie Topic Starter Posts: 75

    The network is running great at the moment. Just got off a LAN game with my bro on Warcraft 3 with absolutely NO LAG or any collisions. All the wires I am using are standard ethernet cables, no crossover ones. I'm using 2 HUBS with one connector in the uplink port of one HUB and in a standard port of another. It's weird, I've got 3 HUBS and only using the current 2 in unison does this network work, any other combination of HUBS fails to work....The one I'm using at the moment is fairly new though (2002) and the others are like 1998 and 1999.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...