PowerPoint picture placeholders exhibiting erratic behavior

  1. Our corporate PowerPoint 2003 template makes extensive use of picture placeholders. Someone came to me with the attached slides and the complaint that after placing pictures and saving the file, the next time they open it, the pictures are not visible or have changed positions seemingly at random.
    The missing pictures are in fact hidden behind other pictures, in the case of the second slide all three are in that first position. First thing I tried was right click, Reset Slide. That causes the pictures to jump into the three positions, but when you save and re-open, they are stacked again. When I reset the first slide, I'm seeing the three images, but also the placeholder with "click icon to add picture" in one case on top of the picture, which I've never seen.
    Is the problem the fact that the placeholders are overlapping on the slide, so PowerPoint can't keep them straight? When I recreated this same layout in a fresh presentation, it behaves fine. Is this file somehow corrupt? Or are picture placeholders just unreliable? Any suggestions for a workaround or fix?
  2. NigelAnthony

    NigelAnthony TS Rookie

    I have seen this happen before, but not quite to the extent of the issues you're seeing. I've also not seen it happen when you close and reopen a file. But I have seen it happen when you hit RESET, and I've seen it with text placeholders as well as with picture placeholders, and I've even seen it happen before the template hits the wild.
    I believe it's got to do with the idx setting in the XML. In the case of your file, the picture placeholders all have the same IDX value (19). I think this is confusing PowerPoint and causing it to reapply the settings from the first picture placeholder with IDX value 19 -- which is why they all end up stacked on top of each other. (In one of the problem files I saw, the idx value kept switching -- it was the most bizarre thing, and I think it was actually a bug.)
    If you create a new layout with new placeholders, as you discovered, it behaves as you'd expect.
    I think something's happened to this layout -- actually, to these placeholders -- to make them corrupt, but I can't tell you what that is. I'd imagine the placeholder was copied from another file, but I don't think that completely explains it. (Looks like your problem placeholder(s) have UK English attached to them, whereas the rest of your file uses US English in case that gives you a hint. The fact that the layout is named 3 columns with pictures is a bit suspect as well.) I sometimes wonder if some versions of PowerPoint have more problems with these things than later versions. (PowerPoint 2007 comes to mind, but I've no concrete evidence for why that would be a problem in this particular situation.)
    I'd probably recreate the layout with new picture placeholders and send the person a new template. Have the user create the slide in the new template and paste it into their existing deck. They may need to choose "keep source formatting" when they paste the new slide, otherwise the old layout may take over.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...