TechSpot

Printer won't power on, tried everything

By Mugsy
Jul 5, 2011
Post New Reply
  1. John407

    John407 TS Rookie

    I have a Canon Pixma MG8210, I had a similar issue... our power dipped for a moment, the printer turned off and would not power back up. I read through the thread above and turned the printer over to remove the power supply. I needed to run out to my garage to get a hex wrench so I turned the printer right-side up and on a hunch hit the power button. It worked just fine. I have no idea why their printers do this, but it is very easy to fix with the proper technical skills ;)
     
  2. spacerman

    spacerman TS Rookie

    I have the same problem as Magiceye. Pixma MP610: When I press the power button it lights up for a nano second then shuts down again. I tried Timroperco's solution but still nothing.
     
  3. ScrappyLaptop

    ScrappyLaptop TS Rookie

    Didn't work here, but I have a 30314 power supply. There are fuses, btw (the giveaway on mine was the "Caution: replace fuse with same type and rating" message silkscreened on the bottom. On the component side there were three black blocks labeled F1-F3, w/ ratings of 2A & 2.5, 240v. Unfortunately for this PS, all are good. Voltage ratings are -11v and -9v on the green and orange, respectively. Rating on the case is 32v @.75A and 24v @ 0.5A. Ebay, $16.
     
  4. LizzyP

    LizzyP TS Rookie

    Hi Timroperco
    I've been reading these posts with avid interest. I have an A3 canon pixma ix6550 which is not quite a year and a half old. Just as I was about to send something to print it just went dead. I've tried all the usual things like checking the power supply etc, but nothing. Have spoken to canon and it could potentially cost me virtually the same amount as the printer cost! Do you think I could try the same tips for the IP4500? I am no techie, but I suppose I've got nothing to loose, but wanted to check in case I've missed something glaringly obvious!
     
    bectech likes this.
  5. Jan Bladh

    Jan Bladh TS Rookie

    I have been testing my IP4700, since it suddenly stopped working. I found that the power supply, with its 5 pin socket has a control signal from the Main logic board. Others have noticed that instead of +24 and +32 Volt the actual voltage is around 10 volt. That is Ok as long as you have pin 1 lower than +5 Volt or unconnected. This is a control signal for letting the PWM board run in ECO mode. Even if you power off the printer the Primary switching is on all the time. Power consumtion is less than 0.5 W anyhow. It is only a 24k ohm resistor on the 24 Volt line. I have not yet get my printer running. Next step is check on Main logic board.
     
  6. mike bitar

    mike bitar TS Rookie

    Dear timroperco can you give me details on how you do it....

    (your saying: I directly re-connected the circuit board to the dangling white connector hanging from the printer. Then I re-attached the female end of the power cord to the two prongs. Next I plugged in the power wire to a receptacle ... then hit the ON button.)

    I have another printer ip4700, I connected the 4500 circuit board to 4700, its work and only on 4500 its not working..???

    what exactly I should do..


    many thanx..

    Where the two prongs you mention
     
    Last edited by a moderator: Feb 18, 2014
  7. JCisJD

    JCisJD TS Rookie

    Thanks for that . I had the same problem with my MP510 (SEEMS TO BE SAME SET UP UNDERNEATH) Followed what you did now all working again:) RESULT!
     
  8. MACamillo

    MACamillo TS Rookie

    Great fix. Thanks heaps. Now I have a print head error - unrecognised !!!!!
    Any suggestions please?
     
  9. rogiain25

    rogiain25 TS Rookie

    Thanks Timroperco,Jan 8, 2012 - spot on, probably it is just the contacts need a thump. Point of detail - you may be lucky if you have a particularly fine 4mm hex socket but many don't fit into the recess round the screw. One that does, comes from http://www.ebay.co.uk/itm/231109959742?_trksid=p2059210.m2749.l2649&var=530292187333&ssPageName=STRK:MEBIDX:IT (that's ceskwoutlet(28926 [​IMG]) - it does actually fit, at a cost of £1.25 post free.

    Actually, however, it's an External Female TORX Bit Star E Socket, of all things, that you really need and you can get a suitably small set of those, part number CT0732
    from Cascav Tools Ltd on Amazon for the princely sum of £7.60 incl postage. As for getting off the power module cover, Timroperco is absolutely correct but I found it much easier to prise the cover off from the screw hole side and just wiggle it a bit (NOT heavy handedly!). The retaining lugs are two on the opposite side and one on the opposite (short) end from the screw hole - just about in a straight line from it. To get the cover back on properly it is the latter lug you have to engage first - the other two will then just pop into place, so that you can then replace the screw before reinserting the module into the printer. Then, hey presto and all is ok again until the next time.....
     
  10. lajmh

    lajmh TS Rookie

    This just happened to my 4500 printer, no power no matter what (printer didn't like the photo paper). Because of the electricity, won't try to fix it because I still have two 882 printers, a 432 and the newest member of the family an ip 100 (which has a battery pack option although it is currently out of stock).

    No one will touch the 4500 (she had a good long life), and I'm not sure if it's worth the time and effort and the money fixing her with all the other printers (in theory I can print four documents simultaneously).

    My query is I have all the ink cartridges and no one will take them. They are all original canon but not in the boxes but shrink wrapped. The only way I can dispose of them is 20 at a time at Staples.
     
  11. AlbertvanderV

    AlbertvanderV TS Rookie

    Amazing: almost had thrown my ip5200 away after it having suffered a power spike. Couldn't find a replacement power supply (k30251) anywhere, although it should be easy enough to replace. Then came across this posting by Timroperco and thought: what the heck, just put the assumed broken supply back and see whether it powers up. Guess what: it did!
    Anyone have an idea what the technical reason behind this magic is? :)

    Cheers to you Timroperco, saved me a printer!
     
     
  12. Seth B

    Seth B TS Rookie

    Thanks Timroperco- worked on my Canon Pixma MP610! This is the main printer for a small company and we were about to go Office Space on it because it would have been our third printer in two years. Now I wonder how easy it would have been to fix the other two...
     
  13. Jeff Hartnell

    Jeff Hartnell TS Rookie

    Awesome, thanks! Just worked for me with a Canon MP610. So simple to unclip the power supply, unplug the little white connector, plug it all back in and away we go... it worked again. A 2 minute job!
    Interestingly I heard a little click in the power supply unit when I plugged the mains power lead back in, maybe a little relay or something.
    My Canon MP610 was previously dead and refusing to power on and now it's working again!
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.