1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Printer won't power on, tried everything

By Mugsy · 103 replies
Jul 5, 2011
Post New Reply
  1. I feel kinda stupid. This should be simple.

    Yesterday, I quickly "aborted" a print job on my Canon ip4500 usb inkjet printer by pressing the power button on the front of the unit. Now it won't power back on.

    The Power button does not appear to be damaged. I've tried plugging the printer in in another room (by itself, no computer) and still nothing. I've also left it unplugged overnight and even tried using a different power cord. It just will not power on. Note, the printer was working just fine yesterday afternoon. The only thing I did was turn it off in mid-operation.

    Even if the power button were damaged (and I see no sign that it is), it should turn on by itself when I go to print. Instead, I get an error message simply saying "the printer is not ready." (at first, I was getting a message that "the printer is offline", but I was able to toggle that by going into the Printer Properties in Windows and changing its online status.)

    The printer is only slightly over a year old, so it's no longer under warranty (naturally). Newer models are junk, so even though Canon has a "trade-in" program, I'd rather fix this one (which SHOULD be something simple).

    I bought the "Canadian" version of this discontinued printer specifically for it's CD printing capabilities. Newer models... and ALL U.S. printers... disable this feature (by law?) According to Canon (after I asked), there is no fuse inside the unit that might have blown.

    Does this problem sound familiar to anyone? The cost of taking the printer to a repair shop would cost more than the printer itself, yet finding a decent replacement would be very difficult if not impossible. Help! TIA.
    videobruce likes this.
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,546   +430

    Does the printer plug directly into the wall, ie - just a wire? Or is there an AC to DC converter in line? If there is a "wall wort" or "brick" on the power line do you have a multimeter to check that it is delivering the correct (or slightly higher) voltage that it says it should.
  3. Mugsy

    Mugsy TS Evangelist Topic Starter Posts: 545   +59


    Thanks for the reply. :)

    Nope, no transformer. Plugs straight into the wall.

    I also found info online about "resetting the Pixma back to factory defaults", but it assumes the printer at least powers on.

    I tried another test and noticed something else. I plugged the printer back into the wall, plugged it into a USB port, and the computer did not detect it the printer, meaning power is not even getting to the circuitry.

    Either Canon is lying about there not being a fuse inside the printer (likely in the p/s), or I have a dead circuit board.

    If that's the case, I never would of purchased a $300 printer that's as fragile as glass. :(

    I think I'm screwed.
  4. Lokalaskurar

    Lokalaskurar TS Enthusiast Posts: 514

    When you press the power button, does the machine normally just turn off in the blink of an eye, or does it initiate 'shut-down procedures'? (Does it take about 1 minute to shut down fully?)

    Because I've seen the ip4600 -> it always prints the last remaining job before shutting down.


    There are normally 3 circuit boards in Canon printers; the control board (HID) - the equivalent of a motherboard (MPCC) and of course the one resting on the internal PSU. I would suspect the PSU, because the PC cannot recognise the printer.

    I know that I personally would remove the PSU and check the internal wiring for voltage. If they are all dead = usually a blown fuse and/or over-aged/blown PSU capacitor or two.

    Might not be much, but this problem seems very strange indeed.
  5. Mugsy

    Mugsy TS Evangelist Topic Starter Posts: 545   +59

    Thanks again for the speedy reply.

    Pressing the power button on the printer would instantly shut it off. I had done this many times before (bad, I know) to abort printing to a DVD just as I noticed a mistake with the label. Ditto printing to photo paper or an adhesive CD label (stuff that's too expensive to waste.)

    Little did I know I was flirting with disaster. I aborted print jobs this way for years with the HP printer I had before this one, so never suspected this could damage my printer.

    Helpful stuff on the circuit boards. Opening/Disassembling the printer looks like it could be messy, but no local service center will even *look* at an inkjet, so it looks like it is up to me. Oh happy day. :(
  6. Timroperco

    Timroperco TS Rookie

    I fixed my iP4500. I think.

    I had the same problem as above. My iP4500 is only 18 months old and rarely used, although I leave it on all the time. However, following a power outage, I couldn't get it to turn on. Tried different receptacles, pressing different button sequences, nada. It was dead.

    I assumed the power outage had caused a surge, possibly blowing an internal fuse. After reading the posts above, I realized there was no fuse ... and perhaps the power outage had blown a circuit board, meaning the whole printer would be replaced.

    I know nothing of electronics or circuitry. But I decided I had nothing to lose ...

    I placed the printer standing on its front face (where printed paper comes out) to examine the bottom. I noticed the power cord isn't directly attached -- it is a removable plug which fits on two prongs mounted on the printer. I removed the power cord, then noticed the prongs are seated in what appears to be a separate module. Turns out, this module can be easily removed -- pressing in just two plastic tabs will release it. However, it now remains attached to the printer by a white plastic slide-on connector holding four colored wires. This white connector plug is easily disconnected, and the box-shaped module is now free. It measures about 6" by 2" by 2".

    On the cover you will see a small silver hex-head screw. You will need a #4 mm hex socket to unscrew it. I used a screwdriver as a wedge to pry up this cover where it is seated on the other side. Out came the circuit board ...

    I didn't see any burn marks or damaged-looking components on the circuit board. And since I come from the old school of "take it apart and put it back together to see if it works," I decided to fool around.

    I directly re-connected the circuit board to the dangling white connector hanging from the printer. Then I re-attached the female end of the power cord to the two prongs. Next I plugged in the power wire to a receptacle ... then hit the ON button.

    Voila! The power light came on and the printer started making noises. I immediately shut it down, then re-assembled the module and re-installed it in the printer. I then took the printer to my computer, reattached the USB wire, plugged in the power cord and turned it on again. After the usual warm-up noises, the thing is printing perfectly again.

    I honestly have no idea if I actually "fixed" anything. Perhaps the power cord was loose from the prongs, or perhaps the wire connector wasn't seated properly before. But this whole effort took less than 10 minutes, and I can say my printer is now working just fine again. Maybe this will help someone else ..
    Fab8888, Seth B and vierab like this.
  7. Bob A

    Bob A TS Rookie

    Did anyone write down the voltages they got from the power supply? I used the method Timroperco detailed, and while it didn't fix the problem, I did take voltage measurements and would like to see if my power supply is okay or not.

    I assume both black wires are ground and used them as the reference points:

    Yellow = 0 - This looks suspicious to me!
    Black = 0
    Red = 7.5 v
    Black = 0
    Blue = 9.95 v

    Yellow looks bad, but without knowing what's normal on a working printer, I can't be sure.


  8. DafEO

    DafEO TS Rookie

    Just registering to answer the above in case it may be of use to others.
    My iP4600 died just as it was about to print a CD. No buttons pressed etc.

    The AC adapter module is replaceable I think - part No - K30304 - seen a few on eBay etc.
    The markings on it say output : 32V - 0.75A and 24V 0.5A

    And indeed my power output is :
    Brown = 0
    Red = 0
    Orange = 23V
    Yellow = 0
    Green = 31V

    So looks like my AC adapter is Ok but printer isn't - annoying as I have newish Canon original inks.
  9. Microman3000

    Microman3000 TS Rookie

    I have exactly the same problem with my ip4500.

    I have pulled the printer apart and checked the power supply, the voltages are the same as mention in the previous post. I have checked all the connections and tried powering it up with the print head disconnected but nothing worked.

    Has anyone here found a solution?

    I can get a new main logic board but would hate to replace it only to find its not the faulty part.
    Last edited by a moderator: May 8, 2016
  10. JohanAbg

    JohanAbg TS Rookie

    The same problem for me too with my IP4500! I have also measurred the voltage from the PSU after disconnecting the 5 wires. The result is the same as Bobs findings ( Yellow=0V; Black=0V (Reference point); Red= 7,5V; Black =0; Blue 9,95V.).
    I opended the PSU but can't see anything that 'visually' looks faulty in there. But obviously some component is faulty in the PSU. Where can I find a new PSU unit? It is not for sale through Canons sales channels here in Sweden.
  11. Microman3000

    Microman3000 TS Rookie

    Strange, because mine shows 32v and 24v with 5 wire plug disconnected.
  12. midlandman

    midlandman TS Rookie

    I can't offer a remedy only my ip4700 just went dead after printing a document checked power adaptor as far as my limited knowledge would allow,looked at circuit board and components inside no visable signs of any problems, thought there would be a fuse but no sign,need a printer bought new ip4950 for £62.00 inc' postage with genuine cartridges (some suppliers take out original and replace with comptables) from Amazon I hate waste but in this throw away environment it's just not worth the cost and frustration, hope this printer lasts longer than the 4700 (a little ove 2 years)
  13. Rogiedoo

    Rogiedoo TS Rookie

    I had the same problem where the printer suddenly showed no power light. I followed Timroperco's advice and took out the module where the power cord goes into the printer. I don't have a small hexagonal screwdriver so rather then try to get inside the module I simply disconnected the white terminal with the 5 wires and then reconnected it. The printer came back to life! So it would appear that both Timroperco's printer and mine had a loose terminal which probably occurs over time. Thank you Timroperco for pointing me in the right direction.
  14. Ossi Orava

    Ossi Orava TS Rookie

    And same thing here with my MP610. There was suddenly no power, and since I have no repairing skills whatsoever, I was already prepared to buy another printer, but decided to google for the possible solutions on the last minute. I found this thread and Timroperco's advice, took the module out, disconnected the white terminal (which seemed to be very tightly fastened already), and plugged it back. And there was power again! Big thanks to Timroperco!
  15. thomh

    thomh TS Rookie

    Just found this thread via google - same problem with my canon pixma ip4500, about two years old. And yes, THANKS to Timroperco my printer is working again. As above, I just disconnected and reconnected the white plastic connector without opening the component. That was all it took, and my printer is on again. My added wrinkle is that this happened last night - printer light turned off for no apparent reason, and power-on did not work. So I moved the whole printer to another room and plugged it into another outlet (after disconnecting/reconnecting the line into the printer). That fixed it, but it went out again today, so I thought I needed a new printer. I hope this new 'fix' keeps working.
  16. MrTechnik

    MrTechnik TS Rookie

    I also just found this thread via google and I have problem with Canon MP630. It don't want to turn ON, no voltage, no signal. I took out the power supply K30304, it says there should be 32V and 24V on output. I checked the voltage with multimeter and this is what it measured:
    - Brown (as reference point) : 0
    - Red: 0
    - Orange: 8.37V
    - Yellow: 0
    - Green: 10.99V

    So I guess the power supply is broken.
    Can someone with working printer tell what voltages he has?
  17. Bill Seaby

    Bill Seaby TS Rookie

    Power failure in the 'hood for a few hours and the Canon IP4500 (5 years old) would not re-power up. Volt meter showed good voltage to the connector. All other equipment fired up OK except the Canon IP4500 printer. TIMROPERCO's "fix" of removing the clipped in module, unhooking the white connector (went no farther then that), then reinstalling WORKED. It powered up, gave me a status, ran a test print and we're are "good to go."
  18. MShaneClark

    MShaneClark TS Rookie

    I also had a random power failure and by following TIMROPERCO's "fix" I was also able to get my IP4500 back up and running. Here is a link to some pictures I took while removing the circuit board for those who need visual cues!
  19. vierab

    vierab TS Rookie

    Thank you Timroperco! The fix worked for me to! I did not disassemble anything, just moved the module around.
  20. TeppyTweets

    TeppyTweets TS Rookie

    I have the same problem. I tried the Timroperco method but my printer didn't startup. Any other ideas? Maybe I have to buy antother printer? :(
  21. Mary Mishefske

    Mary Mishefske TS Rookie

    omg, it works. Your solution fixed my printer. I thought it was a goner. But I did it in less than 2 minutes. You're my hero...
    Dashing star likes this.
  22. Magiceye

    Magiceye TS Rookie

    Hi all thanks for the info, unfortuanately my Pixma is still dead, done all you guys said though brilliant, but on returning to plug in it lights up for a nano second then shuts down again. I am no techie, so beware of my failing, unplugged the mains after taking out the board, thoght put it back in and bolt it all up, WOW did I get a little tingle, I take it that was residual power sitting there waiting for me to get zapped, any one else takeing the board out make sure (unlike me) you earth it before touching it. YES I am a Numpty.
  23. jerrycas

    jerrycas TS Rookie

    Hello Timroperco!
    Your system almost fixed my printer! Please help some more...I did what you said, but when I pulled out the module there were TWO things connecting it to the printer...one is the white plastic piece with 4 colored (blue) wires. the other was a single white wire (perhaps a ground wire). Next, I made a mistake. I took out the white wire without making a firm mental note of exactly where it attached. Then I took out the others.

    there is no hex screw on mine (I have a different model Pixma I guess) and so I could not get the module open...so, I went with your take it apart, put it together idea and just put things back together. I put the white wire into a small hole that appears to have a male part deep inside it that would fit into the female end of the white wire...but I could not get the male/female parts to connect.

    So, anyway, I put it all back together but with the white wire just loosely attached...VOILA! The computer turned on, (which it had not done at all before). I was delighted! Then, it gave an error message--saying there has been a printer error. Please unplug and call the service center.

    I am sure the error lies in the placement of this white wire. Any help? I cannot get it connected to that spot, am not 100% sure that is where it goes anyway, and cannot get the whole module open.

    appreciate any thoughts/help you can offer
  24. Apicius

    Apicius TS Rookie

    Thank you timroperco worked like a dream with my MP499!
  25. Hambo

    Hambo TS Rookie

    I also tried Timroperco's fix on my Canon IP4500. Disconnected the white connector from the plastic module, and then replaced it and my printer came back to life!. Many thanks for the information. Appears to be a common problem with these printers.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...