TechSpot

Problems with FAT32 partition shared with Debian Linux

By limao
Jul 13, 2005
Topic Status:
Not open for further replies.
  1. Hey there..

    I use 3 basic partitions, apart from swap partitions, etc. One ReiserFS partition for a Debian Linux, one FAT32 (10 GB) partition for Windows XP, and one FAT32 partition (77,2 GB) for general use files, such as MP3, photos, browser bookmarks, etc. In Linux, the FAT32 partition works fine, but in Windows XP, it has some problems. Windows reads files from this partition nicely, but has a problem writing to it. When I try to create a folder on this partition, from Windows, I get a message "Can't create folder <foldername>. Incorrect parameter.", and the folder is NOT created. When I try to copy a file from the NTFS partition to the FAT32 partition, Windows gives me "Windows can't save all the data to the file <filename>. Data were lost. This error may have been caused by a hardware or internet conection failure. Try saving this file to another location", but the file is nonetheless created, and it is exactly the same size as the original (yes, pretty weird).
    In addition, I found this problem recently: I downloaded a MP3 file, under Windows, to my Windows partition. Still using Windows, I moved it to my file partition. Then, I swapped to Linux, and did some manipulation with that file (creted a folder on the file partition, and moved that file to the folder). I returned to Windows, and now Winamp can't read the file, hanging up whenever it tries to. Also, I can't move or copy the MP3 file using Windows.

    I use a Samsung SP120N (120 GB, 7200 rpm) HDD.

    Any ideas?
    Tkz in advance..
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    What is the sequence of your partitions?
    Option A:
    1)Linux
    2)XP
    3)FAT32

    or B:
    1)XP
    2)FAT32
    3)Linux

    or C:
    1)XP
    2)Linux
    3)FAT32

    or D:
    1)FAT32
    2)XP
    3)Linux

    The FAT32 partition should be inside an Extended Partition in Options A, B and C
    In Option D: it should be the Primary Partition on the C: drive

    If none of this is the case, report back.
  3. limao

    limao TS Rookie Topic Starter

    My mistake

    According to cfdisk, under Linux, even the partition where Windows is installed is FAT32. My bad, I'm sorry.

    As for the order of my partition, here goes my partition table, as presented by cfdisk:

    [PRIMARY,Boot] hda1: Linux ReiserFS: Debian (10 GB)

    [PRIMARY] hda2: Linux ReiserFS: Reserved for another distro.. (10 GB)

    [PRIMARY] hda3: Win95 FAT32 (LBA): Windows (10 GB)

    [LOGICAL] hda5: Win95 FAT32 (LBA): General use files, as described in opening post (77 GB)

    [LOGICAL] hda6: Linux swap (2 GB)

    Option A, then.

    Obs. in Windows, the file partition (77 GB FAT32 partition) is the C: drive, and the actual Windows partition is G:
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    XP can be on FAT32 or NTFS, so no problem.
    What OS created this large FAT32 partition, Linux or Windows?
    If Linux, it may be slightly different. (why do you call it W95 FAT32 ?)
    If Linux can read NTFS, perhaps you should look into converting both FAT32 partitions to NTFS (careful, you cannot UNdo this!)

    I have honestly no idea, don't know Linux (or its side effects) at all.
    Someone else?
  5. limao

    limao TS Rookie Topic Starter

    I found a new error.
    I downloaded a MP3 file, under Windows, to my Windows partition. Still using Windows, I moved it to my file partition. Then, I swapped to Linux, and did some manipulation with that file (creted a folder on the file partition, and moved that file to the folder). I returned to Windows, and now Winamp can't read the file, hanging up whenever it tries to. Also, I can't move or copy the MP3 file using Windows.

    Answering your questions, realblackstuff:

    I created all partitions using cfdisk, from Linux.

    I call it W95 FAT32 because both cfdisk and qtparted (partition managers from Linux) call them this way.. I believe it's because it is W95 native partition.

    I used Linux to create the partitions because, when I did, Windows was giving me headaches (which is why, in first place, I decided to move to Linux :D).

    Maybe I should convert the Windows partition to NTFS.. but not the file partition. Linux can read from NTFS partitions well, but unfortunately it's not very reliable when it comes to writing to them. Since the file partition is used by both Linux and Windows, I can't risk writing to NTFS from Linux, I've heard and read about serious disasters caused by such attempts. :/

    Obs. I googled out the FAT32 partitions size limit, and theoretically it's 2 TiB ( 2,048 GiB). From the same source, I found that Windows can work with such partitions, but it limits them to 32 GiB only if it's creating the partition, i.e. using PartitionMagic. This makes me rule out the possibility of partition size incompatibilities.
  6. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Maybe just reformat the bad partition with some alternative program instead of mkfs in case Linux did something weird with it when creating the filesystem.

    Also, where do you live? Do you use extended character sets in Linux that could create files with weird names that WIndows can't understand?
  7. limao

    limao TS Rookie Topic Starter

    I converted my Windows partition from FAT32 to NTFS, but it didn't help. Cluster size was 8 KiB, now is 4 KiB

    It's always an option.. the only weird thing in the partition is the cluster size of 32 KB. Apart from that, I cant see what's wrong with it.

    I formatted it using cfdisk, not mkfs. Unless cfdisk is a front-end to mkfs, it was not used. An alternative for me is qtParted, which comes with my distro, but I don't know if it uses mkfs, so it's kinda useless.

    I live in Brazil. Is there any way to know if the character set is supported by Windows or not? As far as I can remember, I didn't touch it during Linux instalation, nor there were any messages/alerts/errors about character sets.
  8. Nodsu

    Nodsu TS Rookie Posts: 9,431

    By default Linux uses the US codepage for short names on FAT32 partitions and unicode for long file names so unless you changed the setting yourself or Debian is weird then it should be OK..

    Try formatting the pesky partition again. Then experiment with plain filenames and then with filenames containing accented characters to see if the problem is with charsets.
  9. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Try the Windows formatter, rather than the Linux one.
    Just my 0.02 cts.
  10. Nodsu

    Nodsu TS Rookie Posts: 9,431

    The partition in question is 77GB - the Windows formatter just won't cut it.

    Another solution is to use ext2 instead of FAT32 for the shared partition. There are drivers that let you mount ext2/3 partitions as drives in Windows.

    This is what I use (supports writing to ext2):
    http://ext2fsd.sourceforge.net/
  11. limao

    limao TS Rookie Topic Starter

    Does this program support writing? If it does, ok...

    Also, is it reliable? There's a program which promises to write to NTFS partitions from within Linux, but it's unreliable, as put by various sites that tested it.

    I'll be away from my computer for three days, so don't expeect to hear from me then. When I return, I'll try Nodsu's suggestion.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.