TechSpot

Rsvpsp.dll gone, how to regret?

By Josef Minde
May 6, 2006
  1. During a hard adaware chase, one item too much was deleted from winsock LSP.
    This was rsvpsp.dll, and now some internet sites using Java don't respond properly. (CS-Manager)

    I can try a restore, but then the virus will reappear too. So i will leave this as the last resort.

    What i have tried:
    - Reinstall the Java engine
    - Start/Run: regsvr32 rsvpsp.dll
    - rsvpsp.dll belongs to Windows Rsvp Service Provider, therefore i removed/reinstralled the QoS packet sceduler in the network protocol.
    - Did a system check "sfc /scannow"
    - Checked that the file is equal as one on a different pc.

    Nothing of this helped in what i think is the real problem; to get the .dll loaded into Winsock LSP.

    Is here anyone which has a solution about how to load rsvpsp.dll back into winsock?
    Or; what can i un-/reinstall to get the .dll back where it belongs?

    Many thanks in advance
    Josef
     
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

  3. Josef Minde

    Josef Minde TS Rookie Topic Starter

    Thanks for your help Vigilante
    The download helped to restore the rsvpsp.dll into winsocks,
    but unfortunately the game will still not respond as expected
    (java engine starts, but nothing is loaded)

    I will try to contact Sun (Java) first, and if that not helps i guess that restore is my last option.

    Time to dress up with my armor against pc-viruses again.... ;-)

    Josef
     
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Your browser could be blocking scripting as well.

    If you use Internet Explorer, click on the Tools menu, then Internet Options.
    On the Security tab, click "Default Level" for each icon across the top. Then click on the Advanced Tab, and click "Restore Defaults".
    Then close all IE windows, then open a new IE and see if it works.

    Make sure you don't have a 3rd party "blocker" on your system such as a popup blocker, security toolbar, anti-hack program etc... If you do, you'll have to check the settings and make sure it isn't blocking java and javascript.

    good luck
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...