TechSpot

Satellite M100 conflict between VGA and PCI Bridges

By acidfk
Mar 20, 2008
Topic Status:
Not open for further replies.
  1. Hi to everyone, it`s my first post in this comunity, i apologize for my bad englisg usage

    The Notebook is a Toshiba Satellite M100 SP1011 PSMA2U-00T00G:

    Celeron M 420 @ 1.60 Ghz
    512 DDr2
    40 GB HDD
    Chipset ATi SB450 South Bridges and IGP X300 Based Grapich Card "Radeon Xpress 200 or 200M"
    High Def. Audio
    3x USB 2.0
    PCMCIA adapter
    WIFI, LAN
    Windows XP sp2
    Phonix Bios V1.30 01/11/2007 ( i update the bios to try to solve the problem with no result )

    is a basic system wiht a very simple bios setup configuration.

    Now the problem is:

    i formated the computer and when i try to intall the graphic driver ATI 8.3 Catalyst Software

    Downloaded direct from the Toshiba Europe Site. the installer send a error message telling me

    there is no a hardware compaible. when i check the grapich Properties i see the VgaSafe was in

    conflict wiht a PCI Bridges.

    Interval of E/S 03B0-03BB
    interval of E/S 03C0-03DF
    Interval of Memory 000A0000-000BFFFF

    all wiht a Denegade Icon and used for a Standar PCI bridges PCI to PCI

    for this reason in the Device Manager there not a Graphic Adapter Root Listed. the hardware is not Recognized for the system.

    this is a copy of System Information of WinXp Conflict/shared resources

    Puerto E/S 0x00000000-0x00000CF7 Bus PCI
    Puerto E/S 0x00000000-0x00000CF7 Controladora de acceso directo a memoria

    Puerto E/S 0x000003C0-0x000003DF Puente PCI estándar de PCI a PCI
    Puerto E/S 0x000003C0-0x000003DF VgaSave

    IRQ 22 Controladora estándar PCI IDE de doble canal
    IRQ 22 NIC Fast Ethernet PCI Familia RTL8139 de Realtek

    IRQ 11 Video Controller (VGA Compatible)
    IRQ 11 Ethernet Controller

    Dirección de memoria 0xD8000000-0xDFFFFFFF Puente PCI estándar de PCI a PCI
    Dirección de memoria 0xD8000000-0xDFFFFFFF Video Controller (VGA Compatible)

    Puerto E/S 0x00009000-0x00009FFF Puente PCI estándar de PCI a PCI
    Puerto E/S 0x00009000-0x00009FFF Video Controller (VGA Compatible)

    Dirección de memoria 0xD0100000-0xD01FFFFF Puente PCI estándar de PCI a PCI
    Dirección de memoria 0xD0100000-0xD01FFFFF Ethernet Controller

    Dirección de memoria 0xD0000000-0xD00FFFFF Puente PCI estándar de PCI a PCI
    Dirección de memoria 0xD0000000-0xD00FFFFF Video Controller (VGA Compatible)

    IRQ 19 Controladora de host USB OpenHCD estándar
    IRQ 19 Controladora de host USB OpenHCD estándar
    IRQ 19 Controlador de host de PCI a USB mejorado

    Dirección de memoria 0xA0000-0xBFFFF Bus PCI
    Dirección de memoria 0xA0000-0xBFFFF Puente PCI estándar de PCI a PCI
    Dirección de memoria 0xA0000-0xBFFFF VgaSave

    Puerto E/S 0x000003B0-0x000003BB Puente PCI estándar de PCI a PCI
    Puerto E/S 0x000003B0-0x000003BB VgaSave

    i used spanish version of XP

    i cant change the IRQ and Interval os E/s, the hardware is not Plug & Play and the checkbox to modify in windows is disable.

    if a Disable one of the tree (3) PCI Bridges listed in the device manager "the VgaSafe the resources come to able but
    i cant install the ati driver just becase the VGA adapter ( compaible VGA ) disapier under the pci bridges is disable

    Searching in Google i found this information on a Microsoft Support Page:

    PCI Video Adapter May Not Function on Secondary PCI Bus

    i cant put link it`s my firts post but if your find in google type this

    google search:

    PCI Video Adapter May Not Function on Secondary PCI Bus (english)

    El adaptador de vídeo PCI no puede funcionar en bus secundario PCI (español)

    in this topic the solution is configuring the bios to enable the correct BIT ISA ( i dont understand so much this )

    but the bios of this notebook is VERY simple and dont have to configure nothing just The HDD pass, System Pass, Boot order. and LEgacy USB. etc
    but nothing like IRQ listening or something like that.

    i have a 2 weeks wiht this problem and i am frusrated now. i try many things:

    Reinstal Windows XP. SP1 and SP2
    Install Windows Xp Home
    Windows Vista.

    and every time wiht the same problem os shared resources.

    If Anybody can help me, SE LO AGRADESCO MUCHO.
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Did you install the motherboard drivers from Toshiba?
  3. acidfk

    acidfk TS Rookie Topic Starter

    yes all drivers. but i cant install the ATi Graphic driver this is my problem. the SBdrv SM bus ATi is installed

    i try to intall the graphic driver ATI 8.3 Catalyst Software

    Downloaded direct from the Toshiba Europe Site.

    note: i cant find my exact model of notebook in any toshiba`s page "PSMA2U"
    in toshiba europe only show "PSMA2E".
  4. acidfk

    acidfk TS Rookie Topic Starter

    finally i fix the problem

    i start the install Hardware update Assistant of windows. now i disable the PCI bridges PCI to PCI. netx i select specific route, select No Find. i select the controller. select USE DISK. find the INF file of ATI and select the correct ATI xpress 200 from list. the driver install. FINE. later i enable the pci bridge. and ALL WORK. know i have my ati work again. thanks to everyone
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.