TechSpot

sound blaster x-fi platinum: RANDOM FREEZE/RESTART/LOUD PIERCING SOUNDS

By dopefisher
Jan 31, 2006
Topic Status:
Not open for further replies.
  1. ok so i have been having thi sprob for a long time, like ever since i got the card, actually. tried looking thru creative forums, even contacted creative customer support several times. it happens when i am playing a game, or even just playing music, but not as often.

    here is what i have done to try and fix: change pci slot of card, change audio settings in creative audio console, change latency settings, change all types of bios settings, uninst/reinst drivers 100's of times/manually delete registry entries/installshield entries/use drivercleaner pro, etc; close ALL background processes except the ones you can't close, probly more but i cant remember off hand.

    this doesn't happen during any particular game either. it happens during the elder scrolls 3: morrowind quite frequently though. other games : wizardry 7, wizardry 8, i DO play a lot of "older games" (1999-2002) and there is no compatibility mode built into the sound card or creative software. i have tried running the games under windopws compat mode, no help either. any ideas anyone?

    p.s., my specs in my profile are up to date. thanks
     
  2. Ruben

    Ruben TS Rookie Posts: 105

    Hi there,
    I see you have tried a lot of things.
    It sounds weird, I do not think sound cards need any compatibility mode.
    With older titles it's direct sound only isn't it so they SHOULD work ....

    Is onboard sound disabled in BIOS?
    What entries do you have under sound video and game controllers in the device manager?
     
  3. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    yes, onboard snd is disabled.

    here is a pic of my device manager window, which shows yet ANOTHER stupid problem lol. cant get rid of those stupid miniport entries.

    [​IMG]
     
  4. Ruben

    Ruben TS Rookie Posts: 105

    These miniports entries may decrease PCI bandwidth available for sound.
    1. Can't you switch them off in BIOS so that you have just one entry under network cards? (do not ask me how, I am no expert with bioses)
    2. Run dxdiag to test direct X sounds. Do they work fine?
    3. What's your OS. Do you have all available SPs?
     
  5. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    i think i got them from a virus or something... i had cfosspeed installed, but something made it keep trying to reinstall itself, and i ended up with all that crap. i deleted as much as i could from the registry by hand, but that stuff wont go away. no there is no option to remove them from bios, but they are disabled, so i dont see how they could hurt anything.

    this problem usually happens when things get intense or i start doing things real fast.
     
  6. Ruben

    Ruben TS Rookie Posts: 105

    I think it's most likely NOT the sound card itself, rather the way your OS manages resources for all physical and virtual devices. I guess registry could get corrupted a bit when you were deleting stuff by hand and the whole OS has a hiccup now...

    1. XP Repair Installation could be an option, then.
    Anyway get rid of these WAN entries, I think they may matter, even if disabled.

    2. if you are using "ACPI Uniprocessor" configuration try another ACPI (NOT a standard PC, just this "ACPI Advanced Configuration and Power Interface" without IRQ>16. See the screenshot.

    3. Oh yeah, and test dxdiag, maybe your direct X driver is messed up

    Good Luck!
     
  7. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    1. my directx checks out just fine.

    2. i read about disabling ACPI, don't you have to reinstall windows to do that? will this be the same type of deal? i will try it thx.
     
  8. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    i looked at your pic, i do not have all the options you have to choose from. i only have "ACPI uniprocessor PC" and that is all.
     
  9. N3051M

    N3051M TS Rookie Posts: 2,800

    you can try getting rid of those device manager entries via safe mode (f8) maybe it will help..
    also those games ran perfect with your normal setup before right?
     
  10. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    i think everything was fine BEFORE i got my x-fi card, before this i had an audigy card, and i don't think i had problem slike this....

    i will try safe mode then
     
  11. iss

    iss TechSpot Chancellor Posts: 2,896

    Are you using the creative mode switcher? have you tired running it in "entertainment mode" instead of "gaming", or vice versa?
     
     
  12. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    1. ok i got rid of all those crazy miniport entries.

    2. yes i have tried ALL possible sound options that i know of, including mode switching.
     
  13. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    help! it wont stop freezing my pc and making high piercing sound!
     
  14. N3051M

    N3051M TS Rookie Posts: 2,800

    would you be able to try out the card in another pc (curiosity)?
     
  15. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    no, i don't have one :(
     
  16. N3051M

    N3051M TS Rookie Posts: 2,800

    ok.. umm.. try getting updated drivers.. thats all i can think of at the moment.. lets see if the other guys have anything...
     
  17. dopefisher

    dopefisher TS Rookie Topic Starter Posts: 540

    uninstalled reinstalled did all that :(
     
  18. seanp789

    seanp789 TS Enthusiast Posts: 113

    I doubts its the games since it happens with music too.
    "CTHELPER.exe" would have been my first guess sinc eit is very problematic but if you have all that disabled that cant be it.

    Next step, if you had virus problems you should reformat and make sure thats not the issue or at the least install the XFi in a another computer, maybe a friends. If you are still having a problem after that I would demand a warrenty RMA from creative.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.