TechSpot

Synchronizing clock on computer

By larryiam
Jun 4, 2008
  1. it seems every time i try to synchronize my computer clock it says error can't synchronize with time server. any suggestions??
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    the control is in Control panel-> Date & Time->Internet Time
    I have three services:
    1. time.windows.com
    2. time.nist.gov
    3. time-a.nist.gov

    change the name and then click Update Now. It takes a few seconds and you should
    see the date+time of sync -- or -- the error.

    choose another name, resync until one works for you :)
     
  3. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    i still have the error
     
  4. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    maybe a result of the infection on your system that you decided not to take up my help on
     
  5. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    uh no! it has done it for quit a while. was just wondering if there was a fix for it. besides another member helped me with the problem and my computer is infection free!! so any suggestions? i will listen to you now blind dragon! :D no hard feeling!
     
  6. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Did you by any chance download combofix as a part of the fix?
     
  7. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    combofix for the synchronizing of the clock?
     
  8. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    No, did the user that helped you have you run combofix, as it changes your clock settings and doesn't set back until you uninstall it properly
     
  9. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    no. he didn't tell me to run combo fix just hijack this and killbox is all
     
  10. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    open a command prompt as an administrator and type the following command:

    Code:
    w32tm /resync
     
  11. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    here is what it said
     
  12. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    from command prompt type the following and post the output

    C:\>w32tm /monitor
     
  13. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    didn't work did i do something wrong? here is wat it said
     
  14. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    yea you need a space before /monitor
     
  15. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    There is a simpler solution. You need to add a different clock synchronization source as jobeard already mentioned. Click here for a list. Just copy a computer name in the left column and paste it into the box.

    Make sure you look at the right column and choose a source that is not very busy. I just did this a couple of weeks ago and finally I could synchronize my PC's clock.
     
  16. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    still didn't work. what did i do now?
     
  17. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    from the prompt just type w32tm /monitor

    The output should show what you are trying to sync to
     
  18. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    ok i did that here are my results
     
  19. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Ok, I'll use jobeard's sites. I may need to tweak this a bit but lets see

    copy (Ctrl +C) and paste (Ctrl +V) the text in the code box below to Notepad.

    Code:
    @echo off
    net stop w32time
    w32tm /config /syncfromflags:manual /manualpeerlist:time.windows.com,time.nist.gov,time-a.nist.gov
    w32tm /config /update
    net start w32time
    delete synctime.cmd and exit

    Save it to your desktop as File name: synctime.cmd
    Save as type: All Files

    Once done, double click synctime.cmd to run it. A command window will open briefly, then close. This is quite normal.
     
  20. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    ok done that. now what? thank you for your time!
     
  21. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    are you still getting error can't synchronize with time server.
     
  22. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    yes i still am
     
  23. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Gotta be something to do with either your software firewall or router firewall.

    I would first try disabling your software firewall and try to sync, if it works you know you need to add it to the trusted sites or tone down the settings.

    You could also access your routers firewall and adjust these settings.
     
  24. larryiam

    larryiam TS Rookie Topic Starter Posts: 476

    ok i will try that and post back the results.
     
  25. jobeard

    jobeard TS Ambassador Posts: 9,322   +622

    Network Time Protocol (NTP) uses UDP port 123. you need to open port 123 i/o udp src/dst any
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...