TechSpot

TCP/IP problems - intermittent?

By cityslicker
Dec 10, 2008
  1. 2 days ago, i noticed after booting up a error message appeared.

    Access Connection
    Connection Failure

    this meant i was not able to go online. i communicated with my isp tech support. we were unable to to get an ip address therefore i was advised to
    (a) call my laptop computer manufacturer and tell them i I have TCP/IP problems..
    (b) turn the dsl modem off for 20 seconds and start up. the connection worked once but not twice
    (c) i was also advised to try this method- start- run- cmd. then enter at the prompt - netsh int ip reset reset.txt
    and this worked.

    but it does not stay fixed. when i turn the laptop on... it seems the Access Connection error massage occurs again. if i use the comand - netsh int reset reset.txt and then reboot i am able to go online. i only tried this once or twice and it worked.

    also i did call my computer manufacturer- they said- it is an TCP/IP problem. actually it was software problem and not a hardware problem. so call the ISP for instructions.

    can anyone offer a permanent remedy?

    many thanks and truly appreciate your replies.

    winxp pro sp2 lenovo T61 Intel dual core T9300, 4 gb ram
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

  3. gguerra

    gguerra TS Maniac Posts: 317

  4. cityslicker

    cityslicker TS Rookie Topic Starter

    jobeard- i did your recommendations. everything went well. in fact while doing the first nine (9) commands - the access connections message appeared twice- each time validating/making the connection successfully.
     
  5. cityslicker

    cityslicker TS Rookie Topic Starter

    jobeard

    what confuses me is this last command

    do i execute it from the command prompt or from the url?

    do i type- nslookup w ww. google.com the message -
    could not find server name for address 192.168.1.1

    then i tried from the command prompt ww. google.com the message- goodl was not recognize as an external or internal command.

    nslookup ww w. google.com

    i did not know what to do next.
    other than that- i had no timeouts or unreachable hosts. so i guess i am good so far.

    please advise and thanks for your time and efforts

    cs
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    >nslookup www. google.com is from a command line, not a url :)
    If you run->cmd /k ipconfig /all
    you will see a line line
    DNS 192.168.1.1​
    and it will exactly match the gateway address
    gateway 192.168.1.1​
    Your router is not forwarding DNS requests to the ISP router :(

    You will need to set the DNS address manually
    View Network Connections->Lan Connection->right-click->properties
    scroll to the bottom to find Tcp/Ip; select it and click the Properties button
    Under the General TAB locate the two radio buttons and click on
    use the following DNS server addresses
    enter the two known DNS addresses for your ISP
    Click OK on this and the parent dialog too​
    To do this, I need the domain name of your ISP
    (eg; mine is timewarnercable.com ) from which I can find the NAME of the ISP
    DNS [ unixCmdPrompt> whois -H xxx] and then reduce it to the IP address for you [nslookup xyz.domainname] :)
     
  7. cityslicker

    cityslicker TS Rookie Topic Starter

    ok jobeard- this is where the fun begins.

    i found the 2 radio buttons. no problem there. but where do i find the two DNS addresses for my ISP? and what is the parent dialogue

    my isp is earthlink.net. i do not know its domain name

    thanks
     
  8. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    that was my task as follows:

    Earthlink's got pinach! :) The DNS names are
    (using whois -H (a unix command) on earthlink.net we find)
    Name Server.......... itchy.earthlink.net
    Name Server.......... scratchy.earthlink.net

    (and then nslookup on the names we get)
    itchy.earthlink.net -> 207.69.188.196
    scratchy.earthlink.net -> 207.69.188.197
    put both of these into the DNS parms and just keep closing the windows with OK

    Once done; redo these
    ipconfig /flushdns

    net stop "dns client"
    net start "dns client"

    now NSLOOKUP GOOGLE.COM shoud report addresses and http://www.google.com/ should work too.
     
  9. cityslicker

    cityslicker TS Rookie Topic Starter

    Tcp/ip

    okay i did what you skillfully recommended.

    everything looks super fine. now i will ask for confirmation that i did everything correctly. i have this question.

    at
    nslookup goggle dot com
    ***Can't find server name for 192 dot 168.1.1 non existent domain
    ***Default servers are not available
    Server: unknown
    Address: 192 dot 168.1.1

    non authoritative answer:
    Name: google dot com
    Addresses: 74 dot 125.45.100 209 dot 85.171.100 72.14.205.100

    But for http :// www dot google dot com and
    http: // www dot google dot com
    i got the same addresses

    BUT for non-authoritative answers... the addresses were different but they were google's.

    the question is: did i follow your instructions correctly?

    thanks
     
  10. cityslicker

    cityslicker TS Rookie Topic Starter

    jobeard- it did not take.

    i rebooted and i was unable to access connections- connection failed.

    i am not sure what i did wrong. <sigh>

    i will try it all over again.

    the only way i can connect is by- cmd. netsh int ip reset reset.txt and then reboot all over again.

    cs
     
  11. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    The 192.168.1.1 is still the primary DNS (ie first one listed) and of course it is failing. The Second 'non authoritative answers' are correct
    just CLICK on the URL address. do not use it as nslookup http://www.google.com/
     
  12. cityslicker

    cityslicker TS Rookie Topic Starter

    jobeard- thanks for your help. i tried all over again following your instructions. and i did everything right but... i still cannot access the internet unless i use this command

    netsh int ip reset reset.txt

    so it appears something else is not right happening. i have no idea what it is. none/zip.

    again i wish to thank you. if you have any last minute ideas.. i would like to listen/read.

    i have a image backup of 10 days ago. i think i will proceed from there. i will just backup the recent past 11 days and proceed from there.

    cs
     
  13. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    this is bugging me too.

    Please run->cmd /k ipconfig /all >myIP.txt

    and follow-up one more time and attach myIP.txt
    (it will be at \Documents and Settings\yourloginId\myIP.txt
     
  14. cityslicker

    cityslicker TS Rookie Topic Starter

    sorry jobeard- i already re-did the changes; i restored my earlier disk image. so what i have will not show the errors.

    however, i do submit to you by pm the requested info. thanks for all your assistance and savant solutions

    i spent way too much time trying to find the solution. i have never seen this type of problem. i even had earthlink tech support help me and <obviously> that did not help.

    again- many thanks

    cd
     
  15. cityslicker

    cityslicker TS Rookie Topic Starter

    Tcp/ip

    whoops i do no have enough posts to pm you.
    see attached file
     
  16. jobeard

    jobeard TS Ambassador Posts: 9,342   +622

    If your current config after the restore is now working, then the problem was not in the
    TCP settings as
    the attachment shows
    • DNS 192.168.1.1 (ie your router)
    • Dns suffix: (blank)
    If your connection is stable (ie is usable after each boot), then don't do anything :)

    Otherwise, add earthlink.net as the Dns suffix:

    I also note you have a Gigabit adapter which I've always found to be problematic in
    keeping stable.
     
  17. cityslicker

    cityslicker TS Rookie Topic Starter

    thanks again- everything is working fine... but for curiousity sake- how would i add earthlink,net as the Dns suffix

    and how would i minimize the impact of gigabit adapter?

    cs
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...