TechSpot

Upgrading from XP 32-bit to Win7 64-bit?

By H3llion
Feb 28, 2011
Post New Reply
  1. Hey guys :)

    I have purchased new 1TB, 7200RPM (32MB cache) Hitachy HDD and would like to know if i should install Windows XP 32 bit or install windows 7 64bit on it. My old HDD was 2MB cache 160GB which kind sucks :3 So will use it as music,video, backup disposal and the new as the boot HDD.

    I have 4GB of Ram
    GTX 460 OC
    Phenom II X2 555 BE (clocked to 4ghz)
    M4N78-SE mobo

    Not sure if its really worth it... I backed up most of my important files on my external drive and already downloaded 64bit applications that i need (flash player, steam, itunes, gpu driver etc..)

    Is it really worth it? Thanks in advance :))

    PS:

    Title typo :X

    Edit:

    Here is Windows 7 Advisor screenshots, doesn't really look too bad :D

    32bit:
    http://img715.imageshack.us/img715/1844/windows7advisor32bit.jpg

    64bit
    http://img560.imageshack.us/img560/5671/windows7advisor64bit.jpg
     
  2. defrag

    defrag Banned

    Since you're using 4gb ram, you should really use a 64 bit operating system to fully utilize all of your memory.

    I've been using one for the past few years, and I can find drivers and software easily now (it was a little hard when 64 bit just came out).
     
  3. superty12

    superty12 TS Enthusiast Posts: 432

    x64, but you really need to update all that stuff it says to, the .NET framework, Microsoft LifeCam, and Steam.
     
  4. H3llion

    H3llion TechSpot Paladin Topic Starter Posts: 974   +99

    Thanks guys trying to install my Windows7 64bit but got stuck at 89% on "expanding windows files" so il see how it goes second time....

    If that dosnt work il probs plug SATA cable to different socket and see if that dosnt anything.... maybe its something in BIOS :3

    Anyway il update this in 2hrs or so...
     
  5. H3llion

    H3llion TechSpot Paladin Topic Starter Posts: 974   +99

    Snap installation stuck at 0% now...Tried it on both HDD's the IDE and the SATA one and always stuck... Everything moves so the PC did not freeze but its always 0%.... best i got was 89% and then it got stuck...

    I tried with different DVD and still same ....I even tried changing the sockets from SATA4 to SATA3 and still same.. Not sure if this will do anything but maybe unplugging the old IDE drive may work...
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.