TechSpot

USB Removable device Problem

By wezz_o
Apr 24, 2007
  1. Hello guys, i have this problem of my removable device, i have this usb flashdrive DataTraveller 2.0 2 gigabit. When i plug it to my win xp, it detects and shows Found New Hardware, Data Traveller 2.00000003645 instead of Data Traveller 2.0 ... :dead: and then it says theres a problem installing the device and its asking for a driver. And I wonder why, it used to work properly without asking any drivers. Could someone help me.. pls.. thanks in advance
     
  2. Po`Girl

    Po`Girl TS Rookie Posts: 668

    It` s possible the device has gone bad or Windows has just forgotten.

    Try installing manually with the add hardware wizard.

    Tell it to look in the C:\Windows\inf folder

    or if you have the XP CD,the i386 folder on the CD.

    The file name is something like usbstor.inf

    If that doesn`t work run the System File Checker sfc /scannow

    Try the device in another PC if you can.
     
  3. wezz_o

    wezz_o TS Rookie Topic Starter Posts: 22

    It works

    Thanks mam!
    it actually works the usbstor thing you have said
    works great.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.