TechSpot

WD external clicks upon bootup, prevents XP load

By jalbin83
Dec 1, 2008
  1. Hello everyone,
    Basically my WD external makes a clicking sound when plugged into my system and prevents the system from booting up altogether. When I unplug the drive from USB, my computer boots up fine (mostly). It almost seems as if the external drive is not getting enough 'juice' to boot up completely but my new system with 650w PS does not include any power-draining peripherals.

    Is it possible that my external is corrupt? Does the clicking always indicate failure? Could it indicate lack of power?

    ALSO, the room in which I have the drive in tends to see a fair amount of dust plenty of which has made its way onto (and into) the MyBook casing. Is it possible for dust to get inside the casing and ruin the drive?

    Thanks for any input.
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    It can be n issue with the USB plug
    Yes dust can cause lots of issues
    It's best to test it in another computer to confirm

    But generally this sound is caused by a faulty harddrive itself
     
  3. jalbin83

    jalbin83 TS Rookie Topic Starter

    do you think it is advisable to purchase an external without 'air holes' as can be seen in the Maxtor as opposed to with 'air holes' as seen in the WD?

    (as a means to protect from dust)

    [​IMG]

    [​IMG]
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Well we've left technical and now gone into sales

    The sealed external casing has been tested to run without issue (in Normal conditions) But I wouldn't use it outside, plugged into a laptop on a hot summers day!

    Personally I'd say go for the vented one
    But that's only because I like things running cool
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...