Windows Networking via Crossover Problem

By SNGX1275
Mar 26, 2004
  1. Ok to get the basic setup outlined here it is:
    Windows XP Machine with 2 NICs:
    * 1 NIC goes to my cable modem via Cat-5
    * 1 NIC goes to my other machine via Crossover cable

    Windows 2k Machine with 1 NIC:
    * 1 NIC goes to the XP machine via Crossover

    So my 2k Machine connects through my XP machine using Windows ICS.

    For the following screenshots:
    Cable Modem = the NIC in the XP machine that goes to my cable modem
    k62 = the NIC in the XP machine that goes to the Windows 2000 machine
    Ugly B&W screenshot is from the Windows 2000 machine
    ***the wierd looking IP address and Default Gateway are truncated for my safety :)***

    Both computers are set up on the same workgroup according to right clicking on my computer and going to Computer Name in XP and Network Identification in 2000.

    The problem is that going to "View Workgroup Computers" in XP I see the workgroup I'm in, and I see only the XP machine, I DO NOT see the Windows 2000 machine. If I type in the computer name in XP (i.e. \\K6-2) it doesn't find it. If I type in the XP Computer's name from Windows 2000 machine (i.e. \\sngx1275) it does find it. And I can also browse files on the XP machine and access them just fine (the shared directories I have set up in XP).

    Question is why can't the XP machine see the 2k machine?

    The 2k machine accesses the internet just fine.
  2. sngx_father

    sngx_father TS Rookie

    Make sure you have NetBIOS installed on both of the NICs that are connected to each other via the crossover cable.
  3. SNGX1275

    SNGX1275 TS Forces Special Topic Starter Posts: 10,689   +395

    That was it. Thanks man. Guess good things can happen from taking the time to create a post :)
  4. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    That's odd, because I didn't think Windows 2000 needed NetBIOS installed, but yeah.. That should usually fix the problem :)
  5. Per Hansson

    Per Hansson TS Server Guru Posts: 1,926   +185

    From the IRC channel:

    <Diablo> sngx1275; you should not require NetBIOS to see the 2K machine from the XP machine
    <Diablo> NetBIOS is the devil!!!
    <Diablo> go in under the NIC properties
    <Diablo> TCP-IP properties
    <Diablo> advanced
    <Diablo> WINS
    <Diablo> check that "activate NETBIOS over TCP/IP" is enabled
    <Diablo> on both comps.. for only the internal interfaces (i.e. not for the one that goes from the XP machine to your cable modem)

    EDIT: I want to really stress that NetBIOS over TCP/IP should NOT be enabled on the connection that goes to the internet...

    If you enable that you give the whole world access to your file and printer sharing and all those insecure windows services ports!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...