Windows won't update

By tbabyboii
Dec 11, 2008
Topic Status:
Not open for further replies.
  1. I have windows XP.. and when i click on windows update it takes me to www.msn.com but when i go and look up windows update it wont take me to the page.? HELP? Here is my HiJackThis log
  2. mflynn

    mflynn Newcomer, in training Posts: 2,793

    Well your HJT log shows AVG at least partially disabled. A sign in some cases of Malware.

    Do not try to reinstall or fix it yet.

    Do the TechSpot 8 steps: http://www.techspot.com/vb/topic58138.html

    Skip no steps (do not install another virus scanner as you already have one).

    Most importantly update MalwareBytes and SuperAntiSpyware!

    Before you scan with SuperAntiSpyWare do the below:

    SuperAntispyware extra config

    After installed double-click the icon on your desktop to run it.

    Update the program definitions.

    Click the Preferences button.

    Then Scanning Control.

    In Scanner Options make sure all boxes are checked except #3 Ignore System Restore.. are checked:

    MalwareBytes extra config

    After update but before running
    Click settings and confirm all are Checked.

    I repeat Update these 2 programs.

    Run them and attach their logs.

    Mike
  3. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    after doing avast virus scanner.. i went to go check my c drive and d drive and came up with this message " windows cannot find 'resycled\boot.com' make aure you typed the name correctly, and then try again. To search for a file, click the Start button, and then click Search. What did I do?
  4. mflynn

    mflynn Newcomer, in training Posts: 2,793

    You already have a Virus scanner and I advised you not to attempt to repair it yet. Not good to have 2 virus scanners. We will fix AVG or uninstall it later.

    We will get to it!

    Ignore what you have there and get the rest of the 8 Steps.

    Mainly the MalwareBytes and SuperAntiSpyware.

    Mke
  5. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    Malware Logs

    Now i stilll have that problem with opening c: drive and d: drive
  6. mflynn

    mflynn Newcomer, in training Posts: 2,793

    Yes I figured that but let me look at the logs.

    Mike

    No wonder you have problems!

    OK you ran MBAM but you did not click next and delete what it found so the log states "No action taken".

    You will need to run MBAM again then when it finds them then delete/remove them. Post the new log.

    Then run MBAM again to confirm it finds nothing else after these cleared.

    Then go here and do this. Even tho you had no problen updating or running.
    http://www.techspot.com/vb/post684649-3.html

    Mike
  7. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    I did delete them.. that was the wrong log.. but i wll run malware again..

    tried to dowload fixit and told me the file was corrupt
  8. mflynn

    mflynn Newcomer, in training Posts: 2,793

    OK great now run it once more to confirm it finds nothing else that was hidden the first time.

    After you run the Special case Fixit, report back on the computer in general and the Drive C: issue.

    Mike

    EDIT: then there is still an issue as I just tested it and it is OK!
  9. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    still says it in corrupt what now

    malware showed nothing else... no more malware
  10. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  11. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    in the first set of registers the regsvr32 C:\windows\system32\mshtml.dll came up with a message "was loaded, but the dll register server entry point was not found. this file can not be registered.. and the next one was regsvr32 C:\windows\system32\msjava.dll had a message "load library (C:\windows\system32\msjava.dll) specified module could not be found.

    my windows update is working.. but i still cannot get into my C: drive or my D: drive and when i try to do msconfig is says windows cannot find 'msconfig' make sure it is spelled correctly and what not.. so what now
  12. mflynn

    mflynn Newcomer, in training Posts: 2,793

    As advised in post #8.

    Update and run MBAM and SAS again so they can finish what they missed and come up clean!

    Mike
  13. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    That is everything. malware came up with nothing. and i still cant get into my c: drive or my D: drive.. or run msconfig what now?
     
  14. mflynn

    mflynn Newcomer, in training Posts: 2,793

  15. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    i ran that and it says all associations ok.. and then i did the sas repairs and nothing happened... and i rebooted.. still cant get into anything
  16. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    well i ran avast and that is when the c: drive and the d: drive and the msconfig stopped working.. was it something that avast did?
  17. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    C: drive and d: drive wont work

    c: drive and D: drive wont open it says cannot find 'resycled\boot.com' make sure you have tryed the name correctly.. etc.. and my msconfig is not working either.. I did the 8 steps on my last thread.. but they dont help at all... HELP ME PLEASE.... It all started after i ran avast virus scanner...
  18. mflynn

    mflynn Newcomer, in training Posts: 2,793

    Hi tbabyboii

    Run HJT Scan only Select and remove the below
    O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - C:\Program Files\AVG\AVG8\avgssie.dll (file missing)

    Then give specifics as I am not there apparently you CAN run some things!

    Do you mean on the WWW or what?

    Specifics!

    Mike


    EDIT:
    Do this!

    ComboFix

    NOTE: If you have had ComboFix more than a few days old delete and re-download.

    Get it here: http://download.bleepingcomputer.com/sUBs/ComboFix.exe
    Or here: http://subs.geekstogo.com/ComboFix.exe

    Double click combofix.exe follow the prompts.

    When finished, it will open a log.
    Attach the log and a new HJT log in your next reply.

    Note: Do not click combofix's window while its running. That may cause it to stall.


    EDIT: Since this happened after Avast go back and do all of post #14 again and reboot!

    Mike
  19. mflynn

    mflynn Newcomer, in training Posts: 2,793

    Go back to your other thread and finish up.

    Mike

    Moderator Edit: Thread now merged
  20. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    here are your logs you need

    and the download in #14 says all associations ok..

    ok after doing all of those things.. when i go to run msconfig.. that still does not work. i still get the saying 'cannot find 'msconfig' make sure you typed the name correctly etc.... but getting into the c:drive from my computer and D: drive from my computer now work.. thank you for that. now what for the msconfig
  21. mflynn

    mflynn Newcomer, in training Posts: 2,793

    Well do a Windows search for msconfig*.* to see if it exists on the HD?

    We will find it but meantime if you need to handle your startups here nis something better:

    http://mlin.net/StartupCPL.shtml

    Mike
  22. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    that does nothing it just says the same thing.. cannot be found...
  23. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    If MSConfig is missing

    Go to C:\Windows\PCHealth\HelpCtr\Binaries\ and check if MSConfig.exe file is there or not. If it’s not there, you can copy it from another computer to the Binaries folder or if you only have Windows XP CD, open a command prompt window, insert your XP CD into the drive and enter the following command: (assuming D is your CD drive and C is where your Windows is installed)

    EXPAND -R D:\I386\MSCONFIG.EX_ C:\WINDOWS\PCHEALTH\HELPCTR\BINARIES

    That should restore MSConfig.exe to your Windows. IF MSConfig.exe is already there and you still can’t launch MSCONFIG from Run command, then the reference to the path within the registry may be wrong. Check this location in the registry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\MSCONFIG.EXE

    In the right pane, next to Default, it should show:

    C:\WINDOWS\PCHealth\HelpCtr\Binaries\MSConfig.exe

    ---------------------------

    Normal locations of MSConfig
    C:\WINDOWS\ServicePackFiles\i386
    C:\WINDOWS\$NtServicePackUninstall$
    C:\WINDOWS\PCHealth\HelpCtr\Binaries
  24. zipperman

    zipperman Newcomer, in training Posts: 1,423   +7

    C drive should be your OS.If Windows loaded then C drive in My Computer
    should be readable.
    D needs a disc in it to read.
  25. tbabyboii

    tbabyboii Newcomer, in training Topic Starter Posts: 34

    Thank you guys so much.... how do you copy it from another computer.. I cant seem to find my Windows XP cd.. now msconfig is in the C:\WINDOWS\ServicePackFiles\i386, and the C:\WINDOWS\$NtServicePackUninstall$ but not in C:\WINDOWS\PCHealth\HelpCtr\Binaries.....
    so yea thank you again so very much at least now i know where i can access it from not just from run.. msconfig... So i just copied and pasted it into the C:\WINDOWS\PCHealth\HelpCtr\Binaries and now it opens when i do run, msconfig..
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.