Windows XP SP3 I am trying to get e-sata recognized

By nickc
Feb 8, 2010
  1. Running an Asus P5Q mother board.

    I do not need a driver, all I need is to activate the AHCI in the BIOS of course when I do that Windows Blue screens before booting. I was told to disable the IDE driver in the Regestry, which will supposedly stop that I have been looking for either of these keys in the Bios because that is suppose to be where the IDE driver is the information came from Vista or Windows7. I cannot find it in my registry neither key Msachi or Iastorv. Can some one tell me what I am doing wrong



    any help will be appreciated
  2. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    If you are changing the SATA controllers from IDE mode to AHCI in the BIOS, usually you have to reinstall Windows.
  3. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    All I need to do is disable the IDE driver. Then I can enable AHCI in the Bios, and windows will recognize my E-SATA when I turn it on as it does a USB hard drive. I am not trying to set up a raid or anything I just want to be able to use this en closer with my backup hard drive like u would a usb hard drive encloser and drag and drop files into it, the other way I can set it up is plug it into a normal sata slot but then I have to reboot to get windows to see it and I have a couple of files that are 200 gig+ and a usb drive is way too slow to back them up.

    This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
    322756 ( ) How to back up and restore the registry in Windows
    To resolve this issue, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

    1. Exit all Windows-based programs.
    2. Click Start, type regedit in the Start Search box, and then press ENTER.
    3. If you receive the User Account Control dialog box, click Continue.
    4. Locate and then click one of the following registry subkeys:
    5. In the right pane, right-click Start in the Name column, and then click Modify.
    6. In the Value data box, type 0, and then click OK.
    7. On the File menu, click Exit to close Registry Editor.

    I guess it was good I went back and read it is enable the driver not disable. although I still cannot find that key.
  4. nickc

    nickc TechSpot Paladin Topic Starter Posts: 923   +11

    ok I did a little more studying, and I stated it right to begin with I have to disable the IDE driver to get windows to do what I want and that is not covered in that article could some one help me do this, diable the IDE driver.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...