TechSpot

Winrscmde and svchost.exe issues

Inactive
By RLong31
Feb 7, 2013
  1. Jay Pfoutz

    Jay Pfoutz Malware Helper Posts: 4,286   +49

    Any more issues?

    We need to know any other issues that are plaguing your computer. Kindly give a summary so we know how to continue from here.

    Many of the things to note for us would be:

    • Slow computer
    • Error messages
    • Fake antivirus alerts or the icon in the system tray
    • svchost.exe running at 100%
    • System crashes or blue screen of death

    Note: Absence of issues does not mean that you're protected in the future.
     
  2. RLong31

    RLong31 TS Rookie Topic Starter Posts: 20

    Still having the issue when I go to Control Panel, under Programs I click "Change Start-up Programs". I get the error "Software Explorers error : 0x80070005. Access is denied.

    Everything else seems to be ok.
     
  3. Jay Pfoutz

    Jay Pfoutz Malware Helper Posts: 4,286   +49

    Download Windows Repair (all in one) from this site

    Install the program then run it.

    Go to Step 2 and allow it to run CheckDisk by clicking on Do It button:

    [​IMG]



    Once that is done then go to Step 3 and allow it to run System File Check by clicking on Do It button:

    [​IMG]


    Go to Step 4 and under "System Restore" click on Create button:

    [​IMG]


    Go to Start Repairs tab and click Start button.

    [​IMG]


    Please ensure that ONLY items seen in the image below are ticked as indicated (they're all checked by default):

    [​IMG]

    Click on box next to the Restart System when Finished. Then click on Start.

    After it, let me know how it's going. :)
     
  4. RLong31

    RLong31 TS Rookie Topic Starter Posts: 20

    Still get the same error with change start-up programs.
     
  5. Jay Pfoutz

    Jay Pfoutz Malware Helper Posts: 4,286   +49

    Do you have User Account Control activated?
     
  6. RLong31

    RLong31 TS Rookie Topic Starter Posts: 20

    No, it is turned off.
     
  7. Jay Pfoutz

    Jay Pfoutz Malware Helper Posts: 4,286   +49

    Please take a screenshot of the specific area, so I may know exactly what you mean...
     
  8. RLong31

    RLong31 TS Rookie Topic Starter Posts: 20

    Screenshot1.jpg
    Under Programs in the Control Panel I try to click on Change Startup Programs....

    Screenshot2.jpg
    Then comes the Software Explorers error......


    Screenshot3.jpg
    Inside Windows Defender.... in the pull-down menu... all of the other options work... I.e. currently running programs, etc... it's only Startup Programs I can't access... so I can decide what comes on when windows starts up... to speed up start up a bit.


    Screenshot4.jpg
     
  9. Jay Pfoutz

    Jay Pfoutz Malware Helper Posts: 4,286   +49

    The following is only applicable to Windows Vista.
    1. Download AccessChk (Sysinternals). This tool allows you to evaluate the access level of specific users or groups of resources including files, directories, Registry keys, global objects and Windows services. Here's the link to download the tool: http://technet.microsoft.com/en-us/sysinternals/bb664922.aspx

    2. Save the zip file on your desktop, and extract the file:
    - Right click on the file, and select Extract All...
    - Click Next when prompted for the Destination.

    As a result, you should see a folder called AccessChk on your desktop.

    3. Open the folder AccessChk

    4. Hold the shift-key and right click in the window. Select "Open Command Prompt Here"

    5. A command prompt window should open with a similar prompt:
    C:\Users\<USERNAME>\Desktop\accesschk>

    6. Type the following command, and press Enter:
    accesschk.exe -s -n "nt service\trustedinstaller" -k "hklm\software\Microsoft\Windows\CurrentVersion\Component Based Servicing" >accesskchk.txt
    Tip: You should be able to copy and paste the command into the command prompt.

    7. Close the Command Prompt Window. Open the Accesschk folder on yoru desktop (if it has been closed).

    8. Double click on Accesschk.txt (the text file), this should open Notepad.

    If this does not help,

    1. Please download the subinacl.msi file from the following link and save the installation patch onto the Desktop:

    http://www.microsoft.com/downloads/...ed6985e3927b&displaylang=en#AffinityDownloads
    SubInACL (SubInACL.exe)

    2. Please go to the Desktop and double click the downloaded file.
    3. Please select the C:\Windows\System32 folder as the Destination Folder during the installation. Later we will use this tool to reset the permission settings on the current machine.
    4. Click the "Start" Button, in the "Start Search" bar, type: "notepad" (without quotes) and press Enter.
    5. Copy the following commands and then paste them into the opened Notepad window:

    Code:
    @echo off
     
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
    subinacl /subdirectories %SystemDrive% /grant=administrators=f
    subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
    subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
    subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f
    subinacl /subdirectories %SystemDrive% /grant=system=f
     
    [USER=154672]Echo[/USER] =========================
    [USER=154672]Echo[/USER] Finished.
    [USER=154672]Echo[/USER] =========================
    @pause
    6. After pasting the above commands, please close the Notepad window. Choose "Save" when you are prompted to save the file. Type "reset.bat" as the file name and choose "Desktop" from the left panel as the save location.

    7. Refer to the Desktop and right click the reset.bat file, then choose "Run as administrator."

    8. You will see a DOS-like window processing.

    NOTE: It may take several minutes, please be patient. When it is finished, you will be prompted with the message: "Finished, press any key to continue".
    Note: About some driver update installation procedure, we also received this error code, please reroute this kind of case to Vista System Team, because, it may regard for third party programs structure.

    Check for the updates after this.

    Hope this information is useful.
    This issue can be also caused by third-party security programs such as firewalls and anti-virus software. You can disable or remove them to check the issue.
    Copied From: Microsoft Answers Support Engineer
    http://social.answers.microsoft.com/Forums/en-US/vistawu/threads
     
  10. Jay Pfoutz

    Jay Pfoutz Malware Helper Posts: 4,286   +49

    Hello! Are you still with us? Your topic is now marked inactive, because you have lacked to reply.

    However, we'd like to still help. Please update us on the state of your PC.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.