XP Home error message on boot-up: System can't logon. Check user name & domain

By Poppa Bear
Aug 10, 2011
Post New Reply
  1. On booting into XP Home, the folowing warning message comes up: "System can't logon. Check user name and domain are correct."

    If the "OK" button is clicked on the warning box, it then allows the password to be typed in, and logs on.

    This error message occurs no matter what log on settings are chosen in User Accounts - with or without password required. And no matter whether the primary log on is set to administrator, user or visitor.

    Any help would be appreciated.
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,327   +49

  3. Poppa Bear

    Poppa Bear TechSpot Enthusiast Topic Starter Posts: 266

    Thanks for the input. Tried creating another user but this made no difference. I suspect the OS may be corrupt, so will try running XP installation disc and choose the "Repair existing installation" option at boot up from the disc.
  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    Hi PB

    just a guess... but if you're getting that error message on reboot it sounds as though you have your computer set to "Autologon" on boot and the autologon info is incorrect. (so autologon fails but manual logons work)

    Try resetting Autologon user/password info or even first try just turning Autologn off. (Are you familiar with the TweakUI tool to change autologon?)
  5. Poppa Bear

    Poppa Bear TechSpot Enthusiast Topic Starter Posts: 266

    Hi LooknAround, nice to be in contact again. Every tip you've given me so far has been a winner. Thanks to your suggestion I've used Revo Uninstaller umpteen times in my own installations and in helping other people solve their computer problems. Then there was the info on how to use Acronis to mount an image and the list goes on. I'm retired and live in a seniors retirement village and seem to have been appointed the computer helper for other retirees. Probably an age thing, but most people in the complex still use XP.

    Getting back to the thread topic, thanks for your input. And no I'm not familiar wtih TweakUI, though I've now downloaded it, however I won't be able to use it until I have access to my friend's PC again. Is it hard to use, or is it easier to switch off autologon manually, and if so, how would I do this?

    Cheers PB :)
  6. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    Hi PB

    Glad to hear you've found the other tips handy :)

    Normal Autologon change isn't too hard but it takes a registry edit - so one has to remember the registry key, be careful of registry errors, etc. TweakUI makes many UI changes quite easy (without any registry edits)

    > Download TweakUI. It installs itself in C:\Windows\system32
    > Navigate to the C:\Windows\system32 folder, double click to run TweakUI
    > in tweaki menu, click Logon->Autologon

    you'll find some other handy UI changes in it as well, if you ever need 'em

    /* edit */
    btw.. TweakUI will only work with XP
  7. Poppa Bear

    Poppa Bear TechSpot Enthusiast Topic Starter Posts: 266

    Thanks LookinAround.

    Have tried TweakUI on my own XP and found the tweak to turn off autologon. It really is a great utility. Thanks heaps. :D Wish I'd known about it when I was using XP as my main OS.

    Will report back after I get a chance to use it on the problem in my friend's PC.

    Cheers PB :)
  8. Poppa Bear

    Poppa Bear TechSpot Enthusiast Topic Starter Posts: 266

    Hi LookinAround,

    Sorry to take so long to get back on this issue. My friend had been away for a few weeks.

    Anyhow, I'm happy to report that once again you've done the magic, and your suggestion to use TweekUI has fixed the problem instantly.

    My friend has asked me to express his thanks to this forum, and to tell you in particular, that he is over the moon as this problem has bugged him for a long time. He is most grateful.

    Cheers PB :D ps if you were a politician you'd get my vote! LOL!
  9. WinXPert

    WinXPert TechSpot Booster Posts: 527

    Problem had been solved, anyway I like to add another solution

    Start | Run | control userpasswords2

    uncheck Users must enter a user name and password to use this computer

    Ok
  10. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    Hi PB

    Thanks for the update. Glad to hear it helped :)
  11. Poppa Bear

    Poppa Bear TechSpot Enthusiast Topic Starter Posts: 266

    Thanks WinXPert, reticked the logon using TweakUI and then disabled it using the run command and it achieved the same result as TweakUI.

    Cheers PB :)
     
  12. WinXPert

    WinXPert TechSpot Booster Posts: 527

    Same solution, different approach. :)


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.