TechSpot

XP Pro home network

By Psychobiker
May 25, 2005
  1. OK -
    Two comps, both running XP Pro. One's hardwired to a router (and then connected to the ADSL router) and the other's wirelessly connected.
    The internet is shared perfectly between the two, so no problems on the hardware side.

    But I've shared both HDDs, can't see the computer from the Entire Network window, yet it will find it as a printer..., giving me the typical message of 'incorrect printer/typed the name wrong' etc.
    Any tutorials or step-by-steps to solve the prob? I want to be able to acces the whole of both hard drives and also the printer (connected to the hardwired machine) from both machines.

    Ta!
    L
     
  2. Psychobiker

    Psychobiker TS Rookie Topic Starter Posts: 67

    nnnnagh TTT
     
  3. Tonkyboy

    Tonkyboy TS Rookie Posts: 33

    Switch off your firewall's first, then try and find each machine. I had one a few weeks back, both XP Pro, wirelss laptop and a PC, and although the firewalls had been told to let them through, it didn't until I switched them off, and then after the network was sorted, turned firewalls on again.

    But, your router may be a hardware firewall, so do you need software firewalls ?

    Worth trying.
     
  4. Psychobiker

    Psychobiker TS Rookie Topic Starter Posts: 67

    Tried. Nada. Pings, but refuses to port 137 both ways!
    Ugh! Anywhere where I can find tutorials? Where do I disable EVERY firewall?
    Is it right they should both have the same IP?

    L
     
  5. Tonkyboy

    Tonkyboy TS Rookie Posts: 33

    No. Separate IP's is normally a good idea. Or set to automatically generate IP addresses.

    Don't much like the sound of "EVERY firewall". You shouldn't have more than one firewall running on a single PC. In control panel, switch of the Windows firewall for a start. What others are you using ? I don't know where you'd find a tutorial, sorry.
     
  6. Psychobiker

    Psychobiker TS Rookie Topic Starter Posts: 67

    OK cool. How do I make separate IPs?
     
  7. crshoveride1

    crshoveride1 TS Rookie Posts: 24

    Sounds like you set up Static IP's? Maybe better if you set them up to automatically get IP's from DHCP. Each PC needs to be different. If you want to keep them static thats fine. Just make the last 3 digits of the IP different. Eg. .101 and .102

    If you had them set to the same IP I'm surprised you were able to ping the IP. That would mean you were pinging the local machine.

    You shouldn't need to turn off ''all'' firewalls. Just the ones on the machines. Leave the one for the router(s) on.

    Do a search for computer(s) and search the computer name. Windows should see it. It may take a bit for it to show in the Network Connections folder.

    What router are you using and is it connected to a modem or to another router?
     
  8. Psychobiker

    Psychobiker TS Rookie Topic Starter Posts: 67

    OK - ADSL Modem goes into Router, which is hardwired, and the other comp wireless to it. Ipconfig tells me that the IP there is identical, just one PC is .100 and the other .101
    But I pinged that and nothing, I went to www.whatismyip.com and pinged the address I got there - and got a response. WTF's going on! It doesn't see the other comp at all

    L
     
  9. crshoveride1

    crshoveride1 TS Rookie Posts: 24

    It may not matter, but do you have a workgroup set up for your network? Make sure that both machines are in the same workgroup as well.
     
  10. whizkid_kamlesh

    whizkid_kamlesh TS Rookie

    ok heres what u do.. step by step...

    1. dude i think its better if u have a static ip address.. that way its easy to identify both systems.. give them addresses in between like this 192.168.1.X where x can be 2,3,4... etc.

    2. check if both the systems are in the same workgroup, coz its required. i have similar setup at home, only difference, one is in ethernet, other usb. both systems are in MSHOME workgroup.. u can give ur own workgroup.

    3. you need to enable the peer-to-peer services in both systems. do this ->
    go to Start->Control Panel->Add/Remove Programs. Select the 'Add/Remove Windows Components from the tab at the left. Scroll down and double click on "networking Services" and make sure all the components are selected in it (especially peer-to-peer networking). [ This is for win xp ]

    4. go to Administrative Tools in Control panel and select the Services tab. Scroll down to find Peer Networking Service and double click.. make the startup type as manual and click on start button. [ This is optional and may or may not be required ]

    5. "disabling firewall" is a big threat as it may enable the network.. but also open doors to many infectations, rather, do this:

    * if ur using Windows firewall, go to windows firewall in Contol Panel and select On (recommended) . Then go to Exceptions tab and make sure there is a tick on the entry "File and Printer Sharing".

    * if ur using some Antivirus.. u need to check the Advanced Options of it and disable any service that blocks file or printer sharing, or peer networking...

    thats it..
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.