ATI Catalyst Radeon Display Driver 3.10

By Payam Rashidi on December 18, 2003, 1:14 AM
ATI has released a newer version of the Catalyst drivers which includes support for the OpenGL Shading Language.

OpenGL Shading Language Support:
This release adds support for the OpenGL Shading Language (GLSL), a flexible, forward-looking, and hardware-independent high-level graphics programming language. The OpenGL Shading Language, defined as an open standard by the OpenGL Architecture Review Board, allows application developers to take advantage of the powerful programmable vertex and pixel processing units present in the 3D graphics system. Open languages offer developers the fastest route to using the latest graphics hardware features.

You can download the driver from the links below.

-[URL=http://www.techspot.com/drivers/index/file/information/2417]ATI Catalyst Radeon Display Driver 3.10 (Windows 2000/XP)[/URL]
-[URL=http://www.techspot.com/drivers/index/file/information/2418]ATI Catalyst Radeon Display Driver 3.10 (Windows 98/ME)[/URL]

Thanks to [URL=http://www.techspot.com/vb/index.php?s=]Didou[/URL] for bringing this to our attention.




User Comments: 27

Got something to say? Post a comment
Krugger said:
i haven't been happy with the last 3 releases... i'm not going to even bother with this one. i have an older card though, so until i get a new one i guess i can't really complain. it does what i need it to for the most part. ATI's support is top notch, unfortunately there are so many cards and so many games... it's hard to be perfect. every problem that is found ppl yell and scream, and the people with problems are always the loudest.
Curl said:
Luckily I haven't had any problem with any of the CATALYST releases. Nothing but steady performance improvements for me
poertner_1274 said:
I have been skeptical of trying them, because my current setup is working fine and I have heard a few horror stories about them. I hope they keep getting better though, and it seems with this open source new technology it might. Keep it up ATI.
MrGaribaldi said:
Nice work...Maybe I should think about updating to DX9b and Cat 3.10... (Currently using 3.6 or something like that with DX9a)
olefarte said:
I too am a little skeptical. I've got them downloaded, but after seeing all the problems others are having, I think I'll wait a while before installing them. I've always been one of those guys who installs any update the first day it's out, but the 3.8 Cats broke me from doing that. They have to be the worst drivers I've seen yet from ATi, since I've owned an ATi card. I'm using the updated 3.9s now and they are working fine, except for a little corruption while playing Deus Ex 2, which I can live with, so I think I'll wait a while.It seems to me that since the 3.7 release, ATi has been having there share of driver prolems. I hope this is not a trend.
---agissi--- said:
Sweet this will go well with my new 9600 :D Thanks.
BrownPaper said:
they fixed the problem from cat 3.9 where openGL would not work with AIWs. the 3.9s were bad for me as a result. the CoD hotfix fixed that problem but this cat 3.10 release is offical. i have been happy with the performance and stability of the cat 3.10 so far.sometimes people with problems directly blame the drivers before looking at other possible culprits. logically troubleshooting is the key. some people with problems get way too emotional and are so angry that their judgement is clouded. if you are positive that the drivers are shoddy on your setup, keep a cool head and revert to your previous drivers.
Masque said:
Anybody else try these yet? I'm still running stable, but I might give these a try. I'm kind of a glutton for punishment. ;)
Curl said:
I upgraded to the CAT 3.10s on release and they have been working great for me. Even smoothed out my Deus Ex 2 a tad bit.olefarte, what corruption are you seeing in Deus Ex 2?
olefarte said:
[quote]olefarte, what corruption are you seeing in Deus Ex 2?[/quote] Really only in the ingame movies. But I can live with that, since I have every setting in the game maxed and on my video card, same thing except AA at 4x and Aniso at 8x.What I'm seeing in the ingame movies is severe artifacting when a person is talking and moving. It's very bad. I'm going to try the 3.10's, just haven't had time to do it yet.Also, after installing the Deus Ex 2, 1.1 patch, the artifacting is worse that before.
chuonthis said:
Are you overclocking your card? The artifacts may be from too high of a core or memory speed.
olefarte said:
[quote][i]Originally posted by chuonthis [/i]Are you overclocking your card? The artifacts may be from too high of a core or memory speed. [/quote] No, I'm not overclocking anything, but I still haven't gotten around to the new 3.10 Cat. drivers yet. Maybe that will help. Anyway, I'm not to concerned about the ingame movie graphics, the gameplay is okay.
Josiiah said:
Interesting, Ill be upgrading my vid drivers soon, Ill let you know how it goes on the amd/nforce2/9700 side of things.
khosw said:
Can I install these on a sapphire radeon 9500 board, that is softmodded to 9700 Pro or not?
XtR-X said:
I tried to download this from ATI and supposedly it was only for RAGE 128 but not RADEON 128. Does this work for say a Radeon 9700 Pro?
TS | Thomas said:
Errm, the Catalyst Drivers are for ATi Radeons, not for old stuff like the Rage 128.
chuonthis said:
khosw, you can go [URL=http://www.ocfaq.com/softmod/download.php]here[/URL] to download softmodded versions of these drivers.XtR-X, if you have any Radeon card, then the CATALYST drivers are for you.
Federelli said:
For those who must know, i have no problems with these drivers at all, and they work amazingly well performance wise :D
poertner_1274 said:
I still don't see the need to update, if there isn't anything wrong....If it ain't broke then don't fix it.I can understand if they say it could fix some things, but what if it doesn't on your system? Just the possibility doesn't make me want to update.
Federelli said:
It does fix Call of Duty, and performance is much better in Sw: KOTORPlus, you have the shading stuff in Opengl which is great for programmers and apart from one missing extention (gl_ext_shadow_funcs) Ati's DX9 series is fully OGL 2.0 compilant for now that is... you know we have to wait for the final specs
olefarte said:
Well, I finally got around to loading the 3.10's, and I'll have to say, they look pretty good. The good part is COD and Max Payne 2, look better than ever, every time i play these games, I'm amazed. The bad part is, after playing COD, I realize again how bad Deus Ex 2 looks, although I don't get as many artifacts in the ingame movies. I swear, I just can't get into this game. Back to COD.
Krugger said:
i'm gonna take the 3.10 plunge, hopefully they fixed some issues i've been having. i won't hold my breathe tho.
Federelli said:
Don't be afraid, they are sure an improvement over 3.8 and 3.9.And on a side note, Olefarte, your so right, what have they done with DX2?!?! it's because that x-box port
Masque said:
[quote][i]Originally posted by poertner_1274 [/i]I still don't see the need to update, if there isn't anything wrong....If it ain't broke then don't fix it.I can understand if they say it could fix some things, but what if it doesn't on your system? Just the possibility doesn't make me want to update. [/quote] It DOES fix a slew of games.....the key would be to scan the list and see if you run any of them. It's also possible that there are issues you're not aware of that may actually be there. Some peeps have seen things that they thought were normal that really aren't. Best thing though is to read the FAQ on the drivers.Just my $.02
MaskedBurrito said:
They've all worked fine for me. Minor problems with Call of Duty but nothing a little digging doesn't solve. I'll be sure to DL this one too.
Krugger said:
[quote][i]Originally posted by Federelli [/i]Don't be afraid, they are sure an improvement over 3.8 and 3.9.And on a side note, Olefarte, your so right, what have they done with DX2?!?! it's because that x-box port [/quote] well, my fear has to do with the fact that 3.9 wouldn't install for me, i needed the hotfix version before i could even get them installed. and the previous two, well i couldnt play NWN with them, as it resulted in my computer becoming frozen everytime, immediately when i alt tabbed or got sent back to the desktop... maybe not the biggest deal, but it was one of the only games i was playing. i've been waiting for several fixes that just dont happen, but thats fine cause i have an old old radeon and know that's not their target.
olefarte said:
For me the 3.8's wouldn't work on much of anything, went back to 3.7's. When the 3.9's came out, COD wouldn't load past the menu, crash back to the desktop. The 3.9 update fixed that problem. So far, no problems with the 3.10's, they work great for me.
Load all comments...

Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...
Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.