Software Windows 10 20h2 disconnects modem frequently

Hi everyone, am just signed up here after finding this place has been providing solutions to tech problems
starting off here's my pc spec (windows specifications)
Edition Windows 10 Pro
Version 20H2
Installed on ‎6/‎23/‎2021
OS build 19042.1052
Experience Windows Feature Experience Pack 120.2212.2020.0

After an update form windows 10 version 2016 to 20H2, everything is working normally except for the modem connectivity that randomly disconnects from the internet (as referred to soft disconnects). Even after a successfully connection, there is no packets of data received.
In the previous version of 2016 there was no such issues that I now encounter with this version 20H2,

I tried editing the group policy (computer configuration>administrative template>windows connection manager>Minimize the number of simultaneous connections to the Internet or a Windows Domain and Enable Windows to soft-disconnect a computer from a network ) but nothing worked

I WILL BE GRATEFUL FOR YOUR RESPONSE
THANKS.
 

Kshipper

Posts: 618   +140
TechSpot Elite
How do you know it's the modem that is disconnecting? Do you mean cable modem or do you mean a dial up modem over phone line? Open a CMD window and use this >> ping www.google.com -t

That will say hello to Google endlessly which should keep a dial up modem from dropping the connection.
 

Avro Arrow

Posts: 1,800   +2,154
TechSpot Elite
How do you know it's the modem that is disconnecting? Do you mean cable modem or do you mean a dial up modem over phone line? Open a CMD window and use this >> ping www.google.com -t

That will say hello to Google endlessly which should keep a dial up modem from dropping the connection.
Good call! I've personally NEVER used a dial-up modem with anything newer than Windows 98.
 

wiyosaya

Posts: 6,523   +4,909
Hi everyone, am just signed up here after finding this place has been providing solutions to tech problems
starting off here's my pc spec (windows specifications)
Edition Windows 10 Pro
Version 20H2
Installed on ‎6/‎23/‎2021
OS build 19042.1052
Experience Windows Feature Experience Pack 120.2212.2020.0

After an update form windows 10 version 2016 to 20H2, everything is working normally except for the modem connectivity that randomly disconnects from the internet (as referred to soft disconnects). Even after a successfully connection, there is no packets of data received.
In the previous version of 2016 there was no such issues that I now encounter with this version 20H2,

I tried editing the group policy (computer configuration>administrative template>windows connection manager>Minimize the number of simultaneous connections to the Internet or a Windows Domain and Enable Windows to soft-disconnect a computer from a network ) but nothing worked

I WILL BE GRATEFUL FOR YOUR RESPONSE
THANKS.
I use a modem in a PC for caller-id. It has been my experience that most every Windows update overwrites the drivers for that modem. I have had to save the registry entries and re-apply them every time.

If you had a driver disk come with the modem, you might try reinstalling the drivers for the modem. I do not know that will work, but it might be worth a try.
 
I think the problem may not be to the driver , as for other modem connection managers such as TTNET connection manager connects to internet without disconnecting but it only lasts for a few minutes. in some cases it connects in accordance with the data packets transferred are above 5mb/s
 

Kshipper

Posts: 618   +140
TechSpot Elite
I can't see the version of Windows causing this but it's easy enough to install the older one if you still have it, or maybe bump up to version 21H1? Do you have other devices on the network too that you can test with? It could be a coincidence that the Internet is now going down since the upgrade. Maybe some of the networking equipment is getting too warm? Can you point a fan at the modem and/or switches?
 

Avro Arrow

Posts: 1,800   +2,154
TechSpot Elite
I think the problem may not be to the driver , as for other modem connection managers such as TTNET connection manager connects to internet without disconnecting but it only lasts for a few minutes. in some cases it connects in accordance with the data packets transferred are above 5mb/s
I'm wondering if it's possible that there's a problem with the phone line itself. I remember back in the day (like early 90s) that sometimes if a phone line was a bit unstable, it would generate a sound that the modem would interpret as a disconnect. It wasn't really a disconnect and wouldn't affect a voice call but modems could be sensitive to it.

It's probably not the problem but I just thought I'd throw it out there as a possibility if you can't find the problem within the computer itself. It would be a weird coincidence with it happening at the same time that you changed your Windows version but I've seen stranger things happen.