Directx9.0c will install but not show up in dxdiag

By tecpalsovic
Oct 8, 2007
  1. hi everyone,
    great site you have here. i have been reading a lot of the treads and posts and some good info here. i have a roblem with dx9.0c not working. i install it but when i run dxdiag its shows dx9.0b. i had trouble try to load nfs carbon. it would load the flash page i believe its called and then nothing would happen. i ran ea support and they said i need dx9.0c but i had 2 other games splinter cell chaos theory and hitman blood money running fine before this and they say that they need dx9.0c. anyway got really sick of it not working that i refomatted my c: drive. reloaded my games on and now nun of them will load. i have all the lastest drivers etc as i did read some of the dx problem threads but it still wont upgrade to 9.0c. here is some of my dxdiag test results. any help would be greatly appreciated.

    Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2, v.2096 (2600.xpsp_sp2_rc1.040311-2315)
    Language: English (Regional Setting: English)
    System Manufacturer: GBT___
    System Model: AWRDACPI
    BIOS: Award Modular BIOS v6.00PG
    Processor: AMD Athlon(tm) XP 2700+, MMX, 3DNow, ~2.2GHz
    Memory: 1536MB RAM
    Page File: 178MB used, 3256MB available
    Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 9.0b (4.09.0000.0903)
    DX Setup Parameters: Not found
    DxDiag Version: 5.03.2600.2096 32bit Unicode

    DxDiag Notes
    DirectX Files Tab: No problems found.
    Display Tab 1: No problems found.
    Sound Tab 1: No problems found.
    Sound Tab 2: No problems found.
    Music Tab: No problems found.
    Input Tab: No problems found.
    Network Tab: No problems found.

    DirectX Debug Levels
    Direct3D: 0/4 (n/a)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (n/a)
    DirectMusic: 0/5 (n/a)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

    Display Devices
    Card name: RADEON 9550 (Omega 3.8.413)
    Manufacturer: ATI Technologies Inc. (Omega 3.8.413)
    Chip type: ATI Radeon Graphics Processor AGP (0x4153)
    DAC type: Internal DAC(400MHz)
    Device Key: Enum\PCI\VEN_1002&DEV_4153&SUBSYS_40501458&REV_00
    Display Memory: 256.0 MB
    Current Mode: 800 x 600 (32 bit) (60Hz)
    Monitor: Plug and Play Monitor
    Monitor Max Res: 1600,1200
    Driver Name: ati2dvag.dll
    Driver Version: 6.14.0010.6719 (English)
    DDI Version: 9 (or higher)
    Driver Attributes: Final Retail
    Driver Date/Size: 9/28/2007 08:06:54, 268800 bytes
    WHQL Logo'd: n/a
    WHQL Date Stamp: n/a
    VDD: n/a
    Mini VDD: ati2mtag.sys
    Mini VDD Date: 9/28/2007 08:06:34, 2418688 bytes
    Device Identifier: {D7B71EE2-0213-11CF-D76D-5A60A1C2CB35}
    Vendor ID: 0x1002
    Device ID: 0x4153
    SubSys ID: 0x40501458
    Revision ID: 0x0000
    Revision ID: 0x0000
    Video Accel: ModeMPEG2_C ModeMPEG2_D

    I also read on 1 of the threads that sp2 had directx9.0c on it and i have it, so cant understand why it still shows ver. 9.0b
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...