External hard drive driver suddenly 'not installed'

By MD3000
Dec 15, 2013
Post New Reply
  1. This is driving me crazy. My Maxtor ext drive (USB) is not listed in My Computer or Disk Management but IS listed in Device manager. It was working fine until after I cloned my old c drive onto a bigger internal drive. I can't see how this could affect it though.
    Disk Manager says 'No Driver Installed for this device' , but when I click on Properties/Driver details there are a number of entries with green ticks.
    I tried to uninstall the device but this just freezes Computer Management. The PC will then not shut down completely.

    The drive works fine on all other PCs.

    Any ideas?
    Thanks

    Attached Files:

  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Based on your symptoms and data in your screen shot, I'm guessing you had Acronis True Image installed at one point and then removed it?

    The snapman.sys driver file shown in your screen shot is part of Acronis TI.

    Let me know if my guess is correct.. then I can explain what happened and how to fix it.
  3. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    My bad. :confused:

    My brain just snapped by into gear.... The problem may not be exactly what I thought it was... but Acronis may still be part of the problem

    Is it still installed?
  4. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    It could well have had Acronis installed, I don't recall doing it though. I did install a free cloning/image app (forget the name ) to clone c drive. I then installed Partion Magic to combine partions on the larger newly clone drive but this did not work so uninstalled it. I then wiped the new drive then installed a Seagate app to re-clone the old c drive with correct partitions. Is this relevant? Since posting I have discovered pc will randomly not recognise other ext hard drives as well. USB sticks are ok.

    I am also getting 'Procedure Entry Point Not Found in Msvcrt.dll File' on start up.

    Thanks for trying to help.
  5. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    1. As best as you can recall, Did the Msvcrt.dll error start about the same time as the Disk problem? Or start a different points in time

    2. Look in Add/Remove Programs (or Programs and Features). Do you find Acronis True Image? or ANY other Acronis True Image product still installed?

    3. Download Filter Driver Load Order to your Desktop. Run it. Select your USB drive, the click Clipboard. Then paste the info to your next post
  6. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Ok, Nothing called Acronis on this system. Never has been. I do have Acronis on another PC but not used. There is an Acronis entry on the attached Seagate usb drive text file. I don't know why. Maybe I tried using Acronis on the other system that this drive is usually connected to.This drive works fine on both systems, though it sometimes fails to load when I try to connect then remove the Maxtor drive on this dogy xp. This process causes the PC to hang. It then won't switch off properly.

    I have attached the Maxtor USB text file as well.

    The Procedure Entry Point Not Found in Msvcrt.dll File error started before any cloning action. It came out of nowhere... or maybe just after I downloaded cloning software. Hard to remember. I have downloaded and replaced the old 'wint32u.dll' but no effect. The new one was twice the size of the old one. Seems odd.
  7. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Did you forget to attach the text data from the Filter Driver Load Order Report (post #5)
  8. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Yes, but posted below

    Attached Files:

  9. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Fyi editorial note: No need to quote prior posts unless there's something specifically in there you want to highlight in your next post.

    That said. Bingo!@ Yea, I think I see the problem. But hang tight till I have a chance to write more either tonight or more likely sometime later tomorrow.
  10. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    snapman.sys and visflt53.sys are both Acronis disk driver files.

    This is what I think is happening
    > Both snapman and vidsflt53 are both defined in the registry as disk driver files
    > The file snapman.sys is till stored on disk but visflt53.sys has been removed

    So Windows is trying to find a driver file that no longer exits. (I;ve seen Acronis and well as some other apps that uninstall but still leave remants behind that cause problems.)

    Double check
    1) Look in CtlPnl->Program and Features again double check if Acronis is listed or not?
    2) Then look to see if c:\windows\system32\drivers\snapman.sys and c:\windows\system32\drivers\vidsflt53.sys are stored on disk. (I believe snapman exists, vidsflt53 does not)

    Let me know result of above and then I'll tell you how to fix the file references in your registry that are causing problems
  11. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Ok, Acronis not listed in Add/ remove programs list. (XP)
    snapman.sys is there, vidsflt53.sys is not.
    Over to you! :)
     
  12. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    This fix requires modifying the registry. So, create a System Restore point before proceeding (just to be safe)

    NOTE to anyone else reading:! The following instructions are specific to MD3000. Someone else may require different changes to their Upper and Lower Filters.
    • Open an administrative command prompt. Type regedit
    • Carefully navigate to registry key
      Code:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}
    • Verify you arrived at the right key. If at the right key, you should see a subkey / value pair towards top of the list that reads
      Code:
      Class    REG_SZ    DiskDrive
    • Right click LowerFilters select Delete
    • Right click UpperFilters select Modify.... Edit value data such that only PartMgr is there. When done they subkey/value should read
      Code:
      UpperFilters   REG_MULTI_SZ   PartMgr
    • Click File->Exit to close regedit. Reboot. Now check your USB drive again
  13. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    You did it! Drive is now running on this system. I still have the Procedure Entry Point Not Found in Msvcrt.dll File error on start up but this does not seems to cause any issues, apart from being irritating.
    Can't thank you enough for your help. :D
  14. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Yippeee! High Fives! We did it,
    [​IMG]
    I probably won't have time to followup with msvcrt.dll till the weekend... but we'll try tackle that one too!
  15. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Well I didn't do much apart from follow instructions.
    Thanks again!
  16. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    You're very most welcome! I'm honestly just happy to have helped.

    We'll start Part "Deux" : Tale of the "Misbehaving msvcrt.dll" in few days :)
  17. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    Hi @MD3000

    Let's see what we can do about that annoying msvcrt.dll message

    Does any other information appear in the error message window? Anything useful in the title bar across the top of the window?

    Then see How to Create and Event Viewer report. We'll check to see if Windows left any clues there
  18. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Hey, very sorry I did not spot your post! Strangely no email alert this time.
    There is no other information apart from what I have already posted. I have uploaded the event report. I am guessing it will make more sense to you than to me! There is another unrelated error in the list about printing failures. This has been on the system for ages, I fix it by turning printer off and on.

    Attached Files:

    • VEW.txt
      File size:
      15.4 KB
      Views:
      2
  19. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    I don't know if it's related to your error or not but there's one interesting System error that keeps re-occurring (you might check the date/times against how often you see your error message)
    Code:
    Event: 7026 Source: Service Control Manager
    The following boot-start or system-start driver(s) failed to load:  avgtp 
    Do you have AVG installed? Is it the paid or free version?

    > Download AVG Remover then disconnect from internet
    > Uninstall AVG. Reboot. Does the problem still occur?

    > You can reinstall AVG see if problem returns
  20. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Ok, removed AVG (free) and reboot but error still there. Now reinstalled AVG.
    Latest VEW file uploaded
    Is this not the line which is relevant?:
    og: 'Application' Date/Time: 30/12/2013 13:21:27
    Type: warning Category: 0
    Event: 1517 Source: Userenv
    Windows saved user MARKPC\Lenovo Loan registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. The registry will be unloaded when it is no longer in use. This is often caused by services running as a user account, try configuring the services to run in either the LocalService or NetworkService account.

    Attached Files:

    • VEW.txt
      File size:
      16.2 KB
      Views:
      2
  21. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    I don't think that event would cause the error you see on startup. That event occurs at log off. It has to do with a program or service having a registry key open when windows wants to log you off and close the registry.

    Are you still running XP? You can install User Profile Cleanup Service from M$

    As to the error message you see on startup,
    1) Try booting into Safe Mode. Does the message go away?
    2) If yes, the start XP in a clean boot. Is message still gone?

    If yes, then you can follow the instructions in clean boot debugging to try and determine which program startup is causing the message to occur
  22. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Whoops. Brain reboot. There is more info on the warning banner. Teamviewer.exe causes this when it loads on start up so will do an un/reinstall before trying your steps
  23. MD3000

    MD3000 Newcomer, in training Topic Starter Posts: 26

    Uninstall of Teamviewer got rid of alert. Did a reinstall, error back. It does not seem to affect the operation of this app. I installed User profile Cleanup as well, but error still there on reboot. Here is the full text:
    TeamViewer.exe - Entry Point not Found
    The procedure entry point_except_handler4_ common could not be located in the dynamic link library mscvrt.dll
  24. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,361   +167

    I'm wondering what version you're running of the dll. Let's check a few things
    1) You're running XP Service Pack3, 32 bit, yes?
    2) All critical Microsoft updates are installed?
    3) For Teamviewer, click Help->About. I have v9.0.24951

    Next we'll check the version of msvcrt.dll in system32 and dllcache. To find the dllcache folder see HERE to first show hidden files and Folders. Locate files
    C:\Windows\System32\msvcrtl.dll
    C:\Windows\System32\dllcache\msvcrt.dll

    For each file, right click Properties->Version.

    I see v7.0.2600.5512, Copyright Microsoft for both files
    EClyde likes this.
  25. EClyde

    EClyde TechSpot Enthusiast Posts: 143   +12

    Wasting valuable bandwidth. LookinAround deserves double kudos for his help
    LookinAround likes this.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.