External hard drive not showing in My Computer

By proquals
Apr 3, 2013
Post New Reply
  1. HELP!!!

    I have a 500gb external hard drive which, up until a few days ago, was working absolutely fine.

    When I would plug it in to my laptop the device was found under 'my computer'.but would not open. Instead when I tried to open it my computer froze and the 'not responding' message was shown, resulting in a forced close of my computer. Now when I attach the hard drive and open 'my computer' the hard drive does not show at all, but 'my computer' still shows the message 'not responding', resulting in a forced close.

    I've been on to a couple of forums already and tried the route of right clicking 'my computer', 'manage' and 'disk management'; but the hard drive does not appear there.

    I'm at a total loss what to do and would massively appreciate your help as I have backed up company data on to this hard drive.

    Thank you in advance!
  2. TheHawk

    TheHawk TechSpot Enthusiast Posts: 191   +7

    Hey pcrquals. I would try the drive in another pc to narrow down where the problem is, a problem with the drive itself, or a problem with the pc recognizing the drive, which might be a problem with the USB port(s) or with the USB drivers. Does another USB device like a flashdrive work when plugged into the same port?
  3. raybay

    raybay TechSpot Evangelist Posts: 10,716   +6

    Is this a drive you formatted and set up? Or is this a store bought item in a case with a brand name?
    The store-bought drives in enclosures have a very bad history... among the worst failure rates in computer-dom... Unless you have a lot of valuable data on it awreddy, test it on another machine... then if non-working stop while you are ahead, and build your own from a good Western Digital or Sealate with an enclosure from someplace like Directron.com or NewEgg or Frys, or CDW.com.
  4. Barradice

    Barradice Newcomer, in training

    @The Hawk : I have a similar prob with my ext Iomega 1GB HD. Have been using it for a long time on my laptop but suddenly is not recognized on my computer. I try to follow previous fixes such as I go to Disk Management, find my device there and says it is unallocated. When I right click only gives me the option of New Simple Volume. There is a smaller box to the left and when I right click on that gives me the options of Convert to dynamic disk or GPT disk. Where to go from here?? Any Help is greatly appreciated :)


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.