TechSpot

Gentoo, iwconfig, ndiswrapper, plus other problems

By Devcon
Nov 12, 2008
  1. [SOLVED] Gentoo, iwconfig, ndiswrapper, plus other problems

    I have all sorts of problems tonight. I will begin by explaing my setup as best I can.

    Distribution: Gentoo kernel 2.6.27
    Wireless Management: wireless-tools & wpa_supplicant (just trying it out) and ndiswrapper 1.53

    Hardware:
    Target Machine: Inspiron 8200 with a Marvell 8335 Wireless PCMCIA adapter
    Network: Netgear MRV814 Router, Speedtouch 330 ADSL modem
    ICS Host Machine: Running XP SP3 with Internet Connection Sharing enabled. Obviously, the modem is connected directly to the host computer and the router is just acting as bridge to the ICS gateway.

    As a preface, ICS works perfectly fine. I can connect to the internet through my wireless router with no problems. The problem, is that I can not access any MSN services or websites I believe as a result of the MTU setting. So now we continue with some terminal output...

    #lspci
    Code:
    03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)
    #ndiswrapper -l
    Code:
    mrv8335 : driver installed
    	device (11AB:1FAA) present
    
    #ifconfig
    Code:
    wlan0     Link encap:Ethernet  HWaddr 08:10:17:02:0d:39  
              inet addr:192.168.0.194  Bcast:192.168.0.255 Mask:255.255.255.0
              inet6 addr: fe80::a10:17ff:fe02:d39/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:264 errors:0 dropped:0 overruns:0 frame:0
              TX packets:267 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:252933 (247.0 KiB)  TX bytes:19569 (19.1 KiB)
              Interrupt:11 Memory:f4010000-f4020000
    
    #iwconfig
    Code:
    lo        no wireless extensions.
    
    sit0      no wireless extensions.
    
    wlan0     IEEE 802.11b  ESSID:"NDAWHOUSE"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:09:5B:52:89:42   
              Bit Rate=11 Mb/s   Sensitivity=-200 dBm  
              RTS thr=2346 B   Fragment thr=2346 B   
              Encryption key:off
              Power Management:off
              Link Quality:50/100  Signal level:-64 dBm  Noise level:-96 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    As you can see, the MTU is currently set to 1500. The optimal MTU for PPOE ADSL connections is 1492. I believe that the host ICS computer is set to 1492; however, I will need to get back to you guys on that one. The current symptoms on the target I8200 machine are as stated, no access to msn services, and a seemingly slower connection over time. I have been googling for some time on changing the MTU with little success.

    My current config files that are applicable:

    /etc/conf.d/net

    -I know this is not set up right at the moment. I'm learning.

    Code:
     
    
    # This blank configuration will automatically use DHCP for any net.*
    # scripts in /etc/init.d.  To create a more complete configuration,
    # please review /etc/conf.d/net.example and save your configuration
    # in /etc/conf.d/net (this file :]!).
    
    ##################
    #Ethernet Config
    ##################
    
    config_eth0=( "null" )
    
    ##################
    #Wireless Config
    ##################
    
    config_wlan0=( "192.168.0.2/24" )
    routes_wlan0=( "default via 192.168.0.1" )
    essid_wlan0="NDAWHOUSE"
    config_NDAWHOUSE=( "192.168.0.1/24 brd 192.168.0.255" )
    routes_NDAWHOUSE=( "default via 192.168.0.1" )
    dns_servers_NDAWHOUSE=( "192.168.0.1" )
    
    ##################
    #WPA Supplicant
    ##################
    
    modules=( "wpa_supplicant" )
    wpa_supplicant_wlan0="-Dndiswrapper"
    
    # It's important that we tell wpa_supplicant which driver we should
    # be using as it's not very good at guessing yet
    /etc/wpa_supplicant/wpa_supplicant.conf
    
    Code:
    # This is a network block that connects to any unsecured access point.
    # We give it a low priority so any defined blocks are preferred.
    # The below line not be changed otherwise we refuse to work
    ctrl_interface=/var/run/wpa_supplicant
    
    # Ensure that only root can read the WPA configuration
    ctrl_interface_group=0
    
    # Let wpa_supplicant take care of scanning and AP selection
    ap_scan=1
    
    # Simple case: WPA-PSK, PSK as an ASCII passphrase, allow all valid ciphers
    network={
      ssid="NDAWHOUSE"
      scan_ssid=1
      #proto=WPA
      #pairwise=TKIP
      #key_mgmt=WPA-PSK
      #psk="pw"
      # The higher the priority the sooner we are matched
      priority=5
    }
    
    These are the only applicable config files I know of for a wireless connection. I orginally thought it may be my Marvell driver as the chipset has a bad reputation, but I have installed Ubuntu on this machine with the same exact ICS setup without problems. All msn websites and messenger worked fine. I cannot verify the MTU setting on my Ubuntu install, as Gentoo has since replaced it. Thus, I am convinced the problem lies in this configuration, as the rest of the network has not changed.

    I have probably forgotten something, so let me know and I'll post more information. I wrote this in a hurry. Anyway, does anyone know how to change the MTU setting on a Gentoo install as outlined above?

    Thanks in advance
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,449   +324

    disable IPv6
    inet6 addr: fe80::a10:17ff:fe02:d39/64 Scope:Link​
     
  3. Devcon

    Devcon TS Rookie Topic Starter Posts: 26

    I had thought of that, but it is not actually the offending setting.

    For the benefit of any folks that may google it in the future, I'm going to mark this solved, although I wish I had a more detailed evaluation of the specific setting in question.

    I was using kernel 2.6.27 vanilla that I had compiled myself. Downloading the new kernel 2.6.27.6 and recompiling has fixed the problem. I did not make any significant changes to the networking config portion of menuconfig.

    I'll try to do a more in depth analysis of the difference between my previous kernel config and the present one.
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,449   +324

    >>dns_servers_NDAWHOUSE=( "192.168.0.1" )

    usually there are TWO dns addresses, but this setting should work;
    can you resolve names to addresses, eg
    nslookup www.google.com?

    you might find the true DNS from your ISP and substitue them. the default route
    will cause the request to be forwarded as necessary.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.