Keyboard multiple characters with 1 keystroke

By tch7198
Aug 6, 2010
Post New Reply
  1. i have an asus g50v vista 64 bit About 15 of the keys produce multiple characters for ex, 'a' produces sda and spacebar produces z0 etc, Device Manager is showing 4 entries under keyboard; 1. keyboard device filter 2.microsoft ehome mcir109 keyboard 3.MS ehome mcir keyboard and 4.MS ehome remote control keyboard keys Any help appreciated Thanx Larry

    Remove all the keyboard entries in the device manager and reboot, letting Windows reinstall the keyboard driver...[advice from forum]

    i posted the above problem a year ago and removed keyboard entries in device manager,as advised here....it worked nicely,,,,exact same problem happening again but removing devices and reboot is doing nothing this time......also my system restore willnot restore..... please help thanx Larry
  2. mailpup

    mailpup TS Special Forces Posts: 8,383   +205

    If you haven't already, can you try another keyboard?
  3. tch7198

    tch7198 Newcomer, in training Topic Starter

    Back in Business

    I finally got this thing working.:D I went back and tried several different restore points....after each restore I got the same message: Restore unsuccessful...there was an error, etc........I got this same message on my last restore, but, mysteriously, the keyboard was back to normal. Thanx for the advice on trying another keyboard...I thought of that but i don't have an extra one.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.