TechSpot

Network "connected", router ping successful but no Internet

By deathfxu
Nov 25, 2008
  1. I have 2 laptops and a desktop on my home network, all plugged into the router. The 2 laptops connect to the network and internet. The desktop shows "connected", is able to ping the router but cannot connect to the internet.

    All are using XP home sp2. The desktop was just introduced to the existing laptop network. I have swapped the router, cable, and ethernet card for grins (i am tech enough to have had some of each laying around). Clearly it's a settings problem.

    Dynamic IP address.
    /ipconfig indicates same gateway as laptops. ("192.168.0.1")
    Worked perfectly on a previous network.

    Any help would be greatly appreciated, I am at my wits end.
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

  3. deathfxu

    deathfxu TS Rookie Topic Starter

    Unfortunately it is still unable to connect to the internet.

    Thank you though.
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    What happens when connected directly to the modem?
    Note: you may need to do a release then a renew to test this
    You can run inetwiz as well

    If that works, it must be a router or network cable issue

    Otherwise try this:

    Start --> Run--> cmd /c ipconfig /all >Desktop\ipconfig.txt < ok>

    And post the ipconfig.txt (on your Desktop) as an attachment [​IMG] here
     
  5. mflynn

    mflynn TS Rookie Posts: 2,793

    It would be nice to get the same on one that works as well for comparison.

    In Local Area connection confirm Client for MS networks and File and printer sharing are there and enabled.

    Turn off Firewall to eliminate it as an issue.

    In Services confirm Computer Browser, Server and Workstation are all set to Automatic and are started.

    Mike
     
  6. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 483

    Have you conisdered malware on the desktop? I would scan with as many tools as possible to rule this avenuie out.
     
  7. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Well "as many tools as possible" can get users into strife
    Many users tend to download the strangest of malware removal tools
    Even Spybots S & D can be counter productive, as it halts any change that support may suggest.

    Not only that but we are in the Storage & Networking forum, and we are eliminating and going through a sequential process, the Ipconfig attachment being favored

    If by chance the member does want to confirm Virus\Malware is not the issue
    This is the only direction and thread I would ever point to, at TechSpot
    UPDATED 8-step Viruses/Spyware/Malware Preliminary Removal Instructions
     
  8. deathfxu

    deathfxu TS Rookie Topic Starter

    It is definitely not a malware problem. I run AVG Pro and Norton 360, both of which currently have their firewalls disabled for troubleshooting (Windows Firewall is off too).

    My router has the modem built into it (ActionTec GT704-WG), so direct plugging into it is the only option.

    I'll double-check what mflynn said and post my ipconfig log file within the hour.

    Thanks again guys.
     
  9. tw0rld

    tw0rld TS Maniac Posts: 609   +6

    That is a definite no no! You should never have more than 1 Anti-Virus program installed at a time, this may be causing the problem. It is strongly advised that you get rid of one.
     
  10. deathfxu

    deathfxu TS Rookie Topic Starter

    oh ok

    Alright. I'll uninstall one right now and see if that helps. I had both active on my last network and it was working fine, but i'll try anything at this point. I scraped the bottom of the idea barrel a while back.

    In the meantime, here are the ipconfig log files of the desktop that doesn't work and the laptop I am currently typing on, on the same network, that does work.

    Also, mflynn all of the stuff you mentioned is active and automatic.
     

    Attached Files:

  11. deathfxu

    deathfxu TS Rookie Topic Starter

    I am now running only AVG (firewall still off). I restarted my computer and am still unable to connect to the internet.

    I am entirely baffled as to how to proceed. As I stated before, I swapped out all involved hardware components. There are other working computers on the network, and my computer used to work just fine on my old network. By all accounts, I should be surfing the web with ease. =/
     
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,514   +336

    the only thing strange is the DNS Suffix = tyler
    Normally this would be your ISP domain, eg mine is socal.rr.com

    well there's another; the two DNS addresses
    one is your router and the other (appears to be) your ISP DNS.
    normally they are in the same subnet (ie your ISP OR your router)

    try manual config for your DNS addresses (you're on sbcglobal.net)
    68.94.156.1
    68.94.157.1
     
  13. mflynn

    mflynn TS Rookie Posts: 2,793

    I agree with Joe.

    I preferr to put in the real ISP DNS Primary and secondary other than leave it to router DHCP.


    Mike
     
  14. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    If that still fails to help, please do the following

    Uninstall AVG fully (Note: disabling\removing the Startup entries is not enough)
    Uninstall Norton fully (Note: disabling\removing the Startup entries is not enough)

    Just to really confirm that, Un-install both fully


    Next download both these tools (on your Internet accessed computer) save them to flash drive (or CD)

    Norton Removal Tool
    AVG Remover Tool
    Here is the 32Bit version (most users): http://www.avg.com/filedir/util/avg_arm_sup_____.dir/avgremover.exe
    Here is the 64Bit version: http://www.avg.com/filedir/util/avg_arv_sup_____.dir/avgremoverx64.exe

    I am also going to directly quote AVG from this link: http://freeforum.avg.com/read.php?13,121087,backpage=,sv=
    Please note:
    • We are presently getting you back online
    • All steps above must be completed
    • There may be up to 4 Restarts, involved

    At last, (once all of the above is precisely completed) Try going on the Internet (without Antivirus! or firewall)

    If it still does not go online, you may need to run WinsockFix one last time
    Then restart
    Then go online

    If it works (which I believe it will ;) )
    Try Free Antivirus like Avira
    Download. Update. Scan

    Please let me know the results :)
     
  15. deathfxu

    deathfxu TS Rookie Topic Starter

    Firstly, thank you everyone for your help so far. Now both AVG and Norton are completely removed. Still no luck.

    How do I manually enter my DNS to what jobeard suggested?
     
  16. deathfxu

    deathfxu TS Rookie Topic Starter

    Nevermind. I found the manual config for it. Testing it now.
     
  17. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Start -> Run -> ncpa.cpl -> ok
    Right click on your Network Connection
    Click on Properties
    Double click on TCP/IP

    Select: "use the following DNS server address"
    Type the above numbers in each field
    Apply OK

    Then...
    Start -> Run -> CMD -> ok
    On the command line type:
    IPConfig /release then press enter
    IPConfig /renew then press enter
    Exit then press enter

    Then...
    Start -> Run -> inetwiz -> ok
    Select Lan
    Follow the prompts

    Try Internet again :)

    Edit:
    Just saw you posted above
     
  18. deathfxu

    deathfxu TS Rookie Topic Starter

    I just did all that except inetwiz. I'll do that now.

    Thanks. You're quick. =)

    No luck after running inetwiz.

    Oddly, when I /ipconfig it still shows "tyler" under the "DNS suffix" line instead of the one i put in manually. I triple checked that I did it right though, and the ipconfig was after a reboot.
     
  19. jobeard

    jobeard TS Ambassador Posts: 13,514   +336

  20. deathfxu

    deathfxu TS Rookie Topic Starter

    I did all the instructions you listed on that page and only got a timeout (the message showed after 2 seconds) on the last line "nslookup www.google.com".

    edit: just clarifying, i did try the browser after, still to no avail.
     
  21. jobeard

    jobeard TS Ambassador Posts: 13,514   +336

    this tells you that
    1. the DNS address is wrong
    2. the gateway address is wrong
    3. there is no connection to the ISP
    (assuming that ipconfig /all has good IP addresses in the reply)

    try ping google by its address
    ping 74.125.19.47​
    if this works, the (2-3) are not the issue and you only have an access issue with the DNS
     
  22. deathfxu

    deathfxu TS Rookie Topic Starter

    The ping was successful!

    edit: Since it still cannot access the DNS server even when the address is put in manually, why else might I not be able to connect?
     
  23. deathfxu

    deathfxu TS Rookie Topic Starter

    So I know that my computer is unable to access the DNS server correctly. I have tried manually entering the DNS address and i've tried the automatic configuration. Is there any other reason why I wouldn't be able to access it?

    Also, let me reiterate my thanks to everyone so far. This has been a long process and I think it's safe to say at this point that if someone is able to fix this, they are truly skilled.
     
  24. jobeard

    jobeard TS Ambassador Posts: 13,514   +336

    search this site for the 8 step removal process.
    There must be something on your system which is hijacking the DNS settings or access.
     
  25. deathfxu

    deathfxu TS Rookie Topic Starter

    I am following the steps listed in the link you sent and will post the results as soon as it is complete. I must admit I am a bit skeptical though. Until I began the troubleshooting process (and thus removed them), I had the complete versions of Norton 360 and AVG on my computer, as well as AdAware and an anti spyware utility (the name of which escapes me now). I also am very intelligent about online downloadable content.

    Regardless, I have been unable to fix this in ages, so i'll give it a shot.

    Thanks for sticking with me J. O. Beard :)
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.