TechSpot

Playing GTA IV

By Punkid
Sep 13, 2009
  1. nismo91

    nismo91 TS Guru Posts: 1,003   +11

    first of all make sure u set your CPU to its max throttle speed. (in win vista = max performance, in winxp = always on) not sure on win7 but i think should be about same as vista.

    and in power setting set the CPU to 100% min and 100% max. im not sure if u need to upgrade your RAM as well or not. i only get back home in december, that's when i can try the GTA IV in my 9500GT and E6300.
     
  2. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    where do i set that ??
     
  3. nismo91

    nismo91 TS Guru Posts: 1,003   +11

    should be in control panel > power options.
    make sure its in high performance, and then check the settings, for CPU. minimum 100% and max 100%. however i did not use win7 yet, but it should be quite similar.
     
  4. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    yea i have set the processor minimum state to 90% and max was already 100%
     
  5. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    ok what the hell my CPU usage wont go below 99%....check this out,when i had vista 32 bit this is the benchmark

    Statistics
    Average FPS: 22.76
    Duration: 37.18 sec
    CPU Usage: 86%
    System memory usage: 94%
    Video memory usage: 80%

    Graphics Settings
    Video Mode: 1440 x 900 (60 Hz)
    Texture Quality: Low
    Render Quality: Low
    View Distance: 25
    Detail Distance: 37

    Hardware
    Microsoft® Windows Vista" Ultimate
    Service Pack 1
    Video Adapter: NVIDIA GeForce 9500 GT
    Video Driver version: 180.48
    Audio Adapter: Speakers (Realtek High Definition Audio)
    Intel(R) Core(TM)2 Duo CPU E4600 @ 2.40GHz

    u see my cpu usage wasnt full and i remember that the game was atleast playable but now with win7 64bit cpu usage jst isnt going below 99%

    Statistics
    Average FPS: 23.30
    Duration: 37.12 sec
    CPU Usage: 99%
    System memory usage: 93%
    Video memory usage: 86%

    Graphics Settings
    Video Mode: 1440 x 900 (60 Hz)
    Texture Quality: Medium
    Texture Filter Quality: High
    View Distance: 20
    Detail Distance: 20

    Hardware
    Microsoft Windows 7 Ultimate
    Microsoft Windows 7 Ultimate
    Video Adapter: NVIDIA GeForce 9500 GT
    Video Driver version: 190.38
    Audio Adapter: Speakers (Realtek High Definition Audio)
    Intel(R) Core(TM)2 Duo CPU E4600 @ 2.40GHz

    File ID: Benchmark.cli

    is it windows 7 or is it the 64bit????
     
  6. nismo91

    nismo91 TS Guru Posts: 1,003   +11

    probably the windows. im not sure. do you have many applications running in the background? dont worry just set minimum and max to 100%.
     
  7. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    no i have only windows messenger running in the background and now ive set the minimum to 100%
     
  8. nismo91

    nismo91 TS Guru Posts: 1,003   +11

    well im not sure then,. i use only vista. maybe that's the limit your computer can perform.
    i'll post back my result with 9500GT on the end of the year later.
     
  9. Punkid

    Punkid TS Maniac Topic Starter Posts: 546

    kk thanks alot man
     
  10. teklord

    teklord TS Maniac Posts: 527

    You need a quad core to play GTA IV, your lower powered dual core won't run it well except on low settings. You should be proud of the FPS you get now though with what you have, that is quite remarkable.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.