Sis 630 with Windows XP

By rwebb
Aug 23, 2004
  1. I have the above config and it starts my PC always in 8-bit, 640x480 mode despite being able to display 32-bit 1024x768.

    I've tried downloading and re-installing display drivers & adapters, device manager, display properties and looking in .ini files, all to no avail.

  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Welcome to TechSpot
    Can you please fill out your "user cp" (top left on this screen) and be a bit more specific?
    What graphics card/motherboard do you have? What version of drivers is installed?
  3. rwebb

    rwebb TS Rookie Topic Starter

    Will complete info this evening.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Not very helpful, are you?
  5. rwebb

    rwebb TS Rookie Topic Starter

    many apologies. You swere asking for info to help me out and I idn't give it to you.

    I've updated my profile as much as I can without pulling my laptop apart.
    The drivers I have installed are:
    display driver: Sis 300/305/630/540/730
    location PCI bus 1, Device 0, function 0 version 5.1.2001.0
    author: microsoft
    Driver files: c:\windows\system32\DRIVERS\sis300ip.sys

    Adapter: sis 630 8MB memory, bios info 2.02.1c

    I tried downloading newer versions of the sis630 drivers before installing the sis utility tray but this definitely isn't the problem.

    Let me know if you'd like any more info.

  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Looks like you use the wrong drivers.
    Uninstall them and go back to the standard VGA 640x480 setup from Windows.
    Then rightclick anywhere on your desktop, select Properties and go into Settings and then Advanced. In there, click on Adapter and then Properties. Now click on Driver and Update Driver.
    Now make sure to install the Sis630 drivers, not the Sis300.
    I don't know XP (use W2K myself), so maybe not all my tips are correct.

    If you can update the drivers by running the downloaded driver-file, do that instead.
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

  8. rwebb

    rwebb TS Rookie Topic Starter

    Thanks guys, I downloaded a version from Sis for the 630/730 and it's working fine.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...