TechSpot

Slow wake from hibernation

By barmecidal
Jul 19, 2011
Post New Reply
  1. A few months ago I built my first system and it has had problems waking from hibernation from the start. My computer specs are:
    Memory: 4 GB RAM ADATA 1333
    Motherboard: ASROCK 880GM-LE
    Processor: AMD Phenom II X4 925 (64-bit)
    Video Card: EVGA nvidia 8800 GTS 320
    Power Supply: Cooler Master RS500 (500W)
    The power Options for the ASRock IES under sleep setting is:
    Sleep after: 360 minutes
    Allow hybrid sleep: On
    Hibernate after: Never
    Allow wake timers: Enable
    I had the same problem with power saver plan, but I don’t know what the sleep settings were at that time. I also looked at the BIOS (AMI version 2.67C) and could not find anything on S states.

    The problems encountered when I try to wake it up is that the processor fan speeds up to 100% and It takes several minutes for the monitors to come on.
     
  2. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member

    Probably just a mistake somewhat nit picky of me, but technically you wouldn't be able to wake from hibernation since hibernation is turned off.

    What you're actually using is "Hybrid Sleep". In this state, the computer goes into standby mode (not turned off, can quickly resume in a few seconds) and simultaneously builds a hibernation file which allows to you to completely power off the system and restore it to its previous state. It's a mix of the two which provides a smooth transition from sleep to powered off and then powered on again states.

    Different power states are important to note here. S3 is "standby" or sleep as most people use it today, "Hibernation" is S4 and "powered off" is S5.

    If your BIOS is set to use the S2 power state instead of S3, this could be part of your issue -- the S2 power state will often times cause your fans to run at full speed while resuming from standby. If your computer is taking a really long time to resume from standby and the fans are running full blast the entire time, then this could explain the loud fans.

    In short, I would check ACPI configuration settings in your BIOS and make sure it is set to use the S3 power state instead of S2. I'm unsure if this will solve the super long resume time though, so if it doesn't fix that issue -- in the meantime -- I would also disable hybrid sleep completely. Instead, use S3 sleep/standby and/or hibernate if necessary... just as a workaround until someone actually posts a real solution.
     
  3. barmecidal

    barmecidal TS Member Topic Starter

    I checked the ACPI configuration settings in the BIOS and I couldn't find anything on S2, S3 or S4 states.
     
  4. Rick

    Rick TechSpot Staff Posts: 6,305   +52 Staff Member

    Below is an image of your BIOS (supposedly) with the settings that are related to power management... not a lot of options here.

    However, I do see a "suspend to RAM" feature in the BIOS. If it is currently disabled, then this is possibly one of your issues. S3 and "suspend to RAM" are in fact the same thing, so you should set this to ON (if possible) or at the very least Auto (which appears to be an option).

    [​IMG]
     
  5. barmecidal

    barmecidal TS Member Topic Starter

    I am pretty sure it is on auto, but it's late and I will have to check tomorrow to be sure.
     
  6. barmecidal

    barmecidal TS Member Topic Starter

    I checked the BIOS and the "suspend to RAM" feature is on auto. "On" was not an option here, so I left it as is.
     


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.