1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

0x0000009c error code, I need help!

By Nathan Bell ยท 28 replies
Feb 26, 2007
  1. I'm running Win XP SP2, AMD Athlon 64, 2000 MHz, ASrock Motherboard, 1 gig DDR SDRAM , and a radeon 9700 pro graphics card.

    I'm getting a Blue screen crash seemingly at random, and it gives the error code listed in my subject line, 0x0000009c.

    I run WoW fairly often, but it doesn't seem to crash noticably more often while I'm playing a graphics-heavy game. After reading about someone else's similar problems on this forum, I downloaded Everest and did a system report, and got the following values for the power supply:

    CPU Core 1.44 V
    Aux 1.47 V
    +3.3 V 3.36 V
    +5 V 5.24 V
    +12 V 12.65 V
    -12 V 2.20 V
    -5 V 2.75 V
    +5 V Standby 5.04 V
    VBAT Battery 0.02 V
    Debug Info F FF 31 FF
    Debug Info T 24 26 24
    Debug Info V 59 5C D2 C2 D0 D0 D0 (01)

    Any help or info would be greatly appreciated. Thanks!
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Hello and welcome to Techspot.

    This is the meaning of the 9C bugcheck.

    (Click to consult the online MSDN article.)
    This is a hardware issue: an unrecoverable hardware error has occurred. The parameters have different meanings depending on what type of CPU you have but, while diagnostic, rarely lead to a clear solution. Most commonly it results from overheating, from failed hardware (RAM, CPU, hardware bus, power supply, etc.), or from pushing hardware beyond its capabilities (e.g., overclocking a CPU).

    As you can see it means you have some kind of hardware failure. You will need to diagnose exactly which hardware is at fault.

    Start by testing you ram and work from there. It`s also a good idea to disconnect anything not required to run your system and see if you still get the crashes. If you do, then the problem lies in what`s left in your system. check your system temperatures. If you are overclocking, reset to the defaults.

    See this thread HERE for instructions on testing your ram.

    Regards Howard :wave: :wave:
  3. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    Thank you for your swift reply.

    I should have mentioned that I ran a defrag, checkdisk, and a memory check program called memscope. The ram returned no errors on one pass, at the time I didn't realize that running multiple passes was neccesary.

    I will try to disconnect and troubleshoot as much as I can, and come back wit anything I find. I'm inclined to think it is the graphics card but I'm certainly not sure about that.

    Thanks again for your help, I'll continue reading your links to the common problems of this type.
  4. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    Well, I know for sure now that it's not the graphics card, as I just bought a new one and installed it and it just crashed again. -Sigh-

    I'm currently running my RAM check program, and I will let it go through for at least 7 passes.

    I'm starting to think it's the powersupply now, but obviously my hunches aren't doing me much good with this problem. Is there a definitive way to figure out if the powersupply is defective without just buying a new one?
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    You could download the free Everest programme from HERE and see if your psu`s voltages are ok.

    You also need to take into account whether your psu is powerful enough for your system. This means you need to look at the psu label and check the wattage and the output in amps on the 12volt rail.

    This psu wattage calculator is very handy for working out the psu power you need to run your system.

    An underpowered or failing psu can cause all manner of system crashes and definitely needs to be looked at as a possible cause.

    Regards Howard :)
  6. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    I've run 4 passes on the RAM checker with no reported errors.

    My PSU sticker says: ATX 400W switching power supply

    With the following listed for the 12v rails:

    +12v1 - 14A
    +12v2 - 15A

    I've attached the quick report from Everest that I ran a couple minutes ago. I don't know if that helps. I can attach the minidump files if that would be useful.

    Thanks again for your continued help.


    Everest Report text file.
  7. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Your temps and psu voltages look ok.

    Please attach 5 or 6 of your latest minidumps.

    Regards Howard :)
  8. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    Dump files

    You asked for 5 or 6, but it looks like there are only 2 in the file C>Windows>Minidumps.

    Also, they're dated the 6th and 8th of February. Shouldn't there be one for every time I get a crash?

    In any case, here they are.
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Yes there should be a minidump written every time you get a bsod.

    Do the following. Right click my computer and select properties. Click the advanced tab and under startup and recovery click settings. Check to make sure the overwrite any existing file box is unchecked. If it`s checked, change the small memory dump(64k) to Kernel memory dump, then uncheck the overwrite any existing file box. Now change the kernel memory dump back to small memory dump(64k). Click ok/apply/ok and reboot your system.

    Your two minidumps both crash at your ATI video card drivers and have a bugcheck of 7F.


    One of three types of problems occurred in kernel-mode: (1) Hardware failures. (2) Software problems. (3) A bound trap (i.e., a condition that the kernel is not allowed to have or intercept). Hardware failures are the most common cause (many dozen KB articles exist for this error referencing specific hardware failures) and, of these, memory hardware failures are the most common.

    Try updating your videocard drivers.

    Regards Howard :)
  10. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    I checked the startup and recovery settings, and that optioin was indeed checked, so I followed your directions and undid it.

    As for the video card, it is running right now with my brand-spankin' new geforce 7600GT that I installed today. The crashes have not changed even after upgrading the video card.

    I have rebooted since then, and I will keep an eye on it to see if it crashes again.
  11. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Ok, post any further minidumps you get.

    Regards Howard :)
  12. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    Went a long time with no crash last night, and I thought that unchecking that one little box had cleared it up.

    But, alas, another crash this morning, same 'machine_check_exception' bsod, and I had to manually restart it.

    But no new minidump files in the folder. What's that all about? I let the machine sit on the bluescreen for about 10 mins, should I just let it sit on that screen until it restarts itself?
  13. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    I really don`t know why it`s not writing minidumps.

    It should be fairly instant, so leaving it on the blue screen, won`t make any difference.

    Have you tried running your system with just one stick of ram?

    I think your problem is probably caused by faulty psu/ram/mobo. Try swapping out the psu and see if that helps. Hardware problems can be very difficult to diagnose, particularly if you don`t have spare parts available for testing.

    Regards Howard :)
  14. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    Another crash, this time with a minidump file! How exciting.

    Also, I've run both RAM chips individually, and it has crashed to the blue screen eventually with either one. Even used a different slot.

    Most recent minidump is attached.
  15. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Your minidump crashes at mfehidk.sys and has a bugcheck of 50. This is a McAfee driver. Try uninstalling daemon tools and see if that helps. Apparently, this driver seems to have an issue with the Daemon tools programme.

    Edit: Have remove a big mistake I made.

    Regards Howard :)
  16. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    I am running McAfee, and I've been debating about getting rid of it!

    Would uninstalling Mcafee and trying something else help? I've been considering AVGfree, which was recommended by a friend. Any thoughts?

    Oh, also, I don't know what Daemon tools are. They sound sinister.
  17. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    If you want to get rid of McAfee,then Id recommend the following antivirus and firewall programmes.

    AVG free or Avast antivirus programmes.

    Zonealarm or Kerio free firewall programmes.

    Daemon Tools allows you to mount images of cd`s etc as virtual drives. You`ll find the programme in add remove programmes in your control panel.

    Regards Howard :)
  18. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    I will look into switching to AVG free and try it out.

    I really don't know about the daemon tools though, it doesn't appear on my program list and I don't think I've ever had it installed.
  19. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    I`m sorry, it looks like I made a mistake. The mfehidk.sys is actually a McAfee driver that has issues when daemon tools is installed. however, It seems like you don`t have Daemon tools installed, so perhaps there`s another issue or it`s just something to do with Mcafee. In any case I suggest you get rid of mcAfee and see how your system performs.

    Regards Howard :)
  20. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    I uninstalled mcaffee and now it seems to be crashing about every 15-30 seconds. I have AVG free installed, but it's crashing too soon to complete an initial scan.

    I've attached the last few mindump files.
  21. Platoxia

    Platoxia TS Rookie

    I hate to say it, but 99.999% of the time when I run into this (both your bsd's) it is a ram 'related' issue. If your memory sticks are ok, then it is probably something relating to your memory slots or the fsb. Sometimes, not even the memory stress tests find the problem. Considering you have tried both memory sticks individually in each slot and are still having issues, my best guess would be that your mobo needs replaced (assuming of course that this memory has no issues in another system).

    just my $0.02...for what its worth
  22. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    Just when we though we might be getting somewhere. Your minidumps crash with various culprits and bugchecks.

    This is indicative of a hardware problem of some description.

    I`d like to check your system for viruses/conflicts etc.

    Go and read this thread HERE and post a HJT log as an attachment.

    Edit: Just seen your post Platoxia. For what it`s worth, I tend to agree with you. BTW: Hello and welcome to Techspot. :wave: :wave:

    Regards Howard :)
  23. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    Ok, ran a hijackthis scan, and I've attached the log file.

    Also, the thing that really seems to be crashing it predictably is running a virus scan with AVG free. Don't know what that means, but I'll try scanning again and see what happens.


    Just finished an AVG scan (with one crash toward the end of it, but I was able to pickup where I left off and complete it) and nothing malicious found. Some of the things that are listed in teh hijackthis file point to Mcaffee though, and I thought I had uninstalled all of the mcafee software before I installed AVG. Latest dump file attached.
  24. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 21,238   +17

    There`s quite a lot to get through here, including getting rid of a nasty adware bho you have.

    Download the Pocket Killbox programme from HERE. Extract it but don`t run it yet.

    You might want to copy and paste these instructions into a notepad file. Then you can have the file open in safe mode, so you can follow the instructions easier.

    Boot into safe mode, under your normal user name(NOT THE ADMINISTRATOR ACCOUNT). See how HERE.

    In Windows Explorer, turn on "Show all files and folders, including hidden and system". See how HERE.

    Click start/run and type services.msc into the run box and press the enter key.

    When the window appears, maximise it. Double click on the following services(if there) and select stop if they are running. Set the startup type to disabled. Click apply/ok for each service you disable.

    McAfee SystemGuards (McSysmon)<Disable the service name and/or the name in brackets.
    McAfee Real-time Scanner (McShield)<Disable the service name and/or the name in brackets.
    McAfee Network Agent (McNASvc)<Disable the service name and/or the name in brackets.

    Close the services window.

    Open your task manager, by holding down the ctrl and alt keys and pressing the delete key.

    Click on the processes tab and end process for(if there).


    Close task manager.

    Run HJT with no other programmes open(except notepad). Click the scan button. Have HJT fix the following, by placing a tick in the little box next to(if there).

    O2 - BHO: CVirtualDNSObj Object - {86C510E9-97EF-4749-914F-0280247BE3A6} - C:\WINDOWS\VirtualDNS.dll

    O16 - DPF: {4ED9DDF0-7479-4BBE-9335-5A1EDB1D8A21} - http://download.mcafee.com/molbin/shared/mcinsctl/4,0,0,101/mcinsctl.cab

    O16 - DPF: {BCC0FF27-31D9-4614-A68E-C18E1ADA4389} - http://download.mcafee.com/molbin/shared/mcgdmgr/1,0,0,26/mcgdmgr.cab

    O23 - Service: McAfee Network Agent (McNASvc) - Unknown owner - c:\program files\common files\mcafee\mna\mcnasvc.exe (file missing)

    O23 - Service: McAfee Real-time Scanner (McShield) - Unknown owner - C:\PROGRA~1\McAfee\VIRUSS~1\mcshield.exe (file missing)

    O23 - Service: McAfee SystemGuards (McSysmon) - Unknown owner - C:\PROGRA~1\McAfee\VIRUSS~1\mcsysmon.exe (file missing)

    Click on the fix checked button.

    Close HJT.

    Locate and delete the following bold files and/or directories(if there).

    C:\PROGRA~1\McAfee<Delete the entire folder.
    c:\program files\common files\mcafee<Delete the entire folder.

    Run the killbox.exe file. When it loads type the full path to the file you would like to delete in the field and check the delete file on reboot button. press the Delete File button (looks like a red circle with a white X). It will prompt you to reboot, select no until you have finished inputting the files you want to delete, only then allow it to reboot and hopefully your files will now be deleted. If your computer doesn`t automatically restart, restart it manually.

    This is the filepath you need to enter into killbox.


    Once your system has rebooted, rehide your protected OS files.

    Post a fresh HJT log and make sure you rename HijackThis.exe as per the instructions HERE.

    Your minidump crashes at your AVG Antivirus programme, but you already know this lol. Probably caused by a conflict with the McAfee programme that was still running.

    Regards Howard :)
  25. Nathan Bell

    Nathan Bell TS Rookie Topic Starter

    Wow, that is a lot. Thank you again for your help with this issue, I certainly appreciate your patience and help with my problem.
    I will do as you suggest and copy/paste and run in safe mode. Luckily I have this laptop that I'm using now to post without fear of crashing etc.

    I should have mentioned in my last post that the crashes during the anti-virus scan didn't go to a BSOD, they just caused a hard restart of the machine. Don't know if it's relevant, but there you have it. I will start on what you outlined above, and post an update.

    Thanks again,



    In the Services part of things, when I try to disable 'McAfee Real-Time Scanner', I get an error message saying

    "Unable to open service McShield for writing on Local Computer. Error 5: Access is denied."

    And it won't let me do anything to the file. The other 2 mcafee programs are disabled, but that one won't change from automatic. Argh.

    Also, I don't know if this is relevant or not, but a see-thru file called 'thumbs.db' has turned up on my desktop. What's that all about? I've never seen it before.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...