100000d1 error every time I play a game

By Aaron5030 ยท 9 replies
Mar 21, 2010
  1. I play a lot of games on the pc, from mmo's to singleplayer games, and have recently began having a lot of problems with bluescreens etc. I haven't put as much love into this pc as my other but i built it about 2 years ago and its run like a charm untill recently. No matter what game i play , about 10 min or so in, the game does one of two things, either freezes completely, or the pc completely reboots itself.

    Every single time the error comes up as 100000d1. Recently a younger sibling of mine managed to get a nasty virus on the pc and after a bit of a debate i decided to reformat and install a fresh xp, it needed to be done anyway, plus i figured it may fix the problem. Low and behold the problem still happens every time.

    Now i understand that this 100000d1 error is related to driver errors of some kind or them being unsigned, however i am not sure as to how i find which driver this is, and also i am not sure as to what steps i should take to fix said driver (assuming that drivers are the issue).

    p.s. im new to the site, i see people linking minidumps and such but i am not sure as to how i get these files, im very computer friendly, if anyone needs me to link something like this in order to help me just let me know how and i will do so immediatly.
  2. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Please post your minidumps for analysis.

    You can find them in C:\Windows\Minidump

    In case you have multiple minidumps (which would be great), please zip them in one single file and post them here. Regards
  3. Aaron5030

    Aaron5030 TS Rookie Topic Starter

    Sure, I was able to find 3 of them.

    Attached Files:

  4. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    2. DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1); caused by XDva332.sys
    3. DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1); caused by XDva332.sys

    Your first minidump points to Windows USB subsystem drivers; now if you have nvidia chipset motherboard; my advice to you is disable legacy USB support; for some reasons nvidia chipset boards have issues with this.

    I have no idea what the heck is XDva332.sys; I am suspecting it may be a rootkit; if and when I find something tangible about it I will let you know immediately. In the meanwhile, please go through 8 step process of malware/virus removal, and post your logs in the appropriate forum for further advice.
  5. Aaron5030

    Aaron5030 TS Rookie Topic Starter

    Have a few minutes break at work so i thought i would catch you up on my findings so far. I ran the 8 steps like i was instructed and posted them in various places and am awaiting responses, however i did not find any viruses or malicious files during my scans.

    After google'ing for a few minutes i found that the strange file may be connected to a rootkit or trojan like you had said before, i had to translate a page from Chinese into english in order to read it but that is more or less what i inquired.

    Aside from the aforementioned i am at a loss. I also tried unhiding files and then searching for it but had no luck there.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Re: XDva332.sys

    Quite recently, i happened to see someone else on TechSpot with similar drivers named XDvannn.sys (where nnn are digits). It seems this name format is common for gamers (Try googling XDVannn.sys or simply XDVa.sys)

    Unfortunately, other then passing along the google hits not sure i can add much more help here :(

    /* edit *
    Example hit: Take a look here
  7. Aaron5030

    Aaron5030 TS Rookie Topic Starter

    I have come across the "XDVA332" folder inside the registry. It is labeled as "LEGACY_XDVA332", contains a folder titled "0000" and therein contains 2 folders labeled "Control" and "LogConf".

    I made a backup of the registry and tried to simply delete the key but every file gives me the error "unable to delete all specified values" or simply "Cannot delete LEGACY_XDVA332: Error while deleting key"


    The - non - legacy folders named xdva332 are easily deletable, and although i did not come across them when i searched myself they were supposedly inside the system32 folder

    *edit again*

    I changed permissions on the registry key and it allowed me to delete it. I am going to force a BSOD and repost the mini dumps that i get.
  8. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Alright, please keep us posted, and let us know if we could be of further assistance. Regards
  9. Aaron5030

    Aaron5030 TS Rookie Topic Starter

    As it seems, XDva322.sys is a driver for a gameguard known as X-trap. It did not have much of an effect by deleting it. I am more interested in knowing about the USBPORT.sys though. What can i do about that? If i disable legacy usb ports, will my usb ports stop working?
  10. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    While looking around I found this microsoft page, describing an update for USBs, I think you may have a look at it, and apply the appropriate patch for your OS.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...