7 in 1 floppy

By steve67474 ยท 6 replies
Apr 6, 2006
  1. Hi guys, just built a system for a friend and installed a Mitsumi 7 in 1 floppy drive. The card reader takes up one of the USB ports on the mobo. Tried to read sd card no go??? the drives report in as removable drives in "my Computer" and it says tha t windows XP needs no drivers (have SP2 on it btw) everything looks good in device manager. Tried CF card still same red light comes on and it cant read flash card. Tried another port on MOBO still no Joy, and I know this port works due to me checking it with USB stick. Sent reader back and new one arrives. Guess what same problem?? The floppy works fine but that is off floppy cable Any Ideas, as I am lost
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Check the USB connections. If you mis-connect, it won't work.
    Do the CR-drives show up in Explorer?
    Have you installed the motherboard drivers? Updated them if available?
  3. steve67474

    steve67474 TS Rookie Topic Starter

    thanx for reply real, yep they show up in explorer as removable drives and have checked the usb connections so am at a loss. I really looked like they report in hardware wise but wont read which I thought eas bad drive. but two on the trot seems odd?? Am going to try it in another system to see if it is some chipset compatability or summat silly like that

    OOps yes I have ensured that the latest drivers were installed on Mobo
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Use a CD Linux like Knoppix or INSERT to see if the cardreader works there. If it works in linux, then your issues are with Windows. If it doesn't work in Linux either, you have hardware problems.

    See what drivers the cardreader uses. I remember having serious problems with a Genesys thing that were caused by official updated drivers from Microsoft..
  5. steve67474

    steve67474 TS Rookie Topic Starter

    thanx nodsu am going to try it in another machine. I just found a bios update for the mobo dated 30th march so am doing that as well. will keep u posted
  6. troubleshooting

    troubleshooting TS Rookie

    Any more luck with this?

    I notice that the card shows up as a genesys USB mass storage device, so I find it interesting to read the comment about Genesys problems. I am running into the same problems - proper pinout, power reaching the device, card detection LED coming on when a card is inserted, etc. No cards are recognized though (multiple SD cards and a CF card).
  7. troubleshooting

    troubleshooting TS Rookie

    I can answer my own question, and hopefully help you. I went to the removable hardware screen and right-clicked on the genesys usb mass storage device's properties. I rolled back the device to get to a Microsoft USB mass storage device dated 2001. Everything works great. Thanks.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...