A laptop mouse problem that nobody can solve

By prash
May 18, 2005
  1. A friend of mine has an old laptop which runs windows 98...it does have USB so I assume its probably the latter version of 98.
    The laptop actually works quite well for its age and has very few things installed.

    My friend has the following problem
    When having an external ps2 mouse installed...and attempt to use it. Everything goes mad. Windows open up, start menu is activated. Folders open. The pattern seems random. I looked at it to try and fix it. I stopped using the ps2 mouse when this happened and tried the touch pad but the problem still existed.

    So I rebooted the laptop using start menu (had to use keyboard). the touch pad works well but as soon as the ps2 mouse is used it goes crazy again.

    I found that if the ps2 mouse is physically attached after the laptop has loaded windows...it works fine!

    I have run anti virus scan using latest definitions. I've uninstalled the ps2 driver and tried removing/reinstalling. Ive checked msconfig for any weird programs running but there's nothing unusual.
    I've checked in bios but the bios is limited and doesnt have ps2 or inbuilt touchpad setting there. I went into control panel and did expect some kind of proprietary software for the touchpad but nothing at all...except the bog standard mouse click speed settings from win 98.

    Anyone know why this problem is ocurring or what i can do to solve it?

    I suspect the ps2 port is faulty but my pc knowledge is very limited as u can tell.
  2. vnf4ultra

    vnf4ultra TechSpot Paladin Posts: 1,388

  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try that mouse on the USB-port with a USB-PS/2 adapter.
    Might work if it is W98-SE.
    Check in Device Manager/Mouse, if there is an interrupt (IRQ) conflict when you boot up with the mouse in the PS/2 port.
    You may be able to set some interrupt as 'reserved' or 'by IPC' or something like that in your BIOS.
  4. prash

    prash TS Rookie Topic Starter

    Your IRQ suggestion made me think further...and it helped.

    I went into bios and found a device called internal input...i disabled it anow things are ok.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...