A7V8X-X Keyboard lock-up

By daBull ยท 8 replies
Oct 26, 2004
  1. Asus A7V8x-x MB, AMD Athlon XP 2500, 256 DDR RAM, ATI Radeon 9200 Vid Card, 40 MB HD, XP Pro, Netgear USB wireless WG121 adapter.

    I was having random reboots and the event log showed that they occured after a DHCP or TCP IP call. I made sure that a virus or worm hadn't snuck in through my firewall and made sure that nothing in my network settings was askew. Thinking that the adapter was the issue, I tried removing it, uninstalling it (including the debris it left in my registry after the software uninstall), updating my bios, and then as a last resort, fdisking the entire harddrive and starting over from scratch.

    Well, it no longer reboots for no reason but now the keyboard locks itself and the mouse up anytime I hit a key in Windows. It even locks up in repair mode. There are no conflicts and the bios are the factory defaults. My wireless connection requires a password so I haven't updated to XP SP2 again but I don't think that that is the problem. Any ideas on what could be causing this?

    My next effort will include downgrading the bios back to the original version that I had but any other ideas would be greatly appreciated.

    Please help.

  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    "factory defaults ..." may not be correct for your configuration.
    Check the actual settings in your bios against peculiarities that you hardware might have or need ,eg. apic,
    You might try a different slot for your ethernet card .
    Why is the need for a password to your wireless lan stopping you from upgrading to SerPak 2 ?
  3. daBull

    daBull TS Rookie Topic Starter

    Thanks for the quick response. My wireless adapter is actually an external adapter that connects via USB. The only "ethernet card" on the system is built-into the mobo. I can't move it obviously but I did disable it without any impact either before or after fdisking and starting over. As for the upgrade to SP2, I had to type the password in and well, that wasn't working so hot.

    The odd thing is that once every 8-10 reboots, the keyboard will actually work without any problems and the system doesn't randomly reboot. Of course I can't just leave the system on when it does work because I am stilling trying to install some of my basic software. Last night for instance, I booted up, was able to input my wireless password and then installed my firewall which in turn required a reboot.

    Now I'm back to square one. :confused:
  4. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Random reboots can be caused by a number of things.I would be more suspicious of a failing power supply ,faulty ram or some corruption in Windows system files and HDD problems.
    I would try to solve this by process of elimination.
    -check event logs ,track errors
    -confirm drivers are up to date
    - reseat and clean ram modules
    - check power supply readings
    -run some diagnostic software(Sandra sisoft)
    Just some ideas ,I think it is critical that you stabilize your platform before loading anymore software. Also I think it is strange you have problems with your password .try tech support at Netgear for that issue .
  5. daBull

    daBull TS Rookie Topic Starter

    Sorry if I gave too much background info and confused the issue.

    I was able to resolve the reboot issue when I reformatted and reinstalled everything

    Now I'm just not able to use the keyboard except 1 out of every 10 reboots. I was able to use the keyboard once this week and during that time I typed in the password for my wireless adapter and am at least able to get online now although I havent' had a chance to yet on that system.

    I'm not familiar with sandra by sisoft so it's certainly worth taking a look at and will give that a go tonight.

    Thanks again. :>
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Keyboard should be easy.
    Try a new/different Kbd .
    If Kbd has usb and serial connector try the one you are not using.
    Is there special software for it ,if so try to find an update.
    Check I/O conflicts.
    Answer is somewhere in that mess.
    Good Luck
  7. daBull

    daBull TS Rookie Topic Starter

    This is the third keyboard that I've tried and it is using the MS standard keyboard driver so nothing out of the ordinary there. (Two of the keyboards were standard 102 key boards and the third was a gateway with CD and other buttons.)

    I did figure out though that the lock-up occurs when the mouse (again, any mouse) steals the I/0 ports that the keyboard needs. Since all mice that I have worked only use IRQ12 as a resource and have no need for the I/O ports, this explains why both the keyboard and mouse lockup. The I/O nabbing occurs before Windows even starts. I went into the bios and changed the PS/2 mouse setting from auto to enabled and that helped a little but not enough. I also set Plug and Play OS from no to yes but that made no difference. Thinking that I could force the mouse to leave the I/O alone, I installed a logitech trackman with updated drivers but that also had no impact.

    If it were a jumper setting, I would assume that I would have a 100% failure rate instead of a 70-80% failure rate.

    I'll look around for a USB mouse and/or keyboard and let you know what happens with that.

    Thanks again,
  8. layco

    layco TS Rookie

    asus keyboard lockup too

    I've been tolerating occational keyboad lockups for several months on my asus a7v8xx based system. I just tried upgrading my bios to a7v8xx13.awd and the system locked up consistently just as the password challange was presented. Before that the mouse still runs the pointer around the screen. I reinstalled a7v8xx09.awd and I'm back to where I was. I now seem to be suffering from corrupt disk files and have been running checkdisk for the last few boots but I expect that is from the several hard reboots I had to do. I'm open to any ideas but I suspect it is a bios confict with something else. I'm running an nvidia video card and not much else installed internally. I'd love to hear any ideas.
  9. daBull

    daBull TS Rookie Topic Starter

    Possible Resolution

    I went in and disabled the onboard gaming port and the three reboots since have all resulted in success without any keyboard lock-ups. Woohoo! I'll continue to monitor the situation through the next couple of weeks but for now I'm excited to be getting positive results on a more regular basis.

    Thanks for all the suggestions and I hope that this new info proves helpful for others with similar problems.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...