Acer Aspire 5715Z won't turn on

By emmatippett · 15 replies
Jan 26, 2010
  1. Hi All,

    I have an Acer Aspire 5715Z and when i press the power on button, it will turn the fan on, and seem to start booting up, but then nothing and turns off.

    There is nothing on the screen at all, infact I dont think the screen even lights up (and yes, I have checked for writing with a torch to make sure its not just the screen or video driver that has gone).

    The only light i get is the little power LED, no hard drive light or anything else and then it turns straight off.

    Any ideas how to fix this or what part i need to get to repair the problem please?


  2. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    I think there may be some hardware issues; but from the info you have given us I am unable to guess what it may be; I'll advise you to take it to Acer if its still under warranty.

    You can also try to see whether pressing ALT+F10 does anything (i doubt ACER recovery will work according the above info, but what the hell .. give it a try).
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    We have seen a number of similar Acer computers with power sockets detached from the system board, and such things as you describe result.
  4. emmatippett

    emmatippett TS Rookie Topic Starter

    Thanks for that... With regards warranty, thats a no go, it ran out ages back. The recovery bit wont work as the laptop never gets that far!

    When I turn the laptop on all I get is the fan firing up, the power light on, sometimes the HD light will flash on for a second and then after about 30 or so seconds it all turns off and nothing.

    This happens with it being plugged in and on battery only.

    Any ideas? Was thinking maybe Motherboard, but dont want to splash out on a new one to find it wasnt that part thats dodgy or to find its something I can fix.

  5. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Well as ray pointed out problems with regard to power socket detachment, check that out, if that doesn't work then it probably would be good idea to disconnect hdd/cd etc. and see does the display comes back, then reconnect each component one by one to find which may be causing this blackout (i am assuming it may not be motherboard)
  6. emmatippett

    emmatippett TS Rookie Topic Starter

    Done as suggested, removed all drives etc and still the same problem. I checked the power socket and its solid, couldnt see any obvious detachments etc.

    One other thing of note, when I do turn the computer on, i can feel and hear the harddrive powering up for a few seconds and the DVD drive wont open at all. Dont know if that helps at all.

    Pls any more ideas or suggestions as its driving me nuts now!
  7. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Well if you are still at it; you can get the cpu out and check it out as well
  8. PeterLaman

    PeterLaman TS Rookie

    Hi Emma, have you got a solution yet? I'm having the same problem here, also with a 5715Z, but mine is still under warranty, so I won't open it up myself. On another forum, it was suggested that some parts on the motherboards may have loosened up by a shock, or something like that. Could that be the case? In my case, the laptop worked fine yesterday evening, but it refuses to wake up today. I know my 5 year old son has taken it out of the drawer today. He's asleep now, but tomorrow, I'll ask whether he dropped it. Normally he is very careful, so I don't think that's the problem.

    Tomorrow morning I'll call Acer support and I'll report here what they have to say.
  9. emmatippett

    emmatippett TS Rookie Topic Starter

    Hi there,

    No i havent found a solution yet. But same as you, no dropping happened here and when I had a look inside the computer all seemed fine. No loose bits anywhere.

    I would really appreciate hearing what acer have to say on the issue and hopefully that will help with narrowing it down.

    Next step for me is going to be testing the CPU incase its thats.
  10. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Either CPU as i mentioned earlier or the board itself.
  11. emmatippett

    emmatippett TS Rookie Topic Starter

    yeah thanks for that, I am going to take the cpu off this afternoon and see what happens. Then if no joy with that, then I guess motherboard it is!! Eeeek, not replaced one of those before, is it hard?
  12. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    just log which cable goes to which socket/attachment so if you need to replace the motherboard that will be handy for you.
  13. emmatippett

    emmatippett TS Rookie Topic Starter

    will make sure i do notes and take photos too just to double make sure i get it all.
  14. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Alright then; best of luck
  15. emmatippett

    emmatippett TS Rookie Topic Starter

    ok removed the Processor and still nothing, so I guess its the motherboard that is at fault! Thanks for your help, I will try and get a replacement and fit it!!!
  16. PeterLaman

    PeterLaman TS Rookie

    I only got an "administrative" response: send it in (will cost me € 55) and they'll have a look. They say the machine's no longer under warranty. It's strange, since I saw 2 years on their website. A closer look showed, I landed on the Belgian website of Acer. However, I bought my Acer in the Netherlands, and the Dutch site says the warranty lasts 1 year... So do they make better computers for the Belgians????

    Anyway, I'm afraid this reply won't help you either. First, I'm gonna have a look inside the computer when I get home from work.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...