ADI 1981B integrated audio - soundmax installer will not complete

By MachineHead ยท 4 replies
Jun 25, 2009
  1. I am running an HP Compaq d220 MT w/ WindowsXP Professional. The onboard audio drivers were uninstalled by mistake. Now I can't get the installer to complete setup of the new drivers and software. Just as it hits 100% it halts and displays this error message: "Drivers not found! Please reboot and run this setup again"

    It does this every time I try it. I have tried many other versions of the Softpaq from the HP website and still it happens. I have an ADI 1981B Chipset, is there something I am missing? What can I do to get the installer to run completely?

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Go to Start->Settings->Control Panel->System->Hardware->Device Manager and delete those drivers that you know are bad.
    Then download the correct drivers.
    You might even want to download the drivers to another computer, and put them on a CD or Flash drive so they are ready when you delete the incorrectly installed software.
  3. MachineHead

    MachineHead TS Rookie Topic Starter

    Thank you for your reply RayBay,but that is not the problem. I DID go to the device manager and there are no drivers or anything. In fact, if I go to control panel and open sound devices, everything is grayed out and there is no devices listed. And I do have the driver/software installer(the proper one), it just won't complete installation. neither would any of the other ones I tried. Any thoughts?

  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Just about has to be a defective hardware component... some sort of problem is being detected. That is the usual cause for what you are describing.
    Have you tried downloading to another computer, then transferring the file with a CD copy or a flash drive.
  5. MachineHead

    MachineHead TS Rookie Topic Starter

    I did try that. no luck. I think I'm missing something. Is there something that the installer looks for before it will install? Controller? I don't know. But I think there's something else missing. I just can't fit all the pieces together.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...